Kategoria: Nowinki internetowe

Dostępny JingOS 0.9, dystrybucja dla tabletów.

Opublikowano wydanie dystrybucji JingOS 0.9, które zapewnia środowisko zoptymalizowane do instalacji na tabletach i laptopach z ekranem dotykowym. Projekt jest rozwijany przez chińską firmę Jingling Tech, mającą przedstawicielstwo w Kalifornii. Zespół deweloperów składa się z pracowników, którzy wcześniej pracowali w firmach Lenovo, Alibaba, Samsung, Canonical/Ubuntu i Trolltech. Rozmiar obrazu do instalacji wynosi 3 GB (x86_64). Osiągnięcia projektu są udostępniane na licencji […]

Wydanie OpenRGB 0.6, narzędzia do zarządzania urządzeniami z podświetleniem RGB.

Opublikowano nową wersję OpenRGB 0.6, darmowego narzędzia do zarządzania urządzeniami z podświetleniem RGB. Pakiet wspiera płyty główne ASUS, Gigabyte, ASRock i MSI z podsystemem RGB do podświetlania obudowy, moduły pamięci z podświetleniem od ASUS, Patriot, Corsair i HyperX, karty graficzne ASUS Aura/ROG, MSI GeForce, Sapphire Nitro i Gigabyte Aorus oraz różne kontrolery taśm LED (ThermalTake, Corsair, NZXT Hue+), […]

Dla języka D wprowadzono środowisko wykonawcze do programowania mikrosterowników

Dylan Graham zaprezentował lekkiego runtime'a LWDR do programowania w języku D mikrokontrolerów z systemem operacyjnym czasu rzeczywistego (RTOS). Aktualna wersja jest skierowana na mikrokontrolery ARM Cortex-M. Rozwój nie ma na celu pełnego pokrycia wszystkich możliwości D, ale zapewnia podstawowe narzędzia. Zarządzanie pamięcią odbywa się ręcznie (new/delete), zbieracz śmieci nie jest wdrożony, ale dostępnych jest szereg haków dla […]

Wydanie serwera aplikacji NGINX Unit 1.24.0

Wydano serwer aplikacji NGINX Unit 1.24, w ramach którego rozwijane jest rozwiązanie umożliwiające uruchamianie aplikacji webowych w różnych językach programowania (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js i Java). Pod kontrolą NGINX Unit może być jednocześnie uruchamianych kilka aplikacji w różnych językach programowania, a parametry uruchamiania można zmieniać dynamicznie bez konieczności edytowania plików konfiguracyjnych i restartu. Kod […]

Wydanie Electron 13.0.0, platformy do tworzenia aplikacji na bazie silnika Chromium

Opublikowano wersję platformy Electron 13.0.0, która oferuje samodzielny framework do tworzenia aplikacji użytkowych na kilka platform, oparty na komponentach Chromium, V8 i Node.js. Zmiana numeru wersji związana jest z aktualizacją do bazy kodu Chromium 91, platformy Node.js 14.16 oraz silnika JavaScript V8 9.1. Wśród zmian w nowym wydaniu: Dodano właściwość process.contextIsolated do określenia wykonania bieżącego […]

Wydanie biblioteki PCRE2 10.37

Wydano wydanie biblioteki PCRE2 10.37, oferującej zestaw funkcji w języku C z implementacją wyrażeń regularnych i mechanizmów dopasowywania wzorców (pattern matching) zbliżonych do składni i semantyki wyrażeń regularnych w języku Perl 5. PCRE2 stanowi przerobioną implementację oryginalnej biblioteki PCRE z niekompatybilnym API i rozszerzonymi możliwościami. Biblioteka została opracowana przez deweloperów serwera pocztowego Exim i jest rozpowszechniana […]

Microsoft wydał menedżer pakietów Windows Package Manager 1.0, podobny do apt i dnf

Firma Microsoft opublikowała wydanie menedżera pakietów Windows Package Manager 1.0 (winget), oferującego narzędzia do instalacji aplikacji z użyciem wiersza poleceń. Kod został napisany w języku C++ i jest rozpowszechniany na licencji MIT. Pakiety instalowane są z repozytorium, które jest wspierane przy udziale społeczności. W przeciwieństwie do instalacji programów z katalogu Microsoft Store, winget pozwala instalować aplikacje bez zbędnego marketingu i […]

Wydania menedżera pakietów Pacman 6.0 oraz instalatora Archinstall 2.2.0

Dostępne są nowe wydania menedżera pakietów Pacman 6.0.0 oraz instalatora Archinstall 2.2.0, stosowanych w dystrybucji Arch Linux. Główne zmiany w Pacman 6.0: Dodano wsparcie dla pobierania plików w wielu równoległych wątkach. Zrealizowano wyświetlanie linii z oznaczeniem postępu pobierania danych. Aby wyłączyć wskaźnik postępu w pacman.conf, można wskazać opcję „—noprogressbar”. Zapewnione zostało automatyczne pomijanie luster, w przypadku których […]

Otwarty kod serwisu sprawdzania haseł HaveIBeenPwned

Troy Hunt otworzył źródła serwisu sprawdzania skompromitowanych haseł „Have I Been Pwned?” (haveibeenpwned.com), który wykonuje sprawdzenie w bazie 11,2 miliarda kont, skradzionych w wyniku włamań do 538 stron internetowych. Początkowo o zamiarze otwarcia kodu projektu ogłoszono w sierpniu zeszłego roku, jednak proces się przedłużył i kod opublikowano dopiero teraz. Kod serwisu napisany jest w […]

Mozilla podsumowała plany dotyczące wsparcia w Firefox trzeciej wersji manifestu Chrome

Firma Mozilla opublikowała plan wdrożenia w Firefox trzeciej wersji manifestu Chrome, który definiuje dostępne dla dodatków możliwości i zasoby. Trzecia wersja manifestu została skrytykowana za zakłócenie działania wielu dodatków do blokowania niechcianych treści i zapewniania bezpieczeństwa. W Firefox zamierzają zrealizować prawie wszystkie możliwości i ograniczenia nowego manifestu, w tym deklaratywne API do filtrowania treści (declarativeNetRequest), […]

Protokół QUIC uzyskał status proponowanego standardu

Komitet IETF (Internet Engineering Task Force), zajmujący się rozwojem protokołów i architektury internetu, zakończył przygotowywanie RFC dla protokołu QUIC i opublikował powiązane z nim specyfikacje pod identyfikatorami RFC 8999 (właściwości protokołu niezależne od wersji), RFC 9000 (transport ponad UDP), RFC 9001 (szyfrowanie TLS kanału QUIC) oraz RFC 9002 (zarządzanie przeciążeniem i określanie utraty pakietów podczas przesyłania danych). […]

Firma Virtuozzo opublikowała dystrybucję VzLinux, która ma na celu zastąpienie CentOS 8

Firma Virtuozzo (dawniej jednostka firmy Parallels), rozwijająca oprogramowanie serwerowe do wirtualizacji oparte na projektach open source, rozpoczęła publiczne udostępnianie dystrybucji VzLinux, która wcześniej była wykorzystywana jako podstawowy system operacyjny dla rozwijanej przez firmę platformy wirtualizacji i różnych produktów komercyjnych. Od teraz VzLinux jest dostępny dla wszystkich chętnych i jest pozycjonowany jako substytut CentOS 8, gotowy do wdrożeń w pracy. Do pobrania […]

Kup niezawodny hosting stron z ochroną DDoS, serwery VPS VDS 🔥 Kup niezawodny hosting stron z ochroną DDoS, serwery VPS VDS - ProHoster