Lançamento do servidor http Lighttpd 1.4.65

Foi lançado o servidor http leve lighttpd 1.4.65, que tenta combinar alta performance, segurança, conformidade com padrões e flexibilidade de configuração. O lighttpd é adequado para uso em sistemas de alta carga e voltado para baixo consumo de memória e recursos de CPU. A nova versão apresenta 173 alterações. O código do projeto é escrito em linguagem C e distribuído sob a licença BSD.

Principais novidades:

  • Adicionada a compatibilidade com WebSocket sobre HTTP/2, além da implementação da RFC 8441, que descreve o mecanismo para iniciar o protocolo WebSockets em um único fluxo dentro da conexão HTTP/2.
  • Implementado um esquema de controle de prioridade estendido, permitindo que o cliente influencie a prioridade das respostas transmitidas (RFC 9218), além de gerenciar prioridades ao redirecionar solicitações. servidor Para o HTTP/2, fornecida a compatibilidade com o quadro PRIORITY_UPDATE.
  • Nas configurações lighttpd.conf, adicionada suporte a correspondências condicionais vinculadas ao início (=^) e ao final (=$) da linha. Essas verificações de string são significativamente mais rápidas que expressões regulares e são suficientes para muitas verificações simples.
  • No mod_webdav, adicionada suporte a operações PUT parciais (cobrindo parte dos dados através do cabeçalho Range). Para ativação, pode-se usar a opção ‘webdav.opts += (“partial-put-copy-modify” => “enable”).
  • No mod_accesslog, adicionada a opção ‘accesslog.escaping = ‘json’.
  • No mod_deflate, adicionada suporte para compilação com libdeflate.
  • A transmissão do corpo da requisição via HTTP/2 foi acelerada.
  • O valor do parâmetro server.max-keep-alive-requests foi alterado de 100 para 1000 por padrão.
  • Na lista de tipos MIME, ‘application/javascript’ foi substituído por ‘text/javascript’ (RFC 9239).

No futuro, será aplicada configurações de criptografia mais rigorosas para TLS e a desativação, por padrão, de criptografias obsoletas. A configuração CipherString será alterada de ‘HIGH’ para ‘EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384’. Além disso, a remoção de opções TLS obsoletas está planejada: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Além disso, a limpeza de mini-módulos continuará, que podem ser substituídos por uma implementação Lua mais flexível do mod_magnet. Em particular, os módulos mod_evasive, mod_secdownload, mod_uploadprogress e mod_usertrack estão programados para serem removidos.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster