Lançamento do OpenBSD 7.2

Foi apresentado o lançamento do sistema operacional livre e semelhante ao UNIX OpenBSD 7.2. O projeto OpenBSD foi fundado por Theo de Raadt em 1995 após um conflito com os desenvolvedores do NetBSD, que resultou na revogação do acesso de Theo ao repositório CVS do NetBSD. Após isso, Theo de Raadt e um grupo de colaboradores criaram um novo sistema operacional aberto baseado na árvore de código fonte do NetBSD, cujo principais objetivos de desenvolvimento foram portabilidade (suporte a 13 plataformas de hardware), padronização, funcionalidade correta, segurança proativa e recursos criptográficos integrados. O tamanho da imagem ISO de instalação completa do sistema básico OpenBSD 7.2 é de 556 MB.

Além do próprio sistema operacional, o projeto OpenBSD é conhecido por seus componentes, que se espalharam por outros sistemas e se estabeleceram como algumas das soluções mais seguras e de qualidade. Entre eles: LibreSSL (fork do OpenSSL), OpenSSH, filtro de pacotes PF, demônios de roteamento OpenBGPD e OpenOSPFD, servidor NTP OpenNTPD, servidor de e-mail OpenSMTPD, multiplexador de terminal de texto (semelhante ao GNU screen) tmux, demônio identd com implementação do protocolo IDENT, alternativa BSD do pacote GNU groff - mandoc, protocolo para a organização de sistemas tolerantes a falhas CARP (Common Address Redundancy Protocol), servidor http leve, utilitário de sincronização de arquivos OpenRSYNC.

Principais melhorias:

  • Foi aprimorado o suporte a sistemas baseados na arquitetura ARM, incluindo o suporte adicionado para chips ARM Apple M2 e Ampere Altra. O suporte para o laptop Lenovo ThinkPad x13s e outros dispositivos baseados no SoC Qualcomm Snapdragon 8cx Gen 3 (SC8280XP) foi incluído.
  • Foi adicionada a capacidade de inicializar no Oracle Cloud com o núcleo para ramdisk (bsd.rd) e núcleo para sistemas multiprocessados (bsd.mp).
  • Incluído o dispositivo kstat, que exporta estatísticas sobre o funcionamento do núcleo, que podem ser visualizadas pela utilidade kstat.
  • Para cada núcleo de processador com suporte a MPERF/APERF, foram implementados sensores de frequência da CPU. Com funcionamento a partir da bateria, o escalonamento da frequência da CPU é ativado com base na carga.
  • Em sistemas ARM64, foi adicionada o suporte inicial para modo de suspensão. O limite de CPUs suportados foi aumentado para 256. A possibilidade de alternar do console baseado em framebuffer (glass console) para o console baseado em porta serial (serial console) foi implementada.
  • O código para identificação do CPU 386sx/386dx, NexGen, Rise e dos antigos processadores Cyrix, lançados antes do chip Cyrix M2, foi removido.
  • Apoio a sistemas multiprocessados (SMP) foi aprimorado. Funções de limitação de largura de banda (rate limit), busca de entradas ARP e contadores de rotas foram transferidas para a categoria mp-safe. A possibilidade de execução paralela de operações, como reempacotamento de pacotes IPv4 e redirecionamento de pacotes IP, foi implementada. Foram adicionados bloqueios de soquetes, usando mutex, nas funções de processamento de pacotes UDP e IP. Chamadas de sistema kbind e pledge foram isentas de bloqueios. Bloqueios de soquetes UNIX, que atuam em nível de soquetes individuais, foram implementados.
  • A implementação do framework drm (Direct Rendering Manager) foi sincronizada com o núcleo Linux 5.15.69 (na versão anterior — 5.15.26). Suporte a chips Intel com base nas microarquiteturas Alder Lake e Raptor Lake foi adicionado ao driver inteldrm. O suporte a framebuffers não alinhados à borda da página de memória foi implementado (aplicados, por exemplo, no MacBook Pro 2021 de 14" e 16").
  • Melhorias foram feitas no hipervisor VMM. Suporte a manipuladores em espaço de usuário baseado em MMIO foi adicionado ao vmd. A emulação de portas de entrada/saída foi transferida para o espaço do usuário no vmm. Estruturas internas e interfaces em vmd, vmctl e vmm foram unificadas. A possibilidade de monitoramento máquinas virtuais por meio do SNMP AgentX, usando os parâmetros VM-MIB (RFC7666), foi adicionada.
  • A variável $rcexec nos scripts de inicialização rc.d foi substituída pela função rc_exec. Uma nova variável daemon_execdir foi adicionada, permitindo mudar o diretório antes de executar a função rc_exec. Um novo comando configtest para verificar a sintaxe da configuração foi adicionado ao rc.d e rcctl.
  • Foi incluída a utilidade ts, que adiciona a hora em que cada linha é recebida através da entrada padrão.
  • A opção "-f" foi adicionada à utilidade ps para agrupamento de processos em árvore, refletindo a relação entre processos pai e filhos.
  • Na utilidade openrsync, a opção "—contimeout" foi implementada para definir o timeout de estabelecimento de conexão.
  • Na utilidade pkg_add, o cache foi ativado por padrão, melhorando a operação com pacotes e garantindo a exibição de um indicador de progresso durante a transferência de dados.
  • No fdisk, o suporte a tabelas GPT e MBR foi melhorado, e avisos foram adicionados para o posicionamento inadequado de partições MBR e GPT.
  • O utilitário disklabel adicionou suporte à palavra-chave raid nos templates para alocação automática de partições com RAID. O suporte para edição de informações sobre a geometria do disco foi descontinuado. O suporte para os atributos ‘bs’ (tamanho do bloco de inicialização), ‘sb’ (tamanho do superbloco) e d[0-4] (dados do disco) foi descontinuado.
  • Foi adicionado ao diretório /usr/share/btrace uma coleção de scripts btrace úteis para rastreamento dinâmico e inspeção de aplicações.
  • A biblioteca de áudio sndio recebeu a função sio_flush para parar imediatamente a reprodução.
  • Incluiu a ferramenta llvm-profdata para trabalhar com dados de profilagem.
  • A utilidade wc teve a contagem de palavras acelerada.
  • Adicionado suporte para novo hardware, incluindo novos drivers:
    • aplaudio (sub-sistema de áudio da Apple).
    • aplmca (controlador MCA da Apple).
    • aplsart (Apple SART).
    • alpdc, apldchidev, apldckbd, apldcms, aplrtk (teclado e trackpad Apple M2).
    • qcgpio, qciic (controladores GPIO e GENI I2C para Qualcomm Snapdragon).
    • sfgpio, stfclock, stfpinctrl, stftemp (drivers para GPIO, temporizador e sensores das placas SiFive).
    • sxirintc (controlador de interrupções para chips Allwinner).
    • gpiorestart (driver para reinicialização via GPIO).
    • No ipmi, o suporte para sensores de energia foi expandido.
    • No ehci, foi adicionado suporte ao controlador utilizado em placas Marvell 3720.
  • No driver igc para adaptadores Ethernet gigabit Intel I225, foi incluído a aceleração de hardware para cálculo de checksums para IPv4, TCP e UDP. No driver ix para adaptadores Ethernet Intel 82598/82599/X540/X550, foi implementado suporte à aceleração de hardware para processamento de segmentos TCP (Large Receive Offloading), ativado pela opção tso no ifconfig.
  • No driver iwx, foi implementado suporte para chips Intel AX210/AX211 e ampliado o espectro de dispositivos sem fio detectáveis.
  • Adicionada a capacidade de boot a partir de partições de RAID de software 1 (softraid) em sistemas amd64, sparc64 e arm64.
  • No snmpd e xlock, foi implementada a separação de privilégios.
  • Nas funções bind e connect para sockets UNIX, foi garantida uma isolação baseada na chamada de sistema unveil.
  • Adicionada uma nova chamada de sistema ypconnect para criar um socket para conexão com servidor YP, utilizando o endereço IP do arquivo bloqueado ypbinding. No ypldap, foi adicionado o modo ‘local bind’, onde o socket RPC é vinculado à interface loopback para excluir conexões externas com o servidor.
  • Os programas hcpleased, mountd, nfsd, pflogd, resolvd, slaacd e unwind listados no catálogo /sbin foram adaptados para usar vinculação dinâmica, permitindo a aplicação de medidas de segurança adicionais a arquivos executáveis vinculados dinamicamente.
  • Na pilha de rede, foram implementadas chamadas de sistema sendmmsg e recvmmsg, que permitem, dentro de uma única chamada de sistema, enviar e ler várias mensagens que anteriormente exigiriam chamadas separadas sendmsg e recvmsg.
  • No filtro de pacotes pf, a manipulação de pacotes IGMP e ICMP6 MLD (Multicast Listener Discovery) foi alterada, permitindo o funcionamento com pacotes multicast de controle na configuração padrão. Foi implementada uma verificação mais rigorosa das mensagens IGMP/MLD.
  • No IPsec, a operação com certificados foi aprimorada. O iked teve sua compatibilidade melhorada com o OpenIKED. O comando ikectl show stats agora exibe estatísticas de conexões bem-sucedidas e com falha ao iked.
  • No bgpd, foi adicionado um filtro max-communities para limitar o número de comunidades permitidas, implementado o RFC 9234 (Prevenção e Detecção de Vazamento de Rota Usando Funções nas Mensagens UPDATE e OPEN), e há suporte completo para o RFC 7911 (Anúncio de Vários Caminhos no BGP). Hashtags estáticas foram substituídas por árvores RB para melhorar o desempenho em grandes sistemas. Foi adicionado um processo bgplgd realizando um servidor FastCGI, que fornece uma REST API para os comandos bgpctl.
  • No rpki-client, agora é permitido o uso de mais de um URI de CRL nos certificados, foi implementado um parâmetro skiplist para ignorar domínios, adicionada a capacidade de verificar ASPA (Autonomous System Provider Authorization) e arquivos sig, além da implementação do decodificador TAL (RFC 8630) e um fortalecimento nas verificações dos certificados EE, melhorando a compatibilidade com as especificações HTTP.
  • No snmpd, agora é permitido o uso de nomes de objetos em snmpd.conf, para além do OID. Houve a implementação de uma lista negra para excluir subárvores da saída. O suporte ao agente master foi adicionado à implementação do protocolo AgentX.
  • No httpd, foram sugeridas novas definições de tipos MIME.
  • A utilidade ftp foi adaptada para utilizar conexões processadas em modo não bloqueante usando ppoll.
  • No tmux ('multiplexador de terminal'), foi adicionada a possibilidade de usar ACL para gerenciar a conexão de vários usuários através de um único socket.
  • Os pacotes LibreSSL e OpenSSH foram atualizados. Uma visão detalhada das melhorias pode ser encontrada nas análises do LibreSSL 3.6.0 e OpenSSH 9.1.
  • O número de portas para a arquitetura AMD64 foi de 11451 (antes 11301), para a aarch64 — 11261 (antes 11081), para i386 — 10225 (antes 10136). Entre as versões de aplicativos nas portas:
    • Asterisk 16.28.0, 18.14.0 e 19.6.0
    • Audacity 2.4.2
    • CMake 3.24.2
    • Chromium 105.0.5195.125
    • Emacs 28.2
    • FFmpeg 4.4.2
    • GCC 8.4.0 e 11.2.0
    • GHC 9.2.4
    • GNOME 42.4
    • Go 1.19.1
    • JDK 8u342, 11.0.16 e 17.0.4
    • KDE Gear 22.08.1
    • KDE Frameworks 5.98.0
    • Krita 5.1.1
    • LLVM/Clang 13.0.0
    • LibreOffice 7.4.1.2
    • Lua 5.1.5, 5.2.4 e 5.3.6
    • MariaDB 10.9.3
    • Mono 6.12.0.182
    • Mozilla Firefox 105.0.1 e ESR 102.3.0
    • Mozilla Thunderbird 102.3.0
    • Mutt 2.2.7 e NeoMutt 20220429
    • Node.js 16.17.1
    • OCaml 4.12.1
    • OpenLDAP 2.6.3
    • PHP 7.4.30, 8.0.23 e 8.1.10
    • Postfix 3.7.2
    • PostgreSQL 14.5
    • Python 2.7.18, 3.9.14 e 3.10.7
    • Qt 5.15.6 e 6.3.1
    • R 4.2.1
    • Ruby 2.7.6, 3.0.4 e 3.1.2
    • Rust 1.63.0
    • SQLite 3.39.3
    • Shotcut 22.06.23
    • Sudo 1.9.11.2
    • Suricata 6.0.6
    • Tcl/Tk 8.5.19 e 8.6.12
    • TeX Live 2021
    • Vim 9.0.0192 e Neovim 0.7.2
    • Xfce 4.16
  • Componentes de terceiros foram atualizados, incluídos na OpenBSD 7.2:
    • A pilha gráfica Xenocara baseada no X.Org 7.7 com xserver 1.21.4 + patches, freetype 2.12.1, fontconfig 2.13.94, Mesa 22.1.7, xterm 372, xkeyboard-config 2.20, fonttosfnt 1.2.2.
    • LLVM/Clang 13.0.0 (+ patches)
    • GCC 4.2.1 (+ patches) e 3.3.6 (+ patches)
    • Perl 5.32.1 (+ patches)
    • NSD 4.6.0
    • Unbound 1.16.3
    • Ncurses 5.7
    • Binutils 2.17 (+ patches)
    • Gdb 6.3 (+ patch)
    • Awk 12.9.2022
    • Expat 2.4.9

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster