Servidor de email Mox 0.0.15 disponível

Foi lançado o projeto Mox 0.0.15, que desenvolve uma solução abrangente para garantir o funcionamento de servidores de email, incluindo todos os componentes necessários para o envio e recebimento de emails. São oferecidas implementações próprias dos servidores SMTP e IMAP4, um sistema de filtragem de conteúdo indesejado, além de interfaces web para administradores e usuários. O código do projeto é escrito na linguagem Go e é distribuído sob a licença MIT.

O objetivo do projeto é criar uma solução "tudo em um", que permita configurar facilmente um servidor de email funcional sem a necessidade de uma configuração trabalhosa e sem a necessidade de integração entre diferentes serviços e aplicativos isolados. Supõe-se que, devido às dificuldades de implantação e manutenção do email, servidores os consumidores preferem provedores de email centralizados, o que destrói a própria ideia do email como um serviço descentralizado, composto por múltiplos servidores de email próprios.

O Mox permite configurar um servidor de email seguro para seus domínios em 10 minutos, suportando a pilha de protocolos moderna e sem a necessidade de instalar dependências adicionais. A atualização do software no servidor de email se resume ao download de uma nova versão do mox e ao reinício. O recebimento e atualização certificados TLS são realizados automaticamente. Para configuração e execução de tarefas relacionadas à manutenção, pode-se usar a interface web, e para configurações avançadas, um arquivo de configuração é fornecido.

Para evitar problemas de segurança decorrentes do trabalho de baixo nível com a memória, é utilizada a linguagem Go no desenvolvimento. Para manter alta qualidade na base de código, são aplicados testes manuais e automatizados de compatibilidade com servidores e clientes de email populares, testes de unidade e fuzzing, além de documentação abrangente do código.

Principais recursos do Mox:

  • Suporte aos protocolos SMTP e IMAP4.
  • Uso de extensões SPF, DKIM e DMARC para identificação de domínios de email, confirmação de autoridade de envio e verificação de autenticidade das mensagens.
  • Monitoramento da reputação de hosts, domínios e remetentes. Uso de classificador bayesiano, DNSBL e listas cinzas para filtragem de mensagens indesejadas.
  • Suporte a extensões para o uso de Unicode e alfabetos nacionais em nomes e domínios.
  • Obtenção automática de certificados TLS em autoridades certificadoras que suportam o protocolo ACME, como o Let’s Encrypt.
  • Suporte a mecanismos DANE e MTA-STS para a criptografia de envios de entrada e saída sobre SMTP com a extensão STARTTLS.
  • Webmail incorporado para leitura e envio de e-mails através do navegador.
  • Interface web de administração incorporada para gerenciamento de domínios e contas, configuração de SPF/DKIM/DMARC/TLSRPT/MTA-STS, visualização de estatísticas e alteração de parâmetros do arquivo de configuração.
  • Disponibilidade de servidor http para servir arquivos estáticos e redirecionar requisições (proxy reverso).
  • Fornecimento de API HTTP/JSON para enviar/carregar mensagens e receber eventos relacionados à entrega.
  • Exportação de métricas para o sistema de monitoramento Prometheus.
  • Suporte a extensões para configuração automática de clientes de e-mail (DNS SRV, https://autoconfig.dominio, QR-code).

Entre as mudanças na nova versão:

  • Suporte adicionado a extensões IMAP:
    • NOTIFY (RFC 5465) para monitorar a chegada de mensagens,
    • UIDONLY (RFC 9586) para solicitar mensagens por UID para reduzir a carga no servidor.
    • MULTISEARCH (RFC 7203) para busca em caixas de mensagens,
    • PREVIEW (RFC 8970) para visualização rápida de mensagens,
    • REPLACE (RFC 8508) para substituição de conteúdo em rascunhos de mensagens,
    • MULTIAPPEND (RFC 3502) para adicionar várias mensagens de uma só vez,
    • METADATA (RFC 5464) para armazenamento de metadados,
    • INPROGRESS (RFC 9585) para transmissão de informações sobre o status de operações de longa duração,
    • NAMESPACE (RFC 2342) para definição de espaços de nomes de caixas de correio,
    • WITHIN (RFC 5032) para busca em intervalos de tempo,
    • CREATE-SPECIAL-USE (RFC 6154) para criação de caixas de correio especializadas, como "Caixa de Entrada" e "Enviados",
    • SAVEDATE (RFC 8514) para monitorar o tempo de salvamento de mensagens na caixa de correio.
  • Configuração adicionada para processar separadores "+" e "-" em endereços de e-mail (you+anything@example.com e you-anything@example.com).
  • Configuração adicionada para proibir a alteração de senha (apenas geração automática de uma senha forte).
  • Configuração adicionada para rejeitar entregas de entrada em caso de erros na transação SMTP.
  • No Webmail, adicionado um botão para baixar mensagens no formato eml ou mbox/maildir em arquivos zip/tgz/tar, além de botões para marcar a caixa de correio como lida e criar caixas de correio adicionais.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster