Foi publicado o lançamento do Issuerd 0.1.17 — servidores de gerenciamento de identidade e acesso (IAM), implementando os protocolos OpenID Connect e OAuth 2.x e compatível com a plataforma Keycloak em nível de modelo de dados e gerenciador REST API. Implementados SSO, MFA (TOTP, WebAuthn/passkeys), federação de usuários do LDAP e Kerberos/SPNEGO, login via provedores de identidade externos (OIDC, redes sociais), páginas de login com design personalizável e localização, configuração inicial declarativa em YAML na primeira execução. O servidor é escrito em Rust (código unsafe proibido em nível de atributos), distribuído sob a licença Apache 2.0 e fornecido como um único arquivo binário autossuficiente, que inclui o console administrativo e o console do usuário. Compilações são geradas para as plataformas Linux, Windows e macOS (amd64 e
arm64).
A característica chave do projeto é a verificação contínua da conformidade
com o conjunto oficial de testes da OpenID Foundation Conformance Suite (5.3.2). Os testes são realizados no CI para cada lançamento em um ambiente docker isolado. Os resultados modulares são armazenados no repositório, e o pacote completo de relatórios é anexado a
cada lançamento. O paridade com o Keycloak é monitorado por um conjunto de testes. Há planos para a certificação oficial.
Dentre os protocolos demandados em cenários com agentes de IA, foram implementados DPoP (RFC 9449, vinculação de token à chave de portador), troca de tokens (RFC 8693, limitação de escopos na troca de token) e CIBA (modo poll, confirmação de ações por um humano). Também são suportados PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), registro dinâmico de clientes (RFC 7591/7592), autorização de dispositivos (RFC 8628). A importação total de 100 mil usuários do MS Active Directory leva cerca de 30 segundos.
Fonte: opennet.ru
