Foi publicada a biblioteca nghttp3 1.0 com a implementação do protocolo HTTP/3

Está disponível o primeiro lançamento estável do projeto nghttp3, que desenvolve uma biblioteca em C com a implementação do protocolo HTTP/3. A versão da biblioteca para o protocolo HTTP/2, desenvolvida pelo mesmo projeto, é usada como base para o módulo mod_http2, que faz parte do servidor http Apache. As contribuições do projeto também são utilizadas na ferramenta Curl. O código da biblioteca é distribuído sob a licença MIT.

O padrão HTTP/3 define o uso do protocolo QUIC (Quick UDP Internet Connections) como transporte para o HTTP/2. O QUIC é uma camada sobre o protocolo UDP, que suporta a multiplexação de várias conexões e fornece métodos de criptografia equivalentes ao TLS/SSL. O protocolo foi criado em 2013 pela Google como uma alternativa à combinação TCP+TLS para a Web, abordando problemas de latência na instalação e negociação de conexões TCP, além de eliminar atrasos causados pela perda de pacotes durante a transferência de dados.

No nghttp3, é fornecida uma implementação independente das especificações RFC 9114 (HTTP/3 sobre o protocolo QUIC), RFC 920 (tecnologia de compressão de cabeçalhos QPACK), RFC 9220 (transmissão de WebSockets sobre HTTP/3) e RFC 9218 (esquema extensível para gerenciamento de prioridades no envio de respostas a solicitações do cliente). A biblioteca não depende de pilhas QUIC específicas e suporta funcionamento sobre diferentes implementações do protocolo de transporte QUIC. O projeto também está desenvolvendo sua própria implementação do protocolo QUIC — ngtcp2, que é aplicada por padrão. Para criptografia de dados no ngtcp2, são suportados quictls, GnuTLS, BoringSSL, Picotls e wolfSSL. Juntamente com o nghttp3 1.0, também foi lançado o primeiro release estável do ngtcp2 1.0.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster