Implementação dos algoritmos criptográficos GOST em Java

Foi publicada a biblioteca crypto-gost com implementação dos algoritmos criptográficos GOST em Java, sem dependências adicionais. Ao contrário da implementação dos algoritmos GOST da biblioteca Castle Bouncy Castle, o crypto-gost melhora a performance da criptografia com o algoritmo "Grilo", resolve problemas de segurança específicos e oferece wrappers simples que não requerem profundo conhecimento em criptografia. O código é fornecido sob uma licença permissiva própria, que permite distribuição, modificação e criação de obras derivadas sem restrições.

Algoritmos suportados:

  • GOST R 34.11-2012 (RFC 6986) — função de hash "Streebog" 256 e 512 bits.
  • GOST R 34.12-2015 — cifra de bloco "Grilo", chave de 256 bits.
  • GOST R 34.13-2015 — modos de criptografia CBC, CFB, CTR (GAMMA), OFB; inserção de autenticação (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — assinatura eletrônica 256 e 512 bits.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 e HMAC-Streebog-512).
  • MGM (Modo Galois Multilinear) — modo AEAD para Grilo (RFC 9058). Compatível com OpenSSL.
  • SCrypt (RFC 7914) — função de derivação de chave baseada em senha.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster