Lançamento do FreeBSD 12.3.

Foi lançado o FreeBSD 12.3, publicado para as arquiteturas amd64, i386, powerpc, powerpc64, powerpcspe, sparc64, armv6, armv7 e aarch64. Imagens para sistemas de virtualização (QCOW2, VHD, VMDK, raw) e ambientes em nuvem da Amazon EC2 também foram preparadas. O lançamento do FreeBSD 13.1 é esperado para a primavera de 2022.

Principais inovações:

  • Foi adicionado o script /etc/rc.final, que é executado na última etapa do trabalho após a finalização de todos os processos do usuário.
  • No pacote de filtragem ipfw, foi fornecido o comando dnctl para gerenciar as configurações do sistema de limitação de tráfego dummynet.
  • Foi adicionado o sysctl kern.crypto para gerenciar a subsistema de criptografia do núcleo, assim como o sysctl de depuração debug.uma_reclaim.
  • Foi adicionado o sysctl net.inet.tcp.tolerate_missing_ts, que permite pacotes TCP sem timestamps (opção timestamp, RFC 1323/RFC 7323).
  • Na versão GENERIC do núcleo para a arquitetura amd64, foi incluída a opção COMPAT_LINUXKPI e ativado o driver mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • No carregador, foi adicionada a capacidade de inicializar o sistema operacional a partir de um disco RAM, e também foi implementado suporte para opções ZFS com com.delphix:bookmark_written e com.datto:bookmark_v2.
  • Na biblioteca fetch, foi adicionada suporte para proxy FTP sobre HTTPS.
  • No gerenciador de pacotes pkg, para os comandos 'bootstrap' e 'add', foi implementada a flag '-r' para especificação do repositório. Garantido o uso de variáveis de ambiente do arquivo pkg.conf.
  • Na ferramenta growfs, agora é possível trabalhar com sistemas de arquivos montados em modo leitura e gravação.
  • Na ferramenta etcupdate, foi implementado um modo de reversão de alterações para restaurar um ou mais arquivos. Foi adicionada a flag '-D' para especificar o diretório-alvo. Garantido que a extração de dados utilize um diretório temporário e adicionada a manipulação de SIGINT.
  • Nas ferramentas freebsd-update e freebsd-version, foi adicionada a flag '-j' para suporte a ambientes jail.
  • A ferramenta cpuset agora pode ser usada em ambientes jail para alterar parâmetros de jail-filhos.
  • Na ferramenta cmp, foram adicionadas opções: '-b' (—print-bytes) para mostrar bytes diferentes, '-i' (—ignore-initial) para ignorar um número específico de bytes iniciais, '-n' (—bytes) para limitar a quantidade de bytes comparados.
  • Na ferramenta daemon, foi adicionada a flag '-H' para manipulação de SIGHUP e reabertura de arquivo, onde a saída é realizada (adicionado para suporte ao newsyslog).
  • Na ferramenta fstyp, ao especificar a flag '-l', foi garantido a identificação e exibição de sistemas de arquivos exFAT.
  • A ferramenta mergemaster agora trata links simbólicos durante o processo de atualização.
  • A ferramenta newsyslog agora inclui a flag "E" para desativar a rotação de logs vazios.
  • A ferramenta tcpdump agora permite a decodificação de pacotes nas interfaces pfsync.
  • Na ferramenta top, foi adicionada a opção de filtro "/" para mostrar apenas processos ou argumentos que correspondam à string fornecida.
  • O unzip agora suporta arquivos protegidos por senha.
  • Apoio aprimorado para hardware. Foram adicionados identificadores PCI para controladores AHCI ASMedia ASM116x e controladores I2C Intel Gemini Lake. Suporte implementado para adaptadores de rede Mikrotik 10/25G e placas de rede sem fio Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Um novo driver igc foi adicionado para controladores ethernet Intel I225 2.5G/1G/100MB/10MB.
  • O nó Netgraph ng_bridge foi adaptado para sistemas SMP. O nó ng_nat agora suporta CGN (Carrier Grade NAT, RFC 6598). Foi possibilitada a substituição do nó ng_source em qualquer parte da rede Netgraph.
  • No driver rctl, utilizado para limitação de recursos, foi adicionada a possibilidade de definir o limite de consumo de recursos para 0.
  • Na interface vlan, foi adicionada a suporte para priorização de tráfego e controle de largura de banda através do ALTQ.
  • Nos drivers amdtemp e amdsmn, foi implementado suporte para CPU Zen 3 "Vermeer" e APU Ryzen 4000 (Zen 2, "Renoir").
  • As versões dos aplicativos de terceiros que fazem parte do sistema base foram atualizadas: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. A ferramenta unzip foi sincronizada com a base de código do NetBSD.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster