Lançamento do OpenBSD 6.9

Foi lançada a versão do sistema operacional UNIX-like OpenBSD 6.9, que é uma versão livre e multiplataforma. Este é o 50º lançamento do projeto, que completará 26 anos este ano. O projeto OpenBSD foi fundado por Theo de Raadt em 1995 após um conflito com os desenvolvedores do NetBSD, que resultou no fechamento do acesso de Theo ao repositório CVS do NetBSD. Após isso, Theo de Raadt, junto com um grupo de colaboradores, criou um novo sistema operacional aberto com base na árvore de códigos fonte do NetBSD, com os principais objetivos de desenvolvimento sendo portabilidade (suporte a 13 plataformas de hardware), padronização, operação correta, segurança ativa e recursos criptográficos integrados. O tamanho da imagem ISO completa do sistema base OpenBSD 6.9 é de 544 MB.

Além do próprio sistema operacional, o projeto OpenBSD é conhecido por seus componentes, que se espalharam por outros sistemas e se estabeleceram como algumas das soluções mais seguras e de qualidade. Entre eles: LibreSSL (fork do OpenSSL), OpenSSH, filtro de pacotes PF, demônios de roteamento OpenBGPD e OpenOSPFD, servidor NTP OpenNTPD, servidor de e-mail OpenSMTPD, multiplexador de terminal de texto (semelhante ao GNU screen) tmux, demônio identd com implementação do protocolo IDENT, alternativa BSD do pacote GNU groff - mandoc, protocolo para a organização de sistemas tolerantes a falhas CARP (Common Address Redundancy Protocol), servidor http leve, utilitário de sincronização de arquivos OpenRSYNC.

Principais melhorias:

  • No driver softraid, foi adicionado o modo RAID1C com a implementação de RAID1 de software com criptografia de dados.
  • Foram incluídos dois novos processos em segundo plano — dhcpleased e resolvd, que trabalham junto com slaacd e unwind para a configuração automática das interfaces de rede e a resolução de nomes no DNS. No dhcpleased, foi implementado o protocolo DHCP para obtenção de endereços IP, enquanto o resolvd gerencia o conteúdo do resolv.conf com base nas informações sobre os servidores de nomes obtidas do dhcpleased, slaacd e drivers como o umb.
  • Foi adicionada a suporte inicial para dispositivos Apple com processador M1. Incluindo o reconhecimento dos núcleos arm64 Apple Icestorm/Firestorm e suporte para os chips sem fio BCM4378, utilizados no SoC Apple M1.
  • Foi melhorado o suporte para a plataforma powerpc64, desenvolvida para sistemas de 64 bits baseados nos processadores POWER8 e POWER9. Em comparação com a versão anterior, para powerpc64 foi implementado o suporte ao mecanismo de proteção RETGUARD, adicionado o driver astfb para o framebuffer Aspeed BMC, resolvidos problemas com os drivers radeondrm e amdgpu em sistemas com GPU AMD, foi adicionado à compilação do kernel para RAM disk a capacidade de inicialização pela rede, foi adicionado suporte para modos de economia de energia do CPU POWER9, foi adicionado suporte para exceções geradas durante operações com ponto flutuante e foi implementado suporte ao IPMI para sistemas PowerNV.
  • Para plataformas ARM64, é suportado CPU Cortex-A78AE, Cortex-X1 e Neoverse V1, implementadas variantes otimizadas para ARM64 das chamadas copyin, copyout e kcopy, adicionado o driver cryptox para suporte a extensões criptográficas ARMv8, bem como o driver smmu para RM System MMU com suporte a Guard Page. Melhorias foram feitas no suporte a dispositivos Raspberry Pi, Rock Pi N10, NanoPi e Pinebook Pro.
  • No driver video, foi adicionado o parâmetro sysctl kern.video.record, que, de forma análoga ao kern.audio.record, controla a habilitação da saída de uma imagem vazia ao tentar capturar vídeo (para a resolução de captura, é necessário alterar o valor para 1). Os processos agora podem abrir o dispositivo video várias vezes (resolvendo problemas com o uso de webcams no Firefox e BigBlueButton).
  • Foram adicionados pontos de rastreamento para chamadas malloc e free, permitindo que, com dt e btrace, se monitore a atividade relacionada à alocação de memória. No btrace, foi adicionada a opção '-n' para analisar o programa sem executar quaisquer ações.
  • Apoio a sistemas multiprocessadores (SMP) foi aprimorado. A implementação de sockets UNIX foi desmembrada do bloqueio geral do núcleo, um mutex compartilhado foi adicionado para serializar operações com msgbuf, a chamada uvm_pagealloc foi convertida para mp-safe, e chamadas como getppid e sendsyslog foram liberadas de bloqueios.
  • Foram resolvidos problemas em componentes DRM (Direct Rendering Manager), incluindo falhas no driver radeondrm em sistemas Powerbook5/6 e RV350, a compatibilidade com DRI3 foi estabelecida em drivers amdgpu e ati, e a criação de dispositivos foi implementada no diretório /dev/dri/ para compatibilidade com o Linux.
  • Foram feitas melhorias no hipervisor VMM. No backend para gerenciar máquinas virtuais, vmd agora suporta a inicialização a partir de discos RAM compactados.
  • A subsistema de áudio foi aprimorado. Agora é possível fixar dispositivos de áudio sndio apenas para reprodução e apenas para gravação. No sndiod, um filtro passa-baixa com resposta ao impulso finita (filtro FIR) de oitava ordem foi ativado, eliminando ruídos devido a sobreposições de espectros durante o re-amostragem. A função de redução automática de volume, quando um novo programa começa a reproduzir (autovolume), está desativada por padrão, com o nível de volume padrão definido em 127. O som de dispositivos alternativos, que diferem quanto à funcionalidade suportada pelo sndiod, é permitido misturar.
  • A montagem e instalação do depurador LLDB estão ativadas por padrão.
  • Adicionada suporte ao manipulador logger no rcctl, rc.subr e rc.d, permitindo a organização da saída de logs de processos em segundo plano, enviando dados para stdout/stderr.
  • Para touchpads, agora é possível configurar o layout dos botões através do wsconsctl. O wscons melhorou o tratamento de toques simultâneos.
  • Para dispositivos ARM64, foi implementada a possibilidade de usar APM para coletar dados sobre o consumo de energia e a carga da bateria. Para restringir o acesso do processo apmd ao sistema de arquivos, foi utilizada a chamada unveil.
  • Ampliado o suporte a hardware. Novos drivers foram adicionados, como acpige (para o tratamento de eventos ACPI, como pressionar o botão de energia), pchgpio (para controladores GPIO nas atuais Intel PCH), ujoy (para controladores de jogos) e uhidpp (para dispositivos Logitech HID++). Adicionado suporte para extensões AMD Vi e Intel VTD IOMMU para isolamento de dispositivos PCI e bloqueio de acesso incorreto à memória. Suporte adicionado para computadores Lynloong LM9002/9003 e LM9013. Foi adicionado suporte ACPI aos drivers pcamux e imxiic.
  • Melhorado o suporte a adaptadores de rede: mvpp (SFP+ e 10G para Ethernet Marvel Armada), mvneta (1000base-x e 2500base-x), mvsw (switches Marvel SOHO), rge (suporte Wake on LAN) e Netgear ProSecure UTM25. Para drivers wireless iwm, iwn e athn, foi adicionada a suporte RA (802.11n Tx Rate Adaptation). No stack wireless, foi aprimorada a seleção automática dos modos 11a/b/g/n/ac ao usar a interface de rede como ponto de acesso.
  • No stack de rede, foi implementado o driver veb (Virtual Ethernet Bridge). Suporte ao modo de monitoramento foi desenvolvido, onde pacotes que chegam na interface de rede não são passados para o stack de rede para processamento, mas podem ser analisados usando mecanismos de análise de tráfego, como BPF. Adicionado um novo tipo de interface de rede — etherbridge. Foi disponibilizada a possibilidade (comando route sourceaddr) de sobrescrever o endereço de origem para programas, contornando o algoritmo padrão de escolha de endereço. endereços IP Automaticamente, interfaces de rede são ativadas ao entrar no modo de autoconfiguração (AUTOCONF4 e AUTOCONF6).
  • O instalador agora fornece uma imagem comprimida de ram-disk (bsd.rd) em todas as plataformas que suportam essa inicialização.
  • Implementada a saída através do syslog de um aviso sobre o uso de substituição de formatação de string "%n" em printf.
  • No demon de roteamento OpenBGPD foi adicionada a suporte ao protocolo RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Para exibir as informações principais sobre as sessões RTR, foi adicionando o comando "bgpctl show rtr".
  • Foi realizada uma reestruturação do código do ospfd e ospf6d para sua unificação com outros demônios de roteamento e simplificação da manutenção. A suporte a interfaces de rede no modo ponto a ponto foi restabelecida.
  • No servidor HTTP embutido httpd, foram implementadas novas opções "location (found|notfound)" para verificar a existência de recursos.
  • Na utilidade rpki-client, foi adicionada a suporte ao protocolo RRDP (The RPKI Repository Delta Protocol, RFC 8182). Implementou-se a possibilidade de especificar mais de um URI no arquivo TAL.
  • Na utilidade dig, foi implementada a suporte ao RFC 8914 (Extended DNS Error) e RFC 8976 (ZONEMD).
  • No dhclient, foi adicionada a possibilidade de especificar opções nos arquivos hostname.if, utilizando as linhas "dhcp".
  • No demônio snmpd, foi implementado suporte completo à conversão de Trapv1 para Trapv2 (RFC 3584). Novas palavras-chave read, write e notify foram adicionadas ao snmpd.conf. Na utilidade snmp, foi implementada a suporte a enumerações SMI.
  • No resolvedor DNS unwind, foi adicionada a suporte ao DNS64 e à recepção de conexões via porta TCP.
  • Na utilidade ftp, foi adicionada a suporte a redirecionamentos permanentes (RFC 7538) e a possibilidade de enviar o cabeçalho If-Modified-Since ao enviar solicitações via HTTP/HTTPS.
  • No OpenSMTPD, foi adicionada a opção "-a" para realizar autenticação antes do envio de mensagens. As ferramentas de criptografia foram transferidas para usar a biblioteca libtls. Nos sockets de escuta para TLS, foi implementada a capacidade de configurar vários certificados, selecionados com base no nome de domínio (SNI).
  • No LibreSSL, foi adicionada a suporte ao protocolo DTLSv1.2. Foi implementada a possibilidade de compilar apenas a libtls (‘—enable-libtls-only’) sem libcrypto e libssl.
  • O pacote OpenSSH foi atualizado. Uma visão detalhada das melhorias pode ser vista aqui: OpenSSH 8.5, OpenSSH 8.6.
  • O número de ports para a arquitetura AMD64 foi de 11310, para aarch64 — 10943, para i386 — 10468. Entre as versões dos aplicativos nos ports: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 e ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Foram atualizados componentes de terceiros que fazem parte do OpenBSD 6.9:

    • O stack gráfico Xenocara baseado no X.Org 7.7 com xserver 1.20.10 + patches, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM\/Clang 10.0.1 (+ patches)
    • GCC 4.2.1 (+ patches) e 3.3.6 (+ patches)
    • Perl 5.32.1 (+ patches)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ patches)
    • Gdb 6.3 (+ patch)
    • Awk 18.12.2020
    • Expat 2.2.10

A nova canção "Vetera Novis" é lançada junto com o lançamento do OpenBSD 6.9.

Fonte: opennet.ru

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster