Categoria: Blog

Lançamento do OpenRGB 0.6, uma ferramenta para gerenciar dispositivos com retroiluminação RGB.

Foi publicado um novo lançamento do OpenRGB 0.6, uma ferramenta livre para gerenciar dispositivos com retroiluminação RGB. O pacote suporta placas-mãe ASUS, Gigabyte, ASRock e MSI com subsistema RGB para iluminação do gabinete, módulos de memória retroiluminados da ASUS, Patriot, Corsair e HyperX, placas gráficas ASUS Aura/ROG, MSI GeForce, Sapphire Nitro e Gigabyte Aorus, diversos controladores de tiras de LED (ThermalTake, Corsair, NZXT Hue+), […]

Para a linguagem D, apresentado runtime para programar microcontroladores

Dylan Graham apresentou um runtime leve LWDR para programação na linguagem D de microcontroladores equipados com sistemas operacionais em tempo real (RTOS). A versão atual é direcionada a microcontroladores ARM Cortex-M. O desenvolvimento não tem como objetivo cobrir todas as capacidades da linguagem D, mas oferece ferramentas básicas. A alocação de memória é feita manualmente (new / delete), o coletor de lixo não está implementado, mas existem diversos hooks para […]

Lançamento do servidor de aplicativos NGINX Unit 1.24.0

Foi lançado o servidor de aplicativos NGINX Unit 1.24, que aprimora a solução para executar aplicações web em diversas linguagens de programação (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js e Java). Sob o gerenciamento do NGINX Unit, várias aplicações em diferentes linguagens de programação podem ser executadas simultaneamente, com parâmetros de execução que podem ser alterados dinamicamente sem a necessidade de editar arquivos de configuração e reiniciar. Código […]

Lançamento do Electron 13.0.0, uma plataforma para criar aplicações com base no motor Chromium

Foi preparado o lançamento da plataforma Electron 13.0.0, que fornece um framework independente para o desenvolvimento de aplicações de usuário multiplataforma, utilizando componentes do Chromium, V8 e Node.js como base. A mudança significativa no número da versão está relacionada à atualização da base de código do Chromium 91, da plataforma Node.js 14.16 e do mecanismo JavaScript V8 9.1. Entre as alterações nesta nova versão: Adicionada a propriedade process.contextIsolated para determinar a execução do atual […]

Lançamento da biblioteca PCRE2 10.37

Saiu o lançamento da biblioteca PCRE2 10.37, que fornece um conjunto de funções em C com uma implementação de expressões regulares e ferramentas de correspondência de padrões (pattern matching), semelhantes em sintaxe e semântica às expressões regulares da linguagem Perl 5. O PCRE2 é uma reimplementação reestruturada da biblioteca original PCRE, com uma API incompatível e capacidades expandidas. A biblioteca é baseada nos desenvolvedores do servidor de e-mail Exim e é distribuída […]

A Microsoft lançou o gerenciador de pacotes Windows Package Manager 1.0, semelhante ao apt e dnf

A Microsoft publicou o lançamento do gerenciador de pacotes Windows Package Manager 1.0 (winget), que fornece ferramentas para instalação de aplicações via linha de comando. O código é escrito em C++ e distribuído sob a licença MIT. Os pacotes são instalados de um repositório, com o suporte da comunidade. Ao contrário da instalação de softwares através do catálogo do Microsoft Store, o winget permite instalar aplicações sem a necessidade de marketing adicional e […]

Lançamentos do gerenciador de pacotes Pacman 6.0 e do instalador Archinstall 2.2.0

Novas versões do gerenciador de pacotes Pacman 6.0.0 e do instalador Archinstall 2.2.0, utilizados na distribuição Arch Linux, estão disponíveis. As principais mudanças no Pacman 6.0 incluem: suporte à download de arquivos em várias threads simultâneas. Foi implementada uma linha de saída com a indicação do progresso do download. Para desabilitar o indicador de progresso, é possível especificar a opção "—noprogressbar" em pacman.conf. Omissão automática de espelhos ao acessá-los, pelos quais […]

O código do serviço de verificação de senhas HaveIBeenPwned foi aberto

Troy Hunt publicou o código-fonte do serviço de verificação de senhas comprometidas "Have I Been Pwned?" (haveibeenpwned.com), que verifica uma base de 11,2 bilhões de contas, comprometidas em decorrência de ataques a 538 sites. O anúncio da intenção de abrir o código do projeto foi feito em agosto do ano passado, mas o processo se arrastou e o código foi publicado apenas agora. O código do serviço é escrito em […]

Mozilla resumiu seus planos para suporte à terceira versão do manifesto do Chrome no Firefox

A Mozilla publicou um plano para implementar na Firefox a terceira versão do manifesto Chrome, que define as capacidades e recursos oferecidos aos complementos. A terceira versão do manifesto foi criticada por quebrar a funcionalidade de muitos complementos de bloqueio de conteúdo indesejado e de segurança. A Firefox pretende implementar quase todas as capacidades e restrições do novo manifesto, incluindo a API declarativa para filtragem de conteúdo (declarativeNetRequest), […]

O protocolo QUIC recebeu o status de padrão proposto

O Comitê IETF (Internet Engineering Task Force), responsável pelo desenvolvimento de protocolos e arquitetura da internet, concluiu a formação do RFC para o protocolo QUIC e publicou as especificações relacionadas sob os identificadores RFC 8999 (propriedades do protocolo independentes da versão), RFC 9000 (transporte sobre UDP), RFC 9001 (criptação TLS para o canal QUIC) e RFC 9002 (gerenciamento de sobrecarga e determinação de perda de pacotes durante a transmissão de dados). […]

A Virtuozzo publicou a distribuição VzLinux, direcionada à substituição do CentOS 8.

A Virtuozzo (an ex-division of Parallels) desenvolvedora de software de servidor para virtualização baseada em projetos abertos, iniciou a distribuição pública do VzLinux, que anteriormente era utilizado como o sistema operacional básico para a plataforma de virtualização desenvolvida pela empresa e vários produtos comerciais. A partir de agora, o VzLinux estará disponível para todos e se posiciona como uma alternativa ao CentOS 8, pronta para implementações em ambientes de trabalho. Para download […]

Lançamento da distribuição Simply Linux 9.1

A empresa Bazalt SPU anunciou o lançamento da distribuição Simply Linux 9.1, baseada na nona plataforma ALT. O produto é distribuído sob um contrato de licença que não transfere o direito de distribuição da distribuição, mas permite que tanto pessoas físicas quanto jurídicas usem o sistema sem restrições. A distribuição é fornecida em compilações para as arquiteturas x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) e pode […]

Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS 🔥 Compre hospedagem confiável para sites com proteção contra DDoS, servidores VPS VDS | ProHoster