{"id":111034,"date":"2023-10-22T09:10:35","date_gmt":"2023-10-22T07:10:35","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3"},"modified":"2023-10-22T09:10:35","modified_gmt":"2023-10-22T07:10:35","slug":"opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","status":"publish","type":"post","link":"https:\/\/prohoster.info\/pt\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","title":{"rendered":"Foi publicada a biblioteca nghttp3 1.0 com a implementa\u00e7\u00e3o do protocolo HTTP\/3","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Est\u00e1 dispon\u00edvel o primeiro lan\u00e7amento est\u00e1vel do projeto nghttp3, que desenvolve uma biblioteca em C com a implementa\u00e7\u00e3o do protocolo HTTP\/3. A vers\u00e3o da biblioteca para o protocolo HTTP\/2, desenvolvida pelo mesmo projeto, \u00e9 usada como base para o m\u00f3dulo mod_http2, que faz parte do servidor http Apache. As contribui\u00e7\u00f5es do projeto tamb\u00e9m s\u00e3o utilizadas na ferramenta Curl. O c\u00f3digo da biblioteca \u00e9 distribu\u00eddo sob a licen\u00e7a MIT.    <\/p>\n<p>O padr\u00e3o HTTP\/3 define o uso do protocolo QUIC (Quick UDP Internet Connections) como transporte para o HTTP\/2. O QUIC \u00e9 uma camada sobre o protocolo UDP, que suporta a multiplexa\u00e7\u00e3o de v\u00e1rias conex\u00f5es e fornece m\u00e9todos de criptografia equivalentes ao TLS\/SSL. O protocolo foi criado em 2013 pela Google como uma alternativa \u00e0 combina\u00e7\u00e3o TCP+TLS para a Web, abordando problemas de lat\u00eancia na instala\u00e7\u00e3o e negocia\u00e7\u00e3o de conex\u00f5es TCP, al\u00e9m de eliminar atrasos causados pela perda de pacotes durante a transfer\u00eancia de dados.           <\/p>\n<p>O nghttp3 oferece uma implementa\u00e7\u00e3o independente das especifica\u00e7\u00f5es RFC 9114 (HTTP\/3 sobre o protocolo QUIC), RFC 920 (tecnologia de compress\u00e3o de cabe\u00e7alhos QPACK), RFC 9220 (transmiss\u00e3o de WebSockets sobre HTTP\/3) e RFC 9218 (esquema extens\u00edvel para gerenciar prioridades de envio de respostas \u00e0s solicita\u00e7\u00f5es do cliente). A biblioteca \u00e9 independente de pilhas QUIC espec\u00edficas e suporta a opera\u00e7\u00e3o sobre diferentes implementa\u00e7\u00f5es do protocolo de transporte QUIC. Ao mesmo tempo, o projeto desenvolve sua pr\u00f3pria implementa\u00e7\u00e3o do protocolo QUIC \u2014 ngtcp2, que \u00e9 utilizada como padr\u00e3o. Como backends para criptografia de dados, o ngtcp2 suporta quictls, GnuTLS, BoringSSL, Picotls e wolfSSL. Juntamente com o nghttp3 1.0, foi lan\u00e7ado tamb\u00e9m a primeira vers\u00e3o est\u00e1vel do ngtcp2 1.0.<br \/>\n<br \/>Fonte: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=59973\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3. \u0420\u0430\u0437\u0432\u0438\u0432\u0430\u0435\u043c\u044b\u0439 \u0442\u0435\u043c \u0436\u0435 \u043f\u0440\u043e\u0435\u043a\u0442\u043e\u043c \u0432\u0430\u0440\u0438\u0430\u043d\u0442 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0434\u043b\u044f \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/2 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u0443\u0435\u0442\u0441\u044f \u0432 \u043a\u0430\u0447\u0435\u0441\u0442\u0432\u0435 \u043e\u0441\u043d\u043e\u0432\u044b \u043c\u043e\u0434\u0443\u043b\u044f mod_http2, \u0432\u0445\u043e\u0434\u044f\u0449\u0435\u0433\u043e \u0432 \u0441\u043e\u0441\u0442\u0430\u0432 http-\u0441\u0435\u0440\u0432\u0435\u0440\u0430 Apache. \u041d\u0430\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 \u0442\u0430\u043a\u0436\u0435 \u0437\u0430\u0434\u0435\u0439\u0441\u0442\u0432\u043e\u0432\u0430\u043d\u044b \u0432 \u0443\u0442\u0438\u043b\u0438\u0442\u0435 Curl. \u041a\u043e\u0434 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0440\u0430\u0441\u043f\u0440\u043e\u0441\u0442\u0440\u0430\u043d\u044f\u0435\u0442\u0441\u044f \u043f\u043e\u0434 \u043b\u0438\u0446\u0435\u043d\u0437\u0438\u0435\u0439 MIT. \u0421\u0442\u0430\u043d\u0434\u0430\u0440\u0442 HTTP\/3 \u043e\u043f\u0440\u0435\u0434\u0435\u043b\u044f\u0435\u0442 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u043d\u0438\u0435 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC (Quick [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111034","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/pt\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"pt_PT\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/pt\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47 Foi publicada a biblioteca nghttp3 1.0 com a implementa\u00e7\u00e3o do protocolo HTTP\/3 | ProHoster","description":"Est\u00e1 dispon\u00edvel o primeiro lan\u00e7amento est\u00e1vel do projeto nghttp3, que desenvolve uma biblioteca em C com a implementa\u00e7\u00e3o do protocolo HTTP\/3.","canonical_url":"https:\/\/prohoster.info\/pt\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"pt_PT","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster","og:description":"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.","og:url":"https:\/\/prohoster.info\/pt\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-10-22T07:10:35+00:00","article:modified_time":"2023-10-22T07:10:35+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts\/111034","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/comments?post=111034"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts\/111034\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/media?parent=111034"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/categories?post=111034"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/tags?post=111034"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}