{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/pt\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"O autor do GnuPG fundou o LibrePGP, um fork do padr\u00e3o OpenPGP","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Werner Koch, principal desenvolvedor e criador do projeto GnuPG (GNU Privacy Guard), fundou o projeto LibrePGP, focado no desenvolvimento de uma especifica\u00e7\u00e3o atualizada, alternativa ao padr\u00e3o OpenPGP. O fork foi criado em resposta a mudan\u00e7as planejadas pelo grupo de trabalho IETF para a pr\u00f3xima atualiza\u00e7\u00e3o da especifica\u00e7\u00e3o OpenPGP (RFC-4880) e que foram vistas por Koch como duvidosas em termos de manter compatibilidade e garantir seguran\u00e7a. Os desenvolvedores que apoiaram o fork, dos projetos GnuPG, RNP (implementa\u00e7\u00e3o OpenPGP do Thunderbird) e Gpg4win, temem que as mudan\u00e7as propostas possam ser prejudiciais para as implementa\u00e7\u00f5es existentes de aplicativos baseados em OpenPGP, cujos usu\u00e1rios esperam estabilidade na especifica\u00e7\u00e3o a longo prazo e n\u00e3o est\u00e3o dispostos a aceitar mudan\u00e7as que comprometam a compatibilidade.    <\/p>\n<p>O LibrePGP inclui melhorias \u00fateis, desenvolvidas nos \u00faltimos anos para uma futura vers\u00e3o da especifica\u00e7\u00e3o OpenPGP, mas exclui modifica\u00e7\u00f5es que impactam negativamente a compatibilidade. Por exemplo, em compara\u00e7\u00e3o com o padr\u00e3o atual RFC-4880, o LibrePGP adotou as seguintes funcionalidades:  <\/p>\n<ul>\n<li class=\"l\"> Suporte ao algoritmo de criptografia Camellia (RFC-5581),\n<li class=\"l\"> Extens\u00f5es ECC (Criptografia de Curva El\u00edptica) para OpenPGP (RFC-6637).\n<li class=\"l\"> Suporte obrigat\u00f3rio a hashes SHA2-256 (SHA-1 e MD5 foram considerados n\u00e3o recomendados, e a possibilidade de desencriptar dados sem verifica\u00e7\u00e3o de integridade foi_CLASSIFIED como completamente obsoleta).\n<li class=\"l\"> Aumento para 256 bits do tamanho do identificador (fingerprint).\n<li class=\"l\"> Suporte ao esquema de assinaturas digitais EdDSA e curvas el\u00edpticas BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 e X448.\n<li class=\"l\"> Suporte ao algoritmo CRYSTALS-Kyber, resistente a ataques de computadores qu\u00e2nticos.\n<li class=\"l\"> Suporte aos modos de criptografia autenticada OCB (Offset codebook mode).\n<li class=\"l\"> Implementa\u00e7\u00e3o da quinta vers\u00e3o do formato de assinaturas digitais com prote\u00e7\u00e3o de metadados.\n<li class=\"l\"> Suporte a subpacotes expandidos com assinaturas digitais.  <\/ul>\n<p>Principais pontos de cr\u00edtica \u00e0 nova especifica\u00e7\u00e3o OpenPGP:  <\/p>\n<ul>\n<li class=\"l\"> O grupo de trabalho IETF, em vez de uma atualiza\u00e7\u00e3o incremental gradual da especifica\u00e7\u00e3o, tentou reinventar o padr\u00e3o, realizando mudan\u00e7as significativas que comprometem a compatibilidade.\n<li class=\"l\"> Imposi\u00e7\u00e3o de suporte ao modo de criptografia sim\u00e9trica GCM (Galois\/Counter Mode), que \u00e9 dif\u00edcil de implementar corretamente, desconsiderando o modo OCB (Offset Codebook Mode), cujas patentes expiraram h\u00e1 alguns anos.\n<li class=\"l\"> Adi\u00e7\u00e3o de pacotes opcionais com preenchimento aleat\u00f3rio adicional para prote\u00e7\u00e3o contra an\u00e1lise de tr\u00e1fego. De acordo com os criadores do LibrePGP, tais pacotes com preenchimento aleat\u00f3rio inicial n\u00e3o verific\u00e1vel criam uma amea\u00e7a de uso para a cria\u00e7\u00e3o de canais ocultos de transmiss\u00e3o de dados e para a evas\u00e3o de sistemas de preven\u00e7\u00e3o de vazamento de dados. Anteriormente, a ideia de incluir preenchimento adicional foi rejeitada por ser um assunto n\u00e3o do n\u00edvel de criptografia, mas do n\u00edvel de aplicativo.\n<li class=\"l\"> Aplica\u00e7\u00e3o de um esquema de criptografia ECDH modificado (mudan\u00e7a no formato OID), em vez do uso da vers\u00e3o j\u00e1 descrita no RFC-6637 e implementada no PGP e GnuPG.\n<li class=\"l\"> Remo\u00e7\u00e3o de algumas funcionalidades pr\u00e1ticas, como o m\u00e9todo cl\u00e1ssico de revoga\u00e7\u00e3o de chaves, a flag &#171;m&#187; para marcar dados MIME e a flag &#171;t&#187; para separar dados textuais de bin\u00e1rios (a flag &#171;t&#187; foi substitu\u00edda pela flag &#171;u&#187; para texto em codifica\u00e7\u00e3o UTF-8).\n<li class=\"l\"> Recusa em incluir no novo formato de assinaturas a prote\u00e7\u00e3o dos metadados do arquivo assinado (por exemplo, \u00e9 poss\u00edvel alterar o nome do arquivo sem invalidar a assinatura).\n<li class=\"l\"> Capacidade duvidosa de adicionar &#171;salt&#187; \u00e0s assinaturas (Salted signature) para aumentar a prote\u00e7\u00e3o contra ataques de colis\u00e3o com um prefixo espec\u00edfico. O valor com sal pode ser usado como um canal oculto n\u00e3o desativ\u00e1vel para transmitir 32 bytes de dados na assinatura.\n<li class=\"l\"> Deslocamento do padr\u00e3o em dire\u00e7\u00e3o ao uso prim\u00e1rio para comunica\u00e7\u00e3o online, ignorando as necessidades de armazenamento de dados a longo prazo.  <\/ul>\n<p>Os defensores do OpenPGP j\u00e1 publicaram cr\u00edticas \u00e0 cr\u00edtica. Como resultado, se um compromisso n\u00e3o for alcan\u00e7ado, a divis\u00e3o pode levar ao aumento das incompatibilidades nas implementa\u00e7\u00f5es do OpenPGP\/LibrePGP. Para solucionar parcialmente esse problema, os desenvolvedores do OpenPGP fixaram a quinta vers\u00e3o do formato de assinaturas de modo compat\u00edvel com o LibrePGP e come\u00e7aram a trabalhar na sexta vers\u00e3o.<br \/>\n<br \/>Fonte: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/pt\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"pt_PT\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/pt\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47O autor do GnuPG fundou o LibrePGP, um fork do padr\u00e3o OpenPGP | ProHoster","description":"Werner Koch, principal desenvolvedor e criador do projeto GnuPG (GNU Privacy Guard), fundou o projeto LibrePGP, focado no desenvolvimento de uma especifica\u00e7\u00e3o atualizada, alternativa ao padr\u00e3o OpenPGP.","canonical_url":"https:\/\/prohoster.info\/pt\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"pt_PT","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/pt\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/pt\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}