A fost publicată biblioteca nghttp3 1.0 cu implementarea protocolului HTTP/3

A apărut prima versiune stabilă a proiectului nghttp3, care dezvoltă o bibliotecă în limbajul C cu implementarea protocolului HTTP/3. O variantă a bibliotecii, dezvoltată de același proiect pentru protocolul HTTP/2, este folosită ca bază pentru modulul mod_http2, ce face parte din serverul http Apache. Inovațiile proiectului sunt de asemenea utilizate în utilitarul Curl. Codul bibliotecii este distribuit sub licența MIT.

Standardul HTTP/3 definește utilizarea protocolului QUIC (Quick UDP Internet Connections) ca transport pentru HTTP/2. QUIC este o extensie a protocolului UDP, care suportă multiplexarea mai multor conexiuni și oferă metode de criptare echivalente cu cele TLS/SSL. Protocolul a fost creat în 2013 de Google ca o alternativă la combinația TCP+TLS pentru web, abordând problemele legate de timpul îndelungat de inițiere și negociere a conexiunilor în TCP și eliminând întârzierile cauzate de pierderile de pachete în procesul de transmitere a datelor.

În nghttp3 se oferă o implementare independentă a specificațiilor RFC 9114 (HTTP/3 peste protocolul QUIC), RFC 920 (tehnologie de compresie a antetelor QPACK), RFC 9220 (transmiterea WebSockets peste HTTP/3) și RFC 9218 (schema extensibilă pentru gestionarea priorităților în răspunsurile la cererile utilizatorului). Biblioteca nu depinde de anumite stive QUIC și suportă funcționarea peste diferite implementări ale protocolului de transport QUIC. Totodată, proiectul dezvoltă și propria implementare a protocolului QUIC — ngtcp2, utilizată implicit. Ca backend-uri pentru criptarea datelor în ngtcp2, sunt suportate quictls, GnuTLS, BoringSSL, Picotls și wolfSSL. Odată cu nghttp3 1.0 a fost publicată și prima versiune stabilă ngtcp2 1.0.

Sursa: opennet.ro

Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS 🔥 Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS | ProHoster