Implementarea algoritmilor criptografici ГОСТ în limbajul Java.

A fost publicată biblioteca crypto-gost cu implementarea algoritmilor criptografici GOST în limbajul Java, fără a necesita dependențe suplimentare. Spre deosebire de implementarea algoritmilor GOST din biblioteca Castle Bouncy Castle, în crypto-gost a fost îmbunătățită performanța criptării cu algoritmul „Cucurigu”, au fost rezolvate problemele de securitate și sunt oferite wrapper-e simple, care nu necesită cunoștințe profunde în criptografie. Codul este distribuit sub o licență proprie permisivă, care permite distribuirea, modificarea și crearea de lucrări derivate fără restricții.

Algoritmi suportați:

  • GOST R 34.11-2012 (RFC 6986) — funcția hash „Streebog” 256 și 512 biți.
  • GOST R 34.12-2015 — cifra de bloc „Cucurigu”, cheia de 256 biți.
  • GOST R 34.13-2015 — moduri de criptare CBC, CFB, CTR (GAMMA), OFB; inserție de tipul MAC (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — semnătură electronică 256 și 512 biți.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 și HMAC-Streebog-512).
  • MGM (Modul Galois Multilinear) — modul AEAD pentru Cucurigu (RFC 9058). Compatibil cu OpenSSL.
  • SCrypt (RFC 7914) — funcția de generare a cheilor bazată pe parolă.

Sursa: opennet.ro

Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS 🔥 Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS | ProHoster