A fost lansată versiunea FreeBSD 12.3, care a fost publicată pentru arhitecturile amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 și armv6, armv7 și aarch64. De asemenea, au fost pregătite imagini pentru sistemele de virtualizare (QCOW2, VHD, VMDK, raw) și medii cloud Amazon EC2. Versiunea FreeBSD 13.1 este așteptată în primăvara anului 2022.
Noutăți cheie:
- A fost adăugat scriptul /etc/rc.final, care este executat în ultima etapă a funcționării, după finalizarea tuturor proceselor utilizatorului.
- Pachetul de filtre ipfw oferă comanda dnctl pentru gestionarea setărilor sistemului de limitare a traficului dummynet.
- A fost adăugat sysctl kern.crypto pentru gestionarea subsistemului criptografic din nucleu, precum și sysctl de depanare debug.uma_reclaim.
- A fost adăugat sysctl net.inet.tcp.tolerate_missing_ts, care permite pachete TCP fără timpi de marcă (opțiunea timestamp, RFC 1323/RFC 7323).
- În nucleul GENERIC pentru arhitectura amd64 a fost inclusă opțiunea COMPAT_LINUXKPI și a fost activat driverul mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
- În încărcător a fost adăugată posibilitatea de a porni sistemul de operare din ram-disk, precum și suportul pentru opțiunile ZFS com.delphix:bookmark_written și com.datto:bookmark_v2.
- În biblioteca fetch a fost adăugat suport pentru proxy FTP peste HTTPS.
- În managerul de pachete pkg pentru comenzile "bootstrap" și "add" a fost implementat flagul "-r" pentru a specifica depozitul. S-a asigurat utilizarea variabilelor de mediu din fișierul pkg.conf.
- În utilitarul growfs a apărut posibilitatea de a lucra cu sistemele de fișiere montate în modul citire și scriere.
- În utilitarul etcupdate a fost implementat modul de revenire la modificări pentru a restaura unul sau mai multe fișiere. A fost adăugat flagul "-D" pentru a specifica directorul țintă. A fost asigurată extragerea datelor folosind un director temporar și a fost adăugată gestionarea SIGINT.
- În utilitarele freebsd-update și freebsd-version a fost adăugat flagul "-j" pentru a sprijini medii jail.
- Utilitarul cpuset poate fi acum utilizat în medii jail pentru a modifica parametrii fiicelor jail.
- În utilitarul cmp au fost adăugate opțiuni: "-b" (—print-bytes) pentru a afișa byte-urile diferite, "-i" (—ignore-initial) pentru a ignora un număr specific de byte-uri inițiale, "-n" (—bytes) pentru a limita numărul de byte-uri comparate.
- În utilitarul daemon a apărut flagul "-H" pentru a gestiona SIGHUP și a redeschide fișierul în care se efectuează ieșirea (adăugat pentru suportul newsyslog).
- În utilitarul fstyp, la specificarea flagului "-l", s-a asigurat identificarea și afișarea sistemelor de fișiere exFAT.
- În utilitarul mergemaster a fost implementată gestionarea link-urilor simbolice în procesul de actualizare.
- Utilitarul newsyslog a primit un flag „E” pentru a dezactiva rotația fișierelor de jurnal goale.
- În utilitarul tcpdump a apărut posibilitatea de decodare a pachetelor pe interfețele pfsync.
- În utilitarul top s-a adăugat comanda-filtru „/” pentru a afișa doar procesele sau argumentele corespunzătoare șirului specificat.
- În unzip a fost adăugată suport pentru arhivele protejate prin parolă.
- A fost îmbunătățit suportul hardware. Au fost adăugate identificatoare PCI pentru controlerele AHCI ASMedia ASM116x și controlerele I2C Intel Gemini Lake. A fost implementat suportul pentru adaptatoarele de rețea Mikrotik 10/25G și plăcile wireless Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. A fost adăugat un nou driver igc pentru controlerele ethernet Intel I225 2.5G/1G/100MB/10MB.
- Nodele Netgraph ng_bridge au fost adaptate pentru sistemele SMP. În nodul ng_nat a fost adăugat suport pentru CGN (Carrier Grade NAT, RFC 6598). A fost oferită posibilitatea de a substitui nodul ng_source în orice parte a rețelei Netgraph.
- În driverul rctl, utilizat pentru limitarea resurselor, a fost adăugată posibilitatea de a stabili o limită a consumului de resurse la valoarea 0.
- În interfața vlan a fost adăugată suport pentru sistemul de prioritizare a traficului și gestionarea lățimii de bandă ALTQ.
- În driver-ele amdtemp și amdsmn a fost implementat suportul pentru CPU Zen 3 „Vermeer” și APU Ryzen 4000 (Zen 2, „Renoir”).
- Au fost actualizate versiunile aplicațiilor terțe incluse în sistemul de bază: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Utilitarul unzip a fost sincronizat cu baza de cod NetBSD.
Sursa: opennet.ro
