Categorie: Blog

Lansarea serverului de aplicații NGINX Unit 1.24.0

A fost lansat serverul de aplicații NGINX Unit 1.24, în cadrul căruia se dezvoltă o soluție pentru a rula aplicații web în diverse limbaje de programare (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js și Java). Sub administrarea NGINX Unit, mai multe aplicații în diferite limbaje de programare pot fi rulate simultan, iar parametrii de pornire pot fi modificați dinamic fără a fi necesară editarea fișierelor de configurare și repornirea. Codul […]

Lansarea Electron 13.0.0, platformă pentru crearea aplicațiilor bazate pe motorul Chromium

A fost pregătit release-ul platformei Electron 13.0.0, care oferă un framework autonom pentru dezvoltarea de aplicații utilizator multiplatformă, bazat pe componentele Chromium, V8 și Node.js. Schimbarea semnificativă a numărului versiunii este legată de actualizarea la baza de cod Chromium 91, platforma Node.js 14.16 și motorul JavaScript V8 9.1. Printre modificările din noul release se numără: Adăugarea proprietății process.contextIsolated pentru a determina execuția curentă […]

Lansarea bibliotecii PCRE2 10.37

A fost lansat release-ul bibliotecii PCRE2 10.37, care oferă un set de funcții în limbajul C cu implementarea expresiilor regulate și a mijloacelor de potrivire cu un model (pattern matching), asemănătoare ca sintaxă și semantică cu expresiile regulate din limbajul Perl 5. PCRE2 reprezintă o reformulare a bibliotecii originale PCRE cu un API incompatibil și funcționalități extinse. Biblioteca este bazată pe dezvoltatorii serverului poștal Exim și este distribuită […]

Microsoft a lansat Windows Package Manager 1.0, similar cu apt și dnf

Compania Microsoft a publicat lansarea managerului de pachete Windows Package Manager 1.0 (winget), care oferă instrumente pentru instalarea aplicațiilor folosind linia de comandă. Codul este scris în C++ și este distribuit sub licența MIT. Pachetele sunt instalate dintr-un depozit susținut cu ajutorul comunității. Spre deosebire de instalarea programelor din catalogul Microsoft Store, winget permite instalarea aplicațiilor fără marketing excesiv și […]

Lansările managerului de pachete Pacman 6.0 și al instalatorului Archinstall 2.2.0

Sunt disponibile noi lansări ale managerului de pachete Pacman 6.0.0 și al installer-ului Archinstall 2.2.0, utilizate în distribuția Arch Linux. Principalele modificări în Pacman 6.0: A fost adăugată suportul pentru descărcarea fișierelor în mai multe fluxuri paralele. A fost implementat un output cu o linie de indicare a progresului descărcării. Pentru a dezactiva indicatorul de progres în pacman.conf, se poate specifica opțiunea „—noprogressbar”. S-a asigurat ocolirea automată a mirror-urilor, atunci când se accesează […]

Codul serviciului de verificare a parolelor HaveIBeenPwned este deschis

Troy Hunt a deschis codul sursă al serviciului de verificare a parolelor compromise „Have I Been Pwned?” (haveibeenpwned.com), care verifică o bază de date de 11,2 miliarde de conturi furate în urma atacurilor asupra a 538 de site-uri. Inițial, a fost anunțat în august anul trecut planul de a deschide codul proiectului, dar procesul a durat și codul a fost publicat abia acum. Codul serviciului este scris în […]

Mozilla a rezumat planurile de suport pentru a treia versiune a manifestului Chrome în Firefox

Compania Mozilla a publicat un plan de implementare în Firefox a celei de-a treia versiuni a manifestului Chrome, care definește capabilitățile și resursele oferite extensiilor. Cea de-a treia versiune a manifestului a fost criticată din cauza afectării funcționării multor extensii pentru blocarea conținutului nedorit și asigurarea securității. În Firefox, se intenționează implementarea aproape tuturor capabilităților și limitărilor noului manifest, inclusiv API-ul declarativ pentru filtrarea conținutului (declarativeNetRequest), […]

Protocolul QUIC a obținut statutul de standard propus.

Comitetul IETF (Internet Engineering Task Force), responsabil de dezvoltarea protocoalelor și arhitecturii internetului, a finalizat formarea RFC pentru protocolul QUIC și a publicat specificațiile corespunzătoare cu identificatorii RFC 8999 (proprietăți nedependente de versiune ale protocolului), RFC 9000 (transport pe UDP), RFC 9001 (criptarea canalului de comunicație QUIC cu TLS) și RFC 9002 (gestionarea supraîncărcării și determinarea pierderii pachetelor la transmiterea datelor). […]

Compania Virtuozzo a publicat distribuția VzLinux, destinat să înlocuiască CentOS 8

Compania Virtuozzo (fostul departament al companiei Parallels), care dezvoltă software server pentru virtualizare pe baza proiectelor open source, a început distribuția publică a distribuției VzLinux, care a fost utilizată anterior ca sistem de operare de bază pentru platforma de virtualizare dezvoltată de companie și diferitele produse comerciale. De acum înainte, VzLinux este disponibil tuturor doritorilor și este poziționat ca o alternativă la CentOS 8, pregătit pentru implementări în producție. Pentru descărcare […]

Lansarea distribuției Simply Linux 9.1

Compania Bazalt SPO a anunțat lansarea distribuției Simply Linux 9.1, construită pe baza celei de-a noua platforme ALT. Produsul este distribuit în cadrul unui acord de licență care nu transferă dreptul de distribuire a distribuției, dar permite utilizarea sistemului fără restricții de către persoane fizice și juridice. Distribuția este disponibilă în pachete pentru arhitecturile x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) și poate […]

A fost publicată baza de date immudb 1.0, care asigură protecție împotriva distorsiunii datelor.

A fost lansată o versiune semnificativă a SGBD-ului immudb 1.0, care garantează imuabilitatea și păstrarea tuturor datelor adăugate vreodată, oferind, de asemenea, protecție împotriva modificărilor retroactive și posibilitatea unei dovezi criptografice a deținerii datelor. Inițial, proiectul a fost dezvoltat ca un depozit NoSQL specializat, manipulând date în format cheie/valoare, dar începând cu versiunea 1.0, immudb se pozicionează ca un SGBD complet cu suport SQL. Cod […]

Este disponibil distribuția AlmaLinux 8.4, care continuă dezvoltarea CentOS 8

A fost lansată versiunea distribuției AlmaLinux 8.4, sincronizată cu distribuția Red Hat Enterprise Linux 8.4. Pachetele sunt pregătite pentru arhitectura x86_64 sub formă de imagine de boot (709 MB), imagine minimă (1.9 GB) și imagine completă (9.8 GB). În curând, vor fi publicate și pachete pentru arhitectura ARM. Distribuția este considerată pregătită pentru implementări de producție și este complet identică cu RHEL în ceea ce privește funcționalitatea, pentru […]

Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS 🔥 Cumpără un hosting fiabil pentru site-uri cu protecție DDoS, servere VPS VDS | ProHoster