{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/ro\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Lansarea OpenSSL 3.2.0 cu suport pentru protocolul QUIC","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Dup\u0103 opt luni de dezvoltare, a fost lansat\u0103 versiunea bibliotecii OpenSSL 3.2.0 cu implementarea protocoalelor SSL\/TLS \u0219i a diferitelor algoritmi de criptare. Suportul pentru OpenSSL 3.2 va fi asigurat p\u00e2n\u0103 pe 23 noiembrie 2025. Suportul pentru versiunile anterioare OpenSSL 3.1 \u0219i 3.0 LTS va dura p\u00e2n\u0103 \u00een martie 2025 \u0219i respectiv septembrie 2026. Suportul pentru versiunea 1.1.1 s-a \u00eencheiat \u00een septembrie anul acesta. Codul proiectului este distribuit sub licen\u021ba Apache 2.0.    <\/p>\n<p>Principalele nout\u0103\u021bi OpenSSL 3.2.0:   <\/p>\n<ul>\n<li class=\"l\"> A fost ad\u0103ugat\u0103 suportul client pentru protocolul QUIC (RFC 9000), utilizat ca transport \u00een protocolul HTTP\/3. Implementarea include, printre altele, capacitatea de a transmite mai multe fluxuri printr-un singur canal de comunicare. Componentele pentru utilizarea QUIC pe <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/ro\/server\/dts-gdansk\/\"   title=\"servere\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">servere<\/a> vor fi incluse \u00een lansarea OpenSSL 3.3, care se preconizeaz\u0103 a fi publicat\u0103 cel t\u00e2rziu p\u00e2n\u0103 pe 30 aprilie 2024.\n<p>QUIC reprezint\u0103 un strat deasupra protocolului UDP, sus\u021bin\u00e2nd multiplexarea mai multor conexiuni \u0219i oferind metode de criptare echivalente cu TLS\/SSL. Protocolul a fost creat \u00een 2013 de c\u0103tre Google ca o alternativ\u0103 la combina\u021bia TCP+TLS pentru web, rezolv\u00e2nd problemele cu timpul lung de stabilire \u0219i negociere a conexiunilor \u00een TCP \u0219i elimin\u00e2nd \u00eent\u00e2rzierile cauzate de pierderea pachetelor \u00een timpul transmisiei de date.       <\/p>\n<li class=\"l\"> \u00cen TLS a fost implementat suportul pentru extensia de compresie a certificatelor \u00een etapa de negociere a conexiunilor (RFC 8879), care permite accelerarea stabilirii conexiunii, deoarece transferul de date ale certificatelor reprezint\u0103 o mare parte din traficul din etapa de negociere a conexiunii. Se sus\u021bine compresia utiliz\u00e2nd bibliotecile zlib, zstd \u0219i Brotli.\n<li class=\"l\"> A fost ad\u0103ugat suportul pentru varianta deterministic\u0103 a semn\u0103turilor digitale ECDSA (Deterministic ECDSA, RFC 6979) \u00een care, \u00een locul unei secven\u021be aleatorii, la generarea semn\u0103turii se utilizeaz\u0103 hash-ul HMAC-SHA256 al cheii private \u0219i al textului mesajului semnat, ceea ce permite ob\u021binerea \u00eentotdeauna a acelea\u0219i semn\u0103turi \u00een opera\u021biuni diferite de semnare, dar nu permite scurgerea de date care ar putea fi folosite pentru a descoperi cheia privat\u0103 (cheia privat\u0103 poate fi descoperit\u0103 dac\u0103 cel pu\u021bin dou\u0103 semn\u0103turi pentru date diferite sunt generate prin utilizarea unei secven\u021be aleatorii repetitive).\n<li class=\"l\"> A fost ad\u0103ugat suportul pentru variantele extinse de semn\u0103turi digitale cu cheie public\u0103 Ed25519 \u0219i Ed448: Ed25519ctx, Ed25519ph \u0219i Ed448ph (RFC 8032).\n<li class=\"l\"> A fost ad\u0103ugat suport pentru modul de criptare AES-GCM-SIV (RFC 8452), care combin\u0103 performan\u021ba ridicat\u0103 a modului GCM (Galois\/Counter Mode) cu rezisten\u021ba la scurgerile de informa\u021bii \u00een cazul reutiliz\u0103rii unui cod nonce aleator.\n<li class=\"l\"> A fost implementat\u0103 func\u021bia de generare a cheii Argon2 (RFC 9106), c\u00e2\u0219tig\u0103toare a concursului de func\u021bii de hashing pentru parole \u00een 2015. A fost ad\u0103ugat\u0103 op\u021biunea de utilizare a unui pool de fire.\n<li class=\"l\"> A fost ad\u0103ugat suport pentru criptarea hibrid\u0103 bazat\u0103 pe mecanismul HPKE (Hybrid Public Key Encryption, RFC 9180), care combin\u0103 u\u0219urin\u021ba transmit\u0103rii cheii \u00een criptarea cu cheie public\u0103 cu performan\u021ba ridicat\u0103 a cript\u0103rii simetrice (informa\u021biile sunt criptate cu o cheie simetric\u0103 rapid\u0103, iar cheia \u00een sine este criptat\u0103 asimetric, lent).\n<li class=\"l\"> TLS a implementat posibilitatea utiliz\u0103rii cheilor publice \u201eraw\u201d (neprocesate) (RFC 7250).\n<li class=\"l\"> A fost ad\u0103ugat suport pentru mecanismul de deschidere rapid\u0103 a conexiunilor TCP (TFO \u2014 TCP Fast Open, RFC 7413), care reduce num\u0103rul de pa\u0219i necesari pentru stabilirea conexiunii, prin combinarea primelor dou\u0103 etape ale procesului clasic de negociere \u00een unul singur \u0219i permite trimiterea de date \u00een etapa ini\u021bial\u0103 a stabilirii conexiunii.\n<li class=\"l\"> \u00cen TLS a fost implementat suport pentru schemele de semn\u0103turi digitale plug-in, care permit utilizarea unor implement\u0103ri externe ale algoritmilor, de exemplu, pentru utilizarea \u00een TLS a algoritmilor rezisten\u021bi la atacuri cu calculatoare cuantice.\n<li class=\"l\"> \u00cen TLS 1.3 a fost ad\u0103ugat suport pentru curbele eliptice protejate Brainpool.\n<li class=\"l\"> A fost ad\u0103ugat suport pentru instruc\u021biuni procesor SM4-XTS.\n<li class=\"l\"> Pe platforma Windows a fost implementat\u0103 posibilitatea utiliz\u0103rii depozitului de certificate r\u0103d\u0103cin\u0103 al sistemului (deactivat \u00een mod implicit). Pentru accesarea certificatelor din depozitul Windows, este propus URI \u201eorg.openssl.winstore:\/\/\u201d.     <\/ul>\n<p>Sursa: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ro<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.2 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/ro\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.2\" \/>\n\t\t<meta property=\"og:locale\" content=\"ro_RO\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/ro\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Lansare OpenSSL 3.2.0 cu suport client pentru protocolul QUIC | ProHoster","description":"Dup\u0103 opt luni de dezvoltare, a fost formatat release-ul bibliotecii OpenSSL 3.2.0 cu implementarea protocoalelor SSL\/TLS \u0219i a diferitelor algoritme de criptare. Suportul pentru OpenSSL 3.2 va fi men\u021binut p\u00e2n\u0103 la 23 noiembrie 2025.","canonical_url":"https:\/\/prohoster.info\/ro\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"ro_RO","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/ro\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/ro\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}