Publikovaná knižnica crypto-gost s implementáciou kryptografických algoritmov GOST v jazyku Java, ktorá nepoužíva žiadne externé závislosti. Na rozdiel od implementácie algoritmov GOST z knižnice Castle Bouncy Castle, má crypto-gost zvýšený výkon šifrovania algoritmom „Kukloč“, vyriešila sa konkrétna bezpečnostná problematika a poskytujú sa jednoduché obálky, ktoré nevyžadujú hlboké znalosti v kryptografii. Kód je dodávaný pod vlastnou povolenou licenciou, ktorá umožňuje distribúciu, modifikáciu a vytváranie odvozených diel bez obmedzení.
Podporované algoritmy:
- GOST R 34.11-2012 (RFC 6986) — hash funkcia „Stribog“ 256 a 512 bitov.
- GOST R 34.12-2015 — blokový šifrovací algoritmus „Kukloč“, kľúč 256 bitov.
- GOST R 34.13-2015 — režimy šifrovania CBC, CFB, CTR (GAMMA), OFB; autentifikácia (CMAC).
- GOST R 34.10-2012 (RFC 7091) — elektronický podpis 256 a 512 bitov.
- HMAC-Stribog (RFC 7836, HMAC-Streebog-256 a HMAC-Streebog-512).
- MGM (Multilinear Galois Mode) — AEAD-režim pre Kukloč (RFC 9058). Kompatibilný s OpenSSL.
- SCrypt (RFC 7914) — funkcia vytvárania kľúča na základe hesla.
Zdroj: opennet.ru
