Vydanie OpenSSH 8.5

Po piatich mesiacoch vývoja bol predstavený release OpenSSH 8.5, otvorenej implementácie klienta a servera pre prácu s protokolmi SSH 2.0 a SFTP.

Vývojári OpenSSH pripomenuli nadchádzajúci prechod do kategórie zastaraných algoritmov, ktoré používajú hash SHA-1, v súvislosti so zvyšovaním účinnosti kolíznych útokov s daným prefixom (náklady na nájdenie kolízie sú odhadované na približne 50 tisíc dolárov). V jednom z najbližších vydaní plánujú predvolene vypnúť používanie algoritmu digitálnych podpisov verejným kľúčom „ssh-rsa“, ktorý je spomínaný v pôvodnom RFC pre protokol SSH a zostáva široko rozšírený v praxi.

Na overenie implementácie ssh-rsa vo svojich systémoch môžete skúsiť pripojiť sa cez ssh s voľbou „-oHostKeyAlgorithms=-ssh-rsa“. Vypnutie digitálnych podpisov „ssh-rsa“ predvolene neznamená úplný zákaz používania RSA-kľúčov, pretože okrem SHA-1 protokol SSH umožňuje používanie aj iných algoritmov výpočtu hash. Konkrétne, okrem „ssh-rsa“ zostane možnosť použitia dvojíc „rsa-sha2-256“ (RSA/SHA256) a „rsa-sha2-512“ (RSA/SHA512).

Na zmiernenie prechodu na nové algoritmy je v OpenSSH 8.5 predvolene zapnutá nastavenie UpdateHostKeys, ktoré umožňuje automaticky previesť klientov na bezpečnejšie algoritmy. Pomocou tohto nastavenia sa aktivuje špeciálne rozšírenie protokolu „hostkeys@openssh.com“, ktoré umožňuje serveru po autentifikácii informovať klienta o všetkých dostupných kľúčoch hostiteľa. Klient môže tieto kľúče odrážať vo svojom súbore ~/.ssh/known_hosts, čo umožňuje organizovať aktualizáciu kľúčov hostiteľa a zjednodušuje výmenu kľúčov na serveri.

Používanie UpdateHostKeys je obmedzené niekoľkými podmienkami, ktoré môžu byť v budúcnosti zrušené: kľúč musí byť uvedený v UserKnownHostsFile a nesmie byť používaný v GlobalKnownHostsFile; kľúč musí byť prítomný len pod jedným menom; nesmie byť použitý certifikát hostiteľského kľúča; v known_hosts nesmú byť použité masky podľa názvu hostiteľa; musí byť vypnuté nastavenie VerifyHostKeyDNS; parametre UserKnownHostsFile musia byť aktívne.

Medzi odporúčanými algoritmami na migráciu sú spomenuté rsa-sha2-256/512 na báze RFC8332 RSA SHA-2 (podporované od OpenSSH 7.2 a používané ako predvolené), ssh-ed25519 (podporované od OpenSSH 6.5) a ecdsa-sha2-nistp256/384/521 na báze RFC5656 ECDSA (podporované od OpenSSH 5.7).

Ďalšie zmeny:

  • Zmeny týkajúce sa bezpečnosti:
    • V ssh-agente bola odstránená zraniteľnosť spôsobená opätovným uvoľnením už uvoľnenej oblasti pamäte (double-free). Problém sa prejavuje od vydania OpenSSH 8.2 a potenciálne môže byť zneužitý pri prístupe útočníka k soketu ssh-agenta na lokálnom systéme. Exploatáciu komplikuje to, že prístup k soketu majú len root a pôvodný používateľ. Najpravdepodobnejším scenárom útoku je presmerovanie agenta na účet, ktorý je pod kontrolou útočníka, alebo na hosť, na ktorom má útočník root-prístup.
    • V sshd bola pridaná ochrana pred prenosom veľmi veľkých parametrov s menom používateľa do podsystemu PAM, čo umožňuje zablokovať zraniteľnosti v systémových moduloch PAM (Pluggable Authentication Module). Napríklad zmena umožňuje zabrániť použitiu sshd ako vektoru pre zneužitie nedávno zistenou root-zraniteľnosťou v Solaris (CVE-2020-14871).
  • Zmeny potenciálne narušujúce kompatibilitu:
    • V ssh a sshd bol prerobený experimentálny spôsob výmeny kľúčov, odolný voči skúmaniu na kvantovom počítači. Kvantové počítače dramaticky rýchlejšie riešia úlohu rozkladu prirodzeného čísla na prvočísla, ktorá je základom moderných asymetrických šifrovacích algoritmov a efektívne je neriesiteľná na klasických procesoroch. Použitý spôsob je založený na algoritme NTRU Prime, vyvinutom pre postkvantové kryptosystémy, a metóde výmeny kľúčov na báze eliptických kriviek X25519. Namiesto sntrup4591761x25519-sha512@tinyssh.org je metóda teraz identifikovaná ako sntrup761x25519-sha512@openssh.com (algoritmus sntrup4591761 bol nahradený sntrup761).
    • V ssh a sshd bol zmenený poriadok oznámenia podporovaných algoritmov digitálnych podpisov. Prvý sa teraz ponúka ED25519 namiesto ECDSA.
    • V ssh a sshd sa nastavenie parametrov kvality služby TOS/DSCP pre interaktívne relácie teraz vykonáva pred vytvorením TCP-pripojenia.
    • V ssh a sshd bola zastavená podpora šifry rijndael-cbc@lysator.liu.se, ktorá je identická s aes256-cbc a používala sa pred schválením RFC-4253.
    • Predvolene je vypnutá možnosť CheckHostIP, ktorej prínos je zanedbateľný, ale jej použitie výrazne komplikuje rotáciu kľúčov pre hostitelia za vyrovnávacími záťažami.
  • Do sshd boli pridané nastavenia PerSourceMaxStartups a PerSourceNetBlockSize na obmedzenie intenzity spúšťania spracovateľov v súvislosti s adresou klienta. Tieto parametre umožňujú jemne riadiť obmedzenia spúšťania procesov v porovnaní s celkovým nastavením MaxStartups.
  • Do ssh a sshd bola pridaná nová možnosť LogVerbose, ktorá umožňuje nútiť zvýšiť úroveň zaznamenávanej ladenia do logu s možnostnosťou filtrovania podľa vzorov, funkcií a súborov.
  • Pri akceptovaní nového hostiteľského kľúča v ssh je zabezpečené zobrazenie všetkých mien hostiteľov a IP adresy, ktoré sú s kľúčom spojené.
  • V ssh je povolené určiť možnosť UserKnownHostsFile=none na deaktiváciu používania súboru known_hosts pri identifikácii hostiteľských kľúčov.
  • V ssh_config pre ssh bola pridaná možnosť KnownHostsCommand, ktorá umožňuje získať údaje known_hosts z výstupu uvedenej príkazu.
  • V ssh_config pre ssh bola pridaná možnosť PermitRemoteOpen, ktorá umožňuje obmedziť cieľ pri používaní možnosti RemoteForward s SOCKS.
  • V ssh sú pre kľúče FIDO zabezpečené opakované požiadavky na PIN v prípade zlyhania operácie s digitálnym podpisom z dôvodu nesprávneho PIN a absence požiadavky na PIN od používateľa (napríklad keď sa nepodarilo získať správne biometrické údaje a zariadenie preplo na manuálne zadanie PIN-u).
  • V sshd bola do mechanizmu izolácie procesu založeného na seccomp-bpf na platforme Linux pridaná podpora ďalších systémových volaní.
  • Nástroj contrib/ssh-copy-id bol aktualizovaný.

Zdroj: opennet.ru

Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster