Uvoľnenie FreeBSD 12.3

Bol spustený FreeBSD 12.3, ktorý je zverejnený pre architektúry amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 a armv6, armv7 a aarch64. Navyše sú pripravené obrazy pre virtualizačné systémy (QCOW2, VHD, VMDK, raw) a cloudové prostredia Amazon EC2. Uvoľnenie FreeBSD 13.1 sa očakáva na jar 2022.

Kľúčové novinky:

  • Pridaný skript /etc/rc.final, ktorý sa spúšťa na poslednej fáze prevádzky po ukončení všetkých používateľských procesov.
  • V paketovom filtre ipfw je k dispozícii príkaz dnctl na správu nastavení systému obmedzenia prevádzky dummynet.
  • Pridaný sysctl kern.crypto na správu kryptosub systému jadra, ako aj ladicí sysctl debug.uma_reclaim.
  • Pridaný sysctl net.inet.tcp.tolerate_missing_ts, ktorý povoľuje TCP pakety bez časových pečiatok (možnosť timestamp, RFC 1323/RFC 7323).
  • V jadre GENERIC pre architektúru amd64 bola zahrnutá možnosť COMPAT_LINUXKPI a aktivovaný ovládač mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • Do bootloadera bola pridaná možnosť načítania operačného systému z RAM disku a implementovaná podpora ZFS možností com.delphix:bookmark_written a com.datto:bookmark_v2.
  • Do knižnice fetch bola pridaná podpora pre proxy FTP nad HTTPS.
  • V balíkovom manažéri pkg pre príkazy „bootstrap“ a „add“ bol implementovaný príznak „-r“ na určenie repozitára. Zabezpečené použitie premenných prostredia z súboru pkg.conf.
  • V utilite growfs sa objavila možnosť práce s súborovými systémami pripojenými v režime čítania a zápisu.
  • V utilite etcupdate sa implementoval režim návratu zmien na obnovenie jedného alebo viacerých súborov. Pridaný príznak „-D“ na určenie cieľového adresára. Zabezpečené získavanie údajov s použitím dočasného adresára a pridané spracovanie SIGINT.
  • Do utilít freebsd-update a freebsd-version bol pridaný príznak „-j“ na podporu jail prostredí.
  • Utilitu cpuset je teraz možné používať v jail prostrediach na zmenu parametrov podriadených jail.
  • Do utility cmp boli pridané možnosti: „-b“ (—print-bytes) na výstup odlišných bajtov, „-i“ (—ignore-initial) na ignorovanie určitého počtu počiatočných bajtov, „-n“ (—bytes) na obmedzenie počtu porovnávaných bajtov.
  • V utilite daemon sa objavil príznak „-H“ na spracovanie SIGHUP a opätovné otvorenie súboru, do ktorého sa zapisuje výstup (pridané na podporu newsyslog).
  • V utilite fstyp bola pri uvedení príznaku „-l“ zabezpečená identifikácia a zobrazenie súborových systémov exFAT.
  • Nástroj mergemaster implementoval spracovanie symbolických odkazov pri aktualizácii.
  • Do nástroja newsyslog bol pridaný prepínač „E“ na deaktiváciu rotácie prázdnych logov.
  • V nástroji tcpdump sa objavila možnosť dekódovania paketov na rozhraniach pfsync.
  • Do nástroja top bola pridaná príkazová filtrácia „/“ na zobrazenie iba procesov alebo argumentov zodpovedajúcich zadanému reťazcu.
  • Do unzip bola pridaná podpora archívov chránených heslom.
  • Bola vylepšená podpora hardvéru. Pridali sa identifikátory PCI zariadení pre AHCI ovládače ASMedia ASM116x a I2C ovládače Intel Gemini Lake. Implementovala sa podpora sieťových adaptérů Mikrotik 10/25G a bezdrôtových kariet Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Bol pridaný nový ovládač igc pre ethernet ovládače Intel I225 2.5G/1G/100MB/10MB.
  • Netgraph uzol ng_bridge bol prispôsobený pre SMP systémy. V uzle ng_nat bola pridaná podpora CGN (Carrier Grade NAT, RFC 6598). Poskytla sa možnosť substitúcie uzla ng_source v akejkoľvek časti Netgraph siete.
  • V ovládači rctl, ktorý sa používa na obmedzenie zdrojov, bola pridaná možnosť nastaviť obmedzenie spotreby zdrojov na hodnotu 0.
  • Do rozhrania vlan bola pridaná podpora systému prioritizácie prevádzky a riadenia šírky pásma ALTQ.
  • V ovládačoch amdtemp a amdsmn bola implementovaná podpora CPU Zen 3 „Vermeer“ a APU Ryzen 4000 (Zen 2, „Renoir“).
  • Boli aktualizované verzie prichádzajúcich v základnom systéme externých aplikácií: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Nástroj unzip bol synchronizovaný s kódovou základňou NetBSD.

Zdroj: opennet.ru

Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster