Vydanie http servera Lighttpd 1.4.65

Bol spustený ľahký http-server lighttpd 1.4.65, ktorý sa snaží skombinovať vysoký výkon, bezpečnosť, súlad so štandardmi a flexibilitu nastavenia. Lighttpd je vhodný pre použitie na vysoko zaťažených systémoch a zameriava sa na nízku spotrebu pamäte a CPU. V novej verzii bolo predstavených 173 zmien. Kód projektu je napísaný v jazyku C a je distribuovaný pod licenciou BSD.

Hlavné novinky:

  • Bol pridaný podpora WebSocket cez HTTP/2, a bol implementovaný RFC 8441, ktorý popisuje mechanizmus na spustenie protokolu WebSocket v jednom vlákne v rámci pripojenia HTTP/2.
  • Bola realizovaná rozšírená schéma správy priorít, ktorá umožňuje klientovi ovplyvniť prioritu prenášaných serverom odpovedí (RFC 9218), ako aj spravovať priority pri presmerovaní dotazov. Pre HTTP/2 je zabezpečená podpora rámca PRIORITY_UPDATE.
  • V nastaveniach lighttpd.conf bola pridaná podpora podmienených porovnaní s viazaním na začiatok (=^) a koniec (=$) reťazca. Takéto reťazcové kontroly sú oveľa rýchlejšie ako regulárne výrazy a sú dostatočné pre mnohé jednoduché kontroly.
  • V mod_webdav bola pridaná podpora čiastkových operácií PUT (zahŕňajúcich časť dát pomocou hlavičky Range). Pre zapnutie môžete použiť možnosť ‘webdav.opts += («partial-put-copy-modify’ => «enable»).
  • V mod_accesslog bola pridaná možnosť ‘accesslog.escaping = ‘json'’.
  • V mod_deflate bola pridaná podpora zostavenia s libdeflate.
  • Bol urýchlený prenos tela dotazu cez HTTP/2.
  • Hodnota parametra server.max-keep-alive-requests bola zmenená z 100 na 1000.
  • V zozname MIME typov bol „application/javascript“ nahradený za „text/javascript“ (RFC 9239).

Na budúce je naplánované uplatnenie prísnejších nastavení šifrovania pre TLS a predvolené vypnutie zastaraných šifrov. Nastavenie CipherString bude zmenené z hodnoty „HIGH“ na „EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384“. Sú tiež naplánované na odstránenie zastarané možnosti TLS: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Ďalej bude pokračovať čistenie mini-modulov, ktoré môžu byť nahradené flexibilnejšou realizáciou mod_magnet pomocou Lua. Konkrétne sa plánuje odstránenie modulov mod_evasive, mod_secdownload, mod_uploadprogress a mod_usertrack.

Zdroj: opennet.ru

Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster