Vydanie OpenBSD 6.9

Bol predstavený návrh voľnej multiplatformovej UNIX-ako operačného systému OpenBSD 6.9. Uvádza sa, že je to 50. vydanie projektu, ktorý tento rok oslávi 26 rokov. Projekt OpenBSD založil Theo de Raadt v roku 1995 po konflikte s vývojármi NetBSD, čo viedlo k tomu, že Theo stratil prístup k CVS repozitáru NetBSD. Následne Theo de Raadt so skupinou podobne zmýšľajúcich jednotlivcov vytvoril na základe zdrojového kódu NetBSD nový otvorený operačný systém, ktorého hlavné ciele vývoja boli prenositeľnosť (podporovaných je 13 hardvérových platforiem), štandardizácia, správne fungovanie, aktívna bezpečnosť a integrované kryptografické prostriedky. Veľkosť úplného inštalačného ISO obrazu základného systému OpenBSD 6.9 je 544 MB.

Okrem samotného operačného systému je projekt OpenBSD známy svojimi komponentmi, ktoré sa rozšírili do iných systémov a overili sa ako jedny z najbezpečnejších a kvalitných riešení. Medzi nimi sú: LibreSSL (fork OpenSSL), OpenSSH, paketový filter PF, demon routing OpenBGPD a OpenOSPFD, NTP server OpenNTPD, poštový server OpenSMTPD, multiplexor textového terminálu (podobný GNU screen) tmux, demon identd s implementáciou protokolu IDENT, BSDL alternatíva k balíku GNU groff — mandoc, protokol pre organizovanie odolných systémov CARP (Common Address Redundancy Protocol), ľahký http server, nástroj na synchronizáciu súborov OpenRSYNC.

Hlavné vylepšenia:

  • Do ovládača softraid bol pridaný režim RAID1C s implementáciou softvérového RAID1 s šifrovaním údajov.
  • Súčasťou sú dva nové pozadie procesy — dhcpleased a resolvd, ktoré spolupracujú so slaacd a unwind na automatickom nastavení sieťových rozhraní a určovaní mien v DNS. V dhcpleased je implementovaný protokol DHCP na získavanie IP adries, zatiaľ čo v resolvd je riadenie obsahu resolv.conf na základe údajov o menových serveroch získaných od dhcpleased, slaacd a ovládačov podobných umb.
  • Pridaná počiatočná podpora zariadení Apple s procesorom M1. Okrem toho bola implementovaná identifikácia arm64-jadier Apple Icestorm/Firestorm a pridaná podpora bezdrôtových čipov BCM4378, ktoré sa používajú v SoC Apple M1.
  • Zlepšená podpora platformy powerpc64, vyvíjanej pre 64-bitové systémy na báze procesorov POWER8 a POWER9. V porovnaní s predchádzajúcim vydaním pre powerpc64 bola implementovaná podpora ochranného mechanizmu RETGUARD, pridaný ovládač astfb pre framebuffer Aspeed BMC, vyriešené problémy s fungovaním ovládačov radeondrm a amdgpu na systémoch s GPU AMD, do zostáv jadra pre ramdisk bola pridaná možnosť sieťového zavádzania, pridaná podpora úsporných režimov CPU POWER9 a podpora výnimiek generovaných pri operáciách s plávajúcou čiarkou, implementovaná podpora IPMI pre systémy PowerNV.
  • Pre platformy ARM64 je zabezpečená podpora CPU Cortex-A78AE, Cortex-X1 a Neoverse V1, implementované optimalizované pre ARM64 varianty volaní copyin, copyout a kcopy, pridaný ovládač cryptox pre podporu kryptografických rozšírení ARMv8 a ovládač smmu pre RM System MMU s podporou Guard Page. Zlepšená podpora zariadení Raspberry Pi, Rock Pi N10, NanoPi a Pinebook Pro.
  • Do ovládača video bol pridaný sysctl-parametr kern.video.record, ktorý podobne ako kern.audio.record riadi aktiváciu výstupu prázdneho obrázka pri pokuse o zachytenie videa (pre povolenie zachytenia je potrebné zmeniť hodnotu na 1). Procesom je povolené opakované otváranie zariadenia video (rieši problémy s používaním webkamery vo Firefox a BigBlueButton).
  • Pridané sledovacie body pre volania malloc a free, ktoré umožňujú pomocou dt a btrace sledovať aktivitu spojenú s distribúciou pamäte. Do btrace bola pridaná možnosť '-n' pre parsovanie programu bez vykonávania akýchkoľvek akcií.
  • Vylepšená podpora viacerých procesorových systémov (SMP). Z celkovej blokády jadra bola vyvedená implementácia UNIX-socketov, pridaný spoločný mutex na serializáciu operácií s msgbuf, prevedený na úroveň mp-safe volanie uvm_pagealloc, zbavené blokád boli volania getppid a sendsyslog.
  • Opravené problémy v komponentoch DRM (Direct Rendering Manager), vrátane odstránenia pádu v ovládači radeondrm na systémoch Powerbook5/6 a RV350, zaistená podpora DRI3 v ovládačoch amdgpu a ati, pre kompatibilitu s Linuxom implementované vytváranie zariadení v adresári /dev/dri/.
  • Boli vykonané vylepšenia v hypervízore VMM. V backendu pre správu virtuálnych strojov vmd sa objavila podpora bootovania so skomprimovaných RAM-diskov.
  • Boli vykonané vylepšenia v zvukovej subsystéme. Poskytnutá možnosť samostatného priradenia zvukových zariadení sndio iba pre reprodukciu a iba pre nahrávanie. V sndiod bol použitý dolnofrekvenčný filter s konečnou impulznou charakteristikou (KIK-filter) ôsmeho radu, ktorý umožnil zbaviť sa šumov spôsobených prekrývaním spektrálnych oborov pri resamplingu. Predvolene je vypnutá funkcia automatického znižovania hlasitosti pri začiatku prehrávania novej aplikácie (autovolume), ako predvolená hodnota je nastavená úroveň hlasitosti 127. Povolené je mixovanie zvuku z alternatívnych zariadení, ktoré sa líšia úrovňou podporovanej funkčnosti v sndiod.
  • Predvolene je aktivovaná zostava a inštalácia debuggera LLDB.
  • Do rcctl, rc.subr a rc.d bola pridaná podpora spracovateľa logger, ktorý umožňuje organizovať výstup logov z pozadových procesov posielajúcich údaje do stdout/stderr.
  • Pre touchpady je poskytnutá možnosť nastaviť rozloženie tlačidiel cez wsconsctl. V wscons bola zlepšená správa súčasných dotykov.
  • Pre zariadenia ARM64 bola implementovaná možnosť používať APM na získanie údajov o spotrebe energie a stave batérie. Na obmedzenie prístupu procesu apmd k súborovému systému sa použil systémový systémový hovor unveil.
  • Bola rozšírená podpora hardvéru. Pridané nové ovládače acpige (na spracovanie udalostí ACPI, ako je stlačenie tlačidla napájania), pchgpio (pre GPIO ovládače, ktoré majú moderné Intel PCH), ujoy (pre herné ovládače), uhidpp (pre zariadenia Logitech HID++). Pridaná podpora pre rozšírenia AMD Vi a Intel VTD IOMMU na izoláciu PCI zariadení a blokovanie nesprávneho prístupu k pamäti. Pridaná podpora pre počítače Lynloong LM9002/9003 a LM9013. Do ovládačov pcamux a imxiic bola pridaná podpora ACPI.
  • Bola vylepšená podpora sieťových adaptérov: mvpp (SFP+ a 10G pre Marvel Armada Ethernet), mvneta (1000base-x a 2500base-x), mvsw (Marvel SOHO prepínače), rge (podpora Wake on LAN), Netgear ProSecure UTM25. Pre bezdrôtové ovládače iwm, iwn a athn bola pridaná podpora RA (802.11n Tx Rate Adaptation). V bezdrôtovej sieti boli zavedené automatický výber režimov 11a/b/g/n/ac pri použití sieťového rozhrania ako prístupového bodu.
  • V sieťovom zásobníku bol implementovaný ovládač veb (Virtuálny Ethernetový most). Bolo zavedené monitorovacie rozhranie, pri ktorom sa prichádzajúce pakety na sieťovom rozhraní neprenášajú do správy sieťového zásobníka, ale môžu sa na ne aplikovať mechanizmy analýzy sieťového prevádzky, ako napríklad BPF. Pridaný nový typ sieťových rozhraní — etherbridge. Bolo poskytnuté možnosť (príkaz route sourceaddr) pre definovanie zdrojovej adresy pre programy, mimo obvyklého algoritmu výberu adresy. IP adresy Bola zabezpečená automatická aktivácia sieťových rozhraní pri zapnutí režimu automatického nastavenia (AUTOCONF4 a AUTOCONF6).
  • V inštalátore bola realizovaná dodávka komprimovaného obrazu ram-disku (bsd.rd) na všetkých platformách, ktoré podporujú takýto typ bootovania.
  • Bola implementovaná výstupná správa cez syslog o použití formátu substitúcie v printf s reťazcom „%n“.
  • V démone smerovania OpenBGPD bola pridaná podpora pre protokol RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Pre zobrazenie základných informácií o RTR reláciách bola pridaná príkaz «bgpctl show rtr».
  • Prebehla reštrukturalizácia kódu ospfd a ospf6d s cieľom ich unifikácie s inými démonmi smerovania a zjednodušenia údržby. Bolo zavedené podporovanie sieťových rozhraní v režime bod-bod.
  • Vo vstavanom HTTP serveri httpd boli implementované nové možnosti «location (found|notfound)» na kontrolu existencie zdrojov.
  • Do utilitky rpki-client bola pridaná podpora pre protokol RRDP (The RPKI Repository Delta Protocol, RFC 8182). Bolo implementované určenie viacerých URI v súbore TAL.
  • Vo utilitke dig bola pridaná podpora RFC 8914 (Extended DNS Error) a RFC 8976 (ZONEMD).
  • V dhclient bola pridaná možnosť určovania volieb v súboroch hostname.if pomocou reťazcov «dhcp».
  • V démone snmpd bola implementovaná plná podpora pre konverziu Trapv1 na Trapv2 (RFC 3584). Do snmpd.conf boli pridané nové kľúčové slová read, write a notify. V utilitke snmp bola zavedená podpora pre výčty SMI.
  • V DNS rezolvery unwind bola pridaná podpora DNS64 a prijímania pripojení cez TCP port.
  • Vo utilitke ftp bola pridaná podpora pre trvalé presmerovania (RFC 7538) a možnosť odosielania hlavičky If-Modified-Since pri odosielaní žiadostí cez HTTP/HTTPS.
  • V OpenSMTPD bola pridaná voľba «-a» na vykonávanie autentifikácie pred odoslaním správy. Šifrovacie prostriedky boli prenesené na používanie knižnice libtls. V počúvajúcich soketoch pre TLS bola implementovaná možnosť nastavenia viacerých certifikátov, vyberaných v závislosti od mena domény (SNI).
  • V LibreSSL bola pridaná podpora pre protokol DTLSv1.2. Bolo implementované zostavenie iba libtls (‘—enable-libtls-only’) bez libcrypto a libssl.
  • Bol aktualizovaný balík OpenSSH. Podrobný prehľad vylepšení si môžete pozrieť tu: OpenSSH 8.5, OpenSSH 8.6.
  • Počet portov pre architektúru AMD64 dosiahol 11310, pre aarch64 — 10943, pre i386 — 10468. Medzi verziami aplikácií v portoch: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 a ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Boli aktualizované komponenty od tretích strán, ktoré sú súčasťou OpenBSD 6.9:

    • Grafický stack Xenocara založený na X.Org 7.7 s xserver 1.20.10 + opravy, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ opravy)
    • GCC 4.2.1 (+ opravy) a 3.3.6 (+ opravy)
    • Perl 5.32.1 (+ opravy)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ záplaty)
    • Gdb 6.3 (+ oprava)
    • Awk 18.12.2020
    • Expat 2.2.10

K vydaniu OpenBSD 6.9 je pripojená nová pieseň „Vetera Novis“.

Zdroj: opennet.ru

Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster