Kategória: Blog

Verzia Electron 13.0.0, platforma na tvorbu aplikácií založených na engíne Chromium

Bol spustený release platformy Electron 13.0.0, ktorá poskytuje samostatný rámec pre vývoj multiplatformových používateľských aplikácií, ktorý využíva komponenty Chromium, V8 a Node.js. Významná zmena čísla verzie súvisí s aktualizáciou na kódovú základňu Chromium 91, platformu Node.js 14.16 a JavaScriptový engine V8 9.1. Medzi zmenami v novej verzii: Pridaná vlastnosť process.contextIsolated na určenie vykonávania aktuálneho […]

Uvoľnenie knižnice PCRE2 10.37

Vyšiel release knižnice PCRE2 10.37, ktorá poskytuje súbor funkcií v jazyku C s implementáciou regulárnych výrazov a nástrojov na porovnávanie vzorov (pattern matching), podobných syntaxou a sémantikou k regulárnym výrazom jazyka Perl 5. PCRE2 predstavuje prepracovanú implementáciu pôvodnej knižnice PCRE s nekompatibilným API a rozšírenými možnosťami. Knižnica je založená na vývoji od tímu mailového servera Exim a distribuuje sa […]

Microsoft vydal balíčkový manažér Windows Package Manager 1.0, podobný apt a dnf.

Spoločnosť Microsoft zverejnila release balíčkového manažéra Windows Package Manager 1.0 (winget), ktorý poskytuje prostriedky na inštaláciu aplikácií pomocou príkazového riadku. Kód je napísaný v jazyku C++ a distribuuje sa pod licenciou MIT. Balíky sa inštalujú z repozitára, podporovaného v spolupráci s komunitou. Na rozdiel od inštalácie programov z katalógu Microsoft Store, winget umožňuje inštalovať aplikácie bez zbytočného marketingu a […]

Vydania balíčkového manažéra Pacman 6.0 a inštalátora Archinstall 2.2.0.

K dispozícii sú nové vydania balíčkového manažéra Pacman 6.0.0 a inštalátora Archinstall 2.2.0, ktoré sú aplikované v distribúcii Arch Linux. Hlavné zmeny v Pacman 6.0: Pridaná podpora na sťahovanie súborov v niekoľkých paralelných prúdoch. Implementované zobrazenie riadku s indikátorom pokroku sťahovania. Na vypnutie indikátora pokroku v pacman.conf je možné uviesť voľbu „—noprogressbar“. Zabezpečené automatické preskakovanie zrkadiel, pri prístupe k ktorým […]

Otvorený kód služby na kontrolu hesiel HaveIBeenPwned.

Troy Hunt otvoril zdrojové kódy služby na kontrolu skompromitovaných hesiel „Have I Been Pwned?“ (haveibeenpwned.com), ktorá vykonáva kontrolu na základe databázy 11,2 miliardy účtov ukradnutých pri hackerstvách 538 webových stránok. Pôvodne bol o úmysle sprístupniť kód projektu oznámené v auguste minulého roka, ale proces sa oneskoril a kód bol zverejnený až teraz. Kód služby je napísaný na […]

Mozilla zhrnula plány na podporu tretej verzie manifestu Chrome vo Firefox.

Spoločnosť Mozilla zverejnila plán implementácie tretej verzie manifestu Chrome vo Firefoxe, ktorý určuje možnosti a zdroje poskytované doplnkom. Tretia verzia manifestu bola predmetom kritiky kvôli narušeniu fungovania mnohých doplnkov na blokovanie nežiaducich obsahov a zabezpečenie. Vo Firefoxe majú v úmysle implementovať takmer všetky funkcie a obmedzenia nového manifestu, vrátane deklaratívneho API na filtrovanie obsahu (declarativeNetRequest), […]

Protokol QUIC získal status navrhovaného štandardu

Výbor IETF (Internet Engineering Task Force), ktorý sa zaoberá rozvojom protokolov a architektúry internetu, dokončil formovanie RFC pre protokol QUIC a zverejnil s ním súvisiace špecifikácie pod identifikátormi RFC 8999 (nezávislé od verzie vlastnosti protokolu), RFC 9000 (transport nad UDP), RFC 9001 (TLS-šifrovanie komunikačného kanála QUIC) a RFC 9002 (riadenie preťaženia a určovanie straty paketov pri prenosoch). […]

Spoločnosť Virtuozzo vydala distribúciu VzLinux, zameranú na náhradu CentOS 8

Spoločnosť Virtuozzo (bývalé oddelenie spoločnosti Parallels), vyvíjajúca serverový softvér na virtualizáciu na základe otvorených projektov, začala verejné šírenie distribúcie VzLinux, ktorá bola predtým používaná ako základný operačný systém pre platformu virtualizácie vyvíjanú spoločnosťou a rôzne komerčné produkty. Odteraz je VzLinux dostupný pre každého a je profilovaný ako náhrada za CentOS 8, pripravenú na pracovné nasadenia. Na stiahnutie […]

Vydanie distribúcie Simply Linux 9.1

Spoločnosť Bazalt SPO oznámila vydanie distribúcie Simply Linux 9.1, založenej na deviatej platforme ALT. Produkt sa distribuuje v rámci licenčnej zmluvy, ktorá neprenáša právo na distribúciu, ale umožňuje bez obmedzení používať systém fyzickým a právnickým osobám. Distribúcia je k dispozícii v zostavách pre architektúry x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) a môže […]

Bola zverejnená databázová sústava immudb 1.0, ktorá zabezpečuje ochranu pred skreslením dát.

Bol predstavený významný release databázového systému immudb 1.0, ktorý zaručuje nemennosť a uchovanie všetkých niekedy pridaných údajov, ako aj poskytuje ochranu proti spätným úpravám a umožňuje kryptografický dôkaz vlastníctva údajov. Projekt bol pôvodne vyvinutý ako špecializované NoSQL úložisko, manipulujúce s údajmi vo formáte kľúč/hodnota, ale od vydania 1.0 je immudb pozicionovaný ako plnohodnotný databázový systém s podporou SQL. Kód […]

Distribúcia AlmaLinux 8.4 je k dispozícii a pokračuje vo vývoji CentOS 8.

Bol predstavený release distribúcie AlmaLinux 8.4, synchrónneho s distribúciou Red Hat Enterprise Linux 8.4. Zostavy sú pripravené pre architektúru x86_64 vo forme bootovateľného (709 MB), minimálneho (1.9 GB) a kompletného obrazu (9.8 GB). V blízkej dobe sa plánuje aj zverejnenie zostáv pre architektúru ARM. Distribúcia je uznaná ako pripravená pre pracovné nasadenia a je úplne identická s RHEL z pohľadu funkčnosti, iba […]

Vydanie distribúcie Oracle Linux 8.4

Spoločnosť Oracle zverejnila release distribúcie Oracle Linux 8.4, vytvorenej na základe balíkovej základne Red Hat Enterprise Linux 8.4. Na stiahnutie bez obmedzení je k dispozícii inštalačný iso-obraz s veľkosťou 8.6 GB, pripravený pre architektúry x86_64 a ARM64 (aarch64). Pre Oracle Linux je otvorený neobmedzený a bezplatný prístup k yum-repozitáru s binárnymi aktualizáciami balíkov s opravami chýb (errata) a problémami […]

Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Kúpte si spoľahlivý hosting pre webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster