Kako začeti uporabljati uporabniški način v Linux

Uvod prevajalca: Ker različne vrste kontejnerjev postajajo pomemben del našega življenja, je lahko precej zanimivo in koristno spoznati tehnologije, s katerimi se je vse začelo. Nekatere od njih je še danes mogoče koristno uporabljati, vendar se jih ne spomnijo vsi (ali ne poznajo, če niso bili prisotni med njihovim hitrim razvojem). Ena takšnih tehnologij je uporabniški način. LinuxIzvirni avtor se je precej poglobil v raziskovanje, ugotavljal, katere stare prakse še delujejo in katere ne, ter sestavil nekaj takega kot vodnik po korakih, kako ustvariti svoj UML v 2k19. In ja, izvirnega avtorja smo povabili na Habr. Cadey, tako da če imate kakršna koli vprašanja - vprašajte v angleščini v komentarjih.

Kako začeti uporabljati uporabniški način v Linux

Uporabniški način v Linux - to je pravzaprav port jedra Linux na sebi. Ta način vam omogoča zagon polnopravnega jedra Linux kot uporabniški proces in ga razvijalci običajno uporabljajo za testiranje gonilnikov. Vendar pa je ta način uporaben tudi kot splošno orodje za izolacijo, podobno načelu delovanja virtualnih strojev. Ta način zagotavlja večjo izolacijo kot Docker, vendar manjšo kot polnopravni virtualni stroj, kot sta KVM ali Virtual Box.

Na splošno se uporabniški način morda zdi nenavadno in težko uporabno orodje, vendar ima svoje prednosti. Navsezadnje je polnopravno orodje. Linux- jedro, ki se izvaja kot neprivilegiran uporabnik. Ta funkcija omogoča zagon potencialno nezaupanja vredne kode brez kakršne koli grožnje za gostiteljski računalnik. In ker gre za polnopravno jedro, so njegovi procesi izolirani od gostiteljskega računalnika, kar pomeni procesi, ki se izvajajo v uporabniškem načinu, gostitelju ne bodo vidni. To ni podobno običajnemu vsebniku Docker, v tem primeru gostiteljski stroj vedno vidi procese znotraj skladišča. Poglejte ta delček pstreeja z enega od mojih strežnikov:

containerd─┬─containerd-shim─┬─tini─┬─dnsd───19*[{dnsd}]
           │                 │      └─s6-svscan───s6-supervise
           │                 └─10*[{containerd-shim}]
           ├─containerd-shim─┬─tini─┬─aerial───21*[{aerial}]
           │                 │      └─s6-svscan───s6-supervise
           │                 └─10*[{containerd-shim}]
           ├─containerd-shim─┬─tini─┬─s6-svscan───s6-supervise
           │                 │      └─surl
           │                 └─9*[{containerd-shim}]
           ├─containerd-shim─┬─tini─┬─h───13*[{h}]
           │                 │      └─s6-svscan───s6-supervise
           │                 └─10*[{containerd-shim}]
           ├─containerd-shim─┬─goproxy───14*[{goproxy}]
           │                 └─9*[{containerd-shim}]
           └─32*[{containerd}]

In to primerjajte z jedrnim ptreejem Linux v uporabniškem načinu:

linux─┬─5*[linux]
      └─slirp

Pri delu z Dockerjevimi vsebniki lahko vidim imena procesov, ki se izvajajo v gostujočem sistemu iz gostiteljskega sistema. Linux Uporabniški način ni mogoč. Kaj to pomeni? To pomeni, da orodja za spremljanje, ki delujejo prek revizijskega podsistema, Linux (Linuxpodsistemu za revidiranje) ne vidijo procesi, ki se izvajajo v gostujočem sistemu. Toda v nekaterih situacijah lahko ta funkcija postane dvorezen meč.

Na splošno je celotna spodnja objava zbirka raziskav in grobih poskusov doseganja želenega rezultata. Da sem to naredil, sem moral uporabiti različna starodavna orodja, prebrati izvorne kode jedra, intenzivno razhroščevati kodo, napisano v dneh, ko sem bil še v osnovni šoli, in se tudi ukvarjati z zgradbami Herokuja z uporabo posebne binarne datoteke, da sem našel orodja, ki sem jih potreboval. . Zaradi vsega tega dela so mi fantje na IRC-ju rekli, da sem čarovnik. Upam, da bo ta objava služila kot zanesljiva dokumentacija za nekoga, ki bo poskusil isto stvar z novejšimi jedri in različicami OS.

prilagoditev

prilagoditev Linux Uporabniški način se izvaja v več fazah:

  • namestitev odvisnosti od gostitelja;
  • prenos jedra Linux;
  • konfiguracija gradnje jedra;
  • sestavljanje jedra;
  • binarna namestitev;
  • konfiguriranje gostujočega datotečnega sistema;
  • izbira parametrov zagona jedra;
  • vzpostavitev mreže za goste;
  • zagon gostujočega jedra.

Predvidevam, da če se odločite, da boste vse to naredili sami, boste najverjetneje naredili vse, kar je opisano v nekaterih Ubuntu ali Debian-podoben sistem. Vse zgoraj opisano sem poskušal implementirati v svoji najljubši distribuciji, Alpine, vendar nič ni delovalo, očitno zaradi jedra Linux ima trdno povezavo do glibc-isms za gonilnike uporabniškega načina. To nameravam sporočiti nadrejenemu, ko bom težavo popolnoma razumel.

Namestitev odvisnosti od gostitelja

Ubuntu za gradnjo jedra potrebuje vsaj naslednje pakete Linux (ob predpostavki čiste namestitve):

- 'build-essential'
- 'flex'
- 'bison'
- 'xz-utils'
- 'wget'
- 'ca-certificates'
- 'bc'
- 'linux-headers'

Namestite jih lahko z naslednjim ukazom (kot root ali s sudo):

apt-get -y install build-essential flex bison xz-utils wget ca-certificates bc 
                   linux-headers-$(uname -r)

Upoštevajte, da zagon programa za nastavitev menija jedra Linux bo potrebna namestitev libncurses-dev. Prepričajte se, da je nameščen z naslednjim ukazom (kot root ali s sudo):

apt-get -y install libncurses-dev

Prenos jedra

Odločite se, kam boste prenesli in nato zgradite jedro. Za to operacijo boste morali dodeliti približno 1,3 GB prostora na trdem disku, zato se prepričajte, da ga imate.

Po pojdi na kernel.org in dobite URL za prenos najnovejšega stabilnega jedra. V času pisanja je to: https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.1.16.tar.xz

Prenesite to datoteko z uporabo 'wget':

wget https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.1.16.tar.xz

In ga ekstrahirajte z 'tar':

tar xJf linux-5.1.16.tar.xz

Zdaj vstopimo v imenik, ustvarjen pri razpakiranju arhiva:

cd linux-5.1.16

Nastavitev gradnje jedra

Sistem gradnje jedra je komplet Makefiles с veliko prilagojena orodja in skripte za avtomatizacijo postopka. Najprej odprite interaktivni namestitveni program:

make ARCH=um menuconfig

Delno vam bo zgradil in prikazal pogovorno okno. Kdaj '[Select]', boste lahko konfigurirali s tipkama Preslednica ali Enter. Krmarite po oknu, kot običajno, s puščicama na tipkovnici "gor" in "dol" in izberite elemente - "levo" ali "desno".

Kazalec pogleda —> pomeni, da ste v podmeniju, do katerega dostopate s tipko Enter. Izhod iz tega je očitno skozi '[Exit]".

Vključi naslednje možnosti v '[Select]' in se prepričajte, da imajo zraven '[*]':

UML-specific Options:
  - Host filesystem
Networking support (enable this to get the submenu to show up):
  - Networking options:
    - TCP/IP Networking
UML Network devices:
  - Virtual network device
  - SLiRP transport

To je to, to okno lahko zapustite tako, da zaporedoma izberete '[Exit]'. Prepričajte se, da ste na koncu pozvani, da shranite konfiguracijo in izberete '[Yes]".

Priporočam, da se po branju te objave poigrate z možnostmi gradnje jedra. S temi poskusi se lahko veliko naučite v smislu razumevanja dela nizkonivojske mehanike jedra in vpliva različnih zastavic na njegovo sestavljanje.

Gradnja jedra

Core Linux Gre za obsežen program, ki počne veliko stvari. Tudi s to minimalno konfiguracijo lahko njegova gradnja na starejši strojni opremi traja kar nekaj časa. Zato jedro zgradite z naslednjim ukazom:

make ARCH=um -j$(nproc)

Za kaj? Ta ukaz bo našemu graditelju povedal, naj v procesu gradnje uporabi vsa razpoložljiva jedra CPE in niti. Ekipa $(nproc) na koncu Build nadomesti izhod ukaza nproc, ki je del coreutils v standardni montaži Ubuntu.

Čez nekaj časa bo naše jedro prevedeno v izvršljivo datoteko ./linux.

Namestitev binarne datoteke

Ker je uporabniški način vklopljen Linux Ustvari navadno binarno datoteko, tako da jo lahko namestite kot kateri koli drug pripomoček. Takole sem to naredil:

mkdir -p ~/bin
cp linux ~/bin/linux

Prav tako je vredno zagotoviti, da ~/bin je v vašem $PATH:

export PATH=$PATH:$HOME/bin

Nastavitev gostujočega datotečnega sistema

Ustvarite imenik za gostujoči datotečni sistem:

mkdir -p $HOME/prefix/uml-demo
cd $HOME/prefix

Odprite alpinelinux.org in vstopite razdelek za prenos poiščite dejansko povezavo za prenos MINI ROOT FILESYSTEM. V času pisanja je bilo to:

http://dl-cdn.alpinelinux.org/alpine/v3.10/releases/x86_64/alpine-minirootfs-3.10.0-x86_64.tar.gz

Prenesite ta arhiv s pomočjo wget:

wget -O alpine-rootfs.tgz http://dl-cdn.alpinelinux.org/alpine/v3.10/releases/x86_64/alpine-minirootfs-3.10.0-x86_64.tar.gz

Zdaj vnesite imenik gostujočega datotečnega sistema in ekstrahirajte arhiv:

cd uml-demo
tar xf ../alpine-rootfs.tgz

Opisana dejanja bodo ustvarila majhno predlogo datotečnega sistema. Zaradi narave sistema bo izredno težko namestiti pakete preko Alpine apk managerja. Toda ta FS bo dovolj za oceno splošne ideje.

Potrebujemo tudi orodje tini za omejitev porabe pomnilnika zombi procesi naše gostujoče jedro.

wget -O tini https://github.com/krallin/tini/releases/download/v0.18.0/tini-static
chmod +x tini

Ustvarjanje ukazne vrstice jedra

V jedru Linux, tako kot večina drugih programov, obstajajo argumenti ukazne vrstice, do katerih lahko dostopate z navedbo ključa --help.

Sam — pomoč

linux --help
User Mode Linux v5.1.16
        available at http://user-mode-linux.sourceforge.net/

--showconfig
    Prints the config file that this UML binary was generated from.

iomem=<name>,<file>
    Configure <file> as an IO memory region named <name>.

mem=<Amount of desired ram>
    This controls how much "physical" memory the kernel allocates
    for the system. The size is specified as a number followed by
    one of 'k', 'K', 'm', 'M', which have the obvious meanings.
    This is not related to the amount of memory in the host.  It can
    be more, and the excess, if it's ever used, will just be swapped out.
        Example: mem=64M

--help
    Prints this message.

debug
    this flag is not needed to run gdb on UML in skas mode

root=<file containing the root fs>
    This is actually used by the generic kernel in exactly the same
    way as in any other kernel. If you configure a number of block
    devices and want to boot off something other than ubd0, you
    would use something like:
        root=/dev/ubd5

--version
    Prints the version number of the kernel.

umid=<name>
    This is used to assign a unique identity to this UML machine and
    is used for naming the pid file and management console socket.

con[0-9]*=<channel description>
    Attach a console or serial line to a host channel.  See
    http://user-mode-linux.sourceforge.net/old/input.html for a complete
    description of this switch.

eth[0-9]+=<transport>,<options>
    Configure a network device.
    
aio=2.4
    This is used to force UML to use 2.4-style AIO even when 2.6 AIO is
    available.  2.4 AIO is a single thread that handles one request at a
    time, synchronously.  2.6 AIO is a thread which uses the 2.6 AIO
    interface to handle an arbitrary number of pending requests.  2.6 AIO
    is not available in tt mode, on 2.4 hosts, or when UML is built with
    /usr/include/linux/aio_abi.h not available.  Many distributions don't
    include aio_abi.h, so you will need to copy it from a kernel tree to
    your /usr/include/linux in order to build an AIO-capable UML

nosysemu
    Turns off syscall emulation patch for ptrace (SYSEMU).
    SYSEMU is a performance-patch introduced by Laurent Vivier. It changes
    behaviour of ptrace() and helps reduce host context switch rates.
    To make it work, you need a kernel patch for your host, too.
    See http://perso.wanadoo.fr/laurent.vivier/UML/ for further
    information.

uml_dir=<directory>
    The location to place the pid and umid files.

quiet
    Turns off information messages during boot.

hostfs=<root dir>,<flags>,...
    This is used to set hostfs parameters.  The root directory argument
    is used to confine all hostfs mounts to within the specified directory
    tree on the host.  If this isn't specified, then a user inside UML can
    mount anything on the host that's accessible to the user that's running
    it.
    The only flag currently supported is 'append', which specifies that all
    files opened by hostfs will be opened in append mode.

Ta plošča poudarja glavne parametre zagona. Zaženimo jedro z minimalnim zahtevanim naborom možnosti:

linux 
  root=/dev/root 
  rootfstype=hostfs 
  rootflags=$HOME/prefix/uml-demo 
  rw 
  mem=64M 
  init=/bin/sh

Zgornje vrstice sporočajo našemu jedru naslednje:

  • Predpostavimo, da je korenski datotečni sistem psevdo naprava /dev/root.
  • Izberite hostfs kot gonilnik korenskega datotečnega sistema.
  • Namestite gostujoči datotečni sistem, ki smo ga ustvarili na korenski napravi.
  • In ja, v načinu branja in pisanja.
  • Uporabite samo 64 MB RAM-a (lahko uporabite veliko manj, odvisno od tega, kaj nameravate početi, vendar se zdi 64 MB optimalna količina).
  • Jedro se samodejno zažene /bin/sh kot init-proces.

Zaženite ta ukaz in dobili bi nekaj takega:

Še en list

Core dump limits :
        soft - 0
        hard - NONE
Checking that ptrace can change system call numbers...OK
Checking syscall emulation patch for ptrace...OK
Checking advanced syscall emulation patch for ptrace...OK
Checking environment variables for a tempdir...none found
Checking if /dev/shm is on tmpfs...OK
Checking PROT_EXEC mmap in /dev/shm...OK
Adding 32137216 bytes to physical memory to account for exec-shield gap
Linux version 5.1.16 (cadey@kahless) (gcc version 7.4.0 (Ubuntu 7.4.0-1ubuntu1~18.04.1)) #30 Sun Jul 7 18:57:19 UTC 2019
Built 1 zonelists, mobility grouping on.  Total pages: 23898
Kernel command line: root=/dev/root rootflags=/home/cadey/dl/uml/alpine rootfstype=hostfs rw mem=64M init=/bin/sh
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
Memory: 59584K/96920K available (2692K kernel code, 708K rwdata, 588K rodata, 104K init, 244K bss, 37336K reserved, 0K cma-reserved)
SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
NR_IRQS: 15
clocksource: timer: mask: 0xffffffffffffffff max_cycles: 0x1cd42e205, max_idle_ns: 881590404426 ns
Calibrating delay loop... 7479.29 BogoMIPS (lpj=37396480)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Mountpoint-cache hash table entries: 512 (order: 0, 4096 bytes)
Checking that host ptys support output SIGIO...Yes
Checking that host ptys support SIGIO on close...No, enabling workaround
devtmpfs: initialized
random: get_random_bytes called from setup_net+0x48/0x1e0 with crng_init=0
Using 2.6 host AIO
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
futex hash table entries: 256 (order: 0, 6144 bytes)
NET: Registered protocol family 16
clocksource: Switched to clocksource timer
NET: Registered protocol family 2
tcp_listen_portaddr_hash hash table entries: 256 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
console [stderr0] disabled
mconsole (version 2) initialized on /home/cadey/.uml/tEwIjm/mconsole
Checking host MADV_REMOVE support...OK
workingset: timestamp_bits=62 max_order=14 bucket_order=0
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
io scheduler noop registered (default)
io scheduler bfq registered
loop: module loaded
NET: Registered protocol family 17
Initialized stdio console driver
Using a channel type which is configured out of UML
setup_one_line failed for device 1 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 2 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 3 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 4 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 5 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 6 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 7 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 8 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 9 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 10 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 11 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 12 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 13 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 14 : Configuration failed
Using a channel type which is configured out of UML
setup_one_line failed for device 15 : Configuration failed
Console initialized on /dev/tty0
console [tty0] enabled
console [mc-1] enabled
Failed to initialize ubd device 0 :Couldn't determine size of device's file
VFS: Mounted root (hostfs filesystem) on device 0:11.
devtmpfs: mounted
This architecture does not have kernel memory protection.
Run /bin/sh as init process
/bin/sh: can't access tty; job control turned off
random: fast init done
/ # 

Zgornje manipulacije nam bodo dale minimalni sistem za goste, brez stvari, kot je /proc ali dodeljeno ime gostitelja. Poskusite na primer naslednje ukaze:

- uname -av
- cat /proc/self/pid
- hostname

Če se želite odjaviti iz gosta, vnesite exit ali pritisnite control-d. To bo uničilo lupino, čemur sledi panika jedra:

/ # exit
Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000
fish: “./linux root=/dev/root rootflag…” terminated by signal SIGABRT (Abort)

To paniko zaradi jedra imamo, ker jedro Linux predpostavlja, da se inicializacijski proces vedno izvaja. Brez njega sistem ne more več delovati in se zaključi. Ker pa gre za proces uporabniškega načina, se nastali izhod pošlje v SIGABRT, kar ima za posledico izhod.

Nastavitev gostujočega omrežja

Ampak tukaj se stvari začnejo zapletati. Omrežje v uporabniškem načinu Linux – tu se začne razpadati celoten koncept omejenega »uporabniškega načina«. Navsezadnje je omrežje na sistemski ravni običajno omejeno. privilegiran načini izvajanja iz nam vsem razumljivih razlogov.

Opomba. per .: lahko preberete več o različnih možnostih za delo z omrežjem v UML tukaj.

Potovanje v Slirp

Vendar pa obstaja starodavno in skoraj nepodprto orodje, imenovano Slirp, s pomočjo katerega uporabniški način Linux lahko komunicira z omrežjem. Deluje nekoliko podobno kot sklad TCP/IP na uporabniški ravni in za zagon ne potrebuje nobenih sistemskih dovoljenj. To orodje je bilo izdano leta 1995, zadnja posodobitev pa ima datum 2006 leto. Slirp je zelo star. V času brez podpore in posodobitev so šli prevajalniki tako daleč, da lahko zdaj to orodje opišemo le kot koda rot.

Torej, prenesimo Slirp iz repozitorijev. Ubuntu in poskusimo ga zagnati:

sudo apt-get install slirp
/usr/bin/slirp
Slirp v1.0.17 (BETA)

Copyright (c) 1995,1996 Danny Gasparovski and others.
All rights reserved.
This program is copyrighted, free software.
Please read the file COPYRIGHT that came with the Slirp
package for the terms and conditions of the copyright.

IP address of Slirp host: 127.0.0.1
IP address of your DNS(s): 1.1.1.1, 10.77.0.7
Your address is 10.0.2.15
(or anything else you want)

Type five zeroes (0) to exit.

[autodetect SLIP/CSLIP, MTU 1500, MRU 1500, 115200 baud]

SLiRP Ready ...
fish: “/usr/bin/slirp” terminated by signal SIGSEGV (Address boundary error)

O bogovi. Namestimo Slirpov razhroščevalnik in poglejmo, ali lahko ugotovimo, kaj se tukaj dogaja:

sudo apt-get install gdb slirp-dbgsym
gdb /usr/bin/slirp
GNU gdb (Ubuntu 8.1-0ubuntu3) 8.1.0.20180409-git
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/slirp...Reading symbols from /usr/lib/debug/.build-id/c6/2e75b69581a1ad85f72ac32c0d7af913d4861f.debug...done.
done.
(gdb) run
Starting program: /usr/bin/slirp
Slirp v1.0.17 (BETA)

Copyright (c) 1995,1996 Danny Gasparovski and others.
All rights reserved.
This program is copyrighted, free software.
Please read the file COPYRIGHT that came with the Slirp
package for the terms and conditions of the copyright.

IP address of Slirp host: 127.0.0.1
IP address of your DNS(s): 1.1.1.1, 10.77.0.7
Your address is 10.0.2.15
(or anything else you want)

Type five zeroes (0) to exit.

[autodetect SLIP/CSLIP, MTU 1500, MRU 1500, 115200 baud]

SLiRP Ready ...

Program received signal SIGSEGV, Segmentation fault.
                                                    ip_slowtimo () at ip_input.c:457
457     ip_input.c: No such file or directory.

Napaka bije v nas ta vrstica. Poglejmo stacktrace, morda nam bo tam kaj pomagalo:

(gdb) bt full
#0  ip_slowtimo () at ip_input.c:457
        fp = 0x55784a40
#1  0x000055555556a57c in main_loop () at ./main.c:980
        so = <optimized out>
        so_next = <optimized out>
        timeout = {tv_sec = 0, tv_usec = 0}
        ret = 0
        nfds = 0
        ttyp = <optimized out>
        ttyp2 = <optimized out>
        best_time = <optimized out>
        tmp_time = <optimized out>
#2  0x000055555555b116 in main (argc=1, argv=0x7fffffffdc58) at ./main.c:95
No locals.

Tukaj vidimo, da se zrušitev zgodi med začetkom glavne zanke, ko slirp poskuša preveriti časovne omejitve. Na tej točki sem moral opustiti poskus odpravljanja napak. Toda poglejmo, ali deluje Slirp, zgrajen iz sort. Ponovno sem prenesel arhiv neposredno s spletnega mesta Sourceforge, ker je vlečenje nečesa od tam skozi ukazno vrstico muka:

cd ~/dl
wget https://xena.greedo.xeserv.us/files/slirp-1.0.16.tar.gz
tar xf slirp-1.0.16.tar.gz
cd slirp-1.0.16/src
./configure --prefix=$HOME/prefix/slirp
make

Tukaj vidimo opozorila o nedefiniranih vgrajenih funkcijah, torej o nezmožnosti povezovanja nastale binarne datoteke. Zdi se, da je gcc med letom 2006 in to točko prenehal proizvajati simbole, ki se uporabljajo v vgrajenih funkcijah vmesnih prevedenih datotek. Poskusimo zamenjati ključno besedo inline na prazen komentar in si oglejte rezultat:

vi slirp.h
:6
a
<enter>
#define inline /**/
<escape>
:wq
make

Ne. Tudi to ne deluje. Še vedno ne najdem simbolov za te funkcije.

Na tej točki sem obupal in začel iskati Github Gradbeni paketi Heroku. Moja teorija je bila, da bi nek gradbeni paket Heroku vseboval binarne datoteke, ki jih potrebujem. Na koncu me je iskanje pripeljalo tukaj. Prenesel sem in razpakiral uml.tar.gz in našel naslednje:

total 6136
-rwxr-xr-x 1 cadey cadey   79744 Dec 10  2017 ifconfig*
-rwxr-xr-x 1 cadey cadey     373 Dec 13  2017 init*
-rwxr-xr-x 1 cadey cadey  149688 Dec 10  2017 insmod*
-rwxr-xr-x 1 cadey cadey   66600 Dec 10  2017 route*
-rwxr-xr-x 1 cadey cadey  181056 Jun 26  2015 slirp*
-rwxr-xr-x 1 cadey cadey 5786592 Dec 15  2017 uml*
-rwxr-xr-x 1 cadey cadey     211 Dec 13  2017 uml_run*

To je dvojiška datoteka slip! Ali dela?

./slirp
Slirp v1.0.17 (BETA) FULL_BOLT

Copyright (c) 1995,1996 Danny Gasparovski and others.
All rights reserved.
This program is copyrighted, free software.
Please read the file COPYRIGHT that came with the Slirp
package for the terms and conditions of the copyright.

IP address of Slirp host: 127.0.0.1
IP address of your DNS(s): 1.1.1.1, 10.77.0.7
Your address is 10.0.2.15
(or anything else you want)

Type five zeroes (0) to exit.

[autodetect SLIP/CSLIP, MTU 1500, MRU 1500]

SLiRP Ready ...

Ne sesuje - torej bi moralo delovati! Vstavimo to dvojiško datoteko ~/bin/slirp:

cp slirp ~/bin/slirp

V primeru, da ga ustvarjalec paketa odstrani, I naredil ogledalo.

Nastavitev omrežja

Zdaj pa nastavimo omrežje na našem gostujočem jedru. Posodobite možnosti zagona:

linux 
  root=/dev/root 
  rootfstype=hostfs 
  rootflags=$HOME/prefix/uml-demo 
  rw 
  mem=64M 
  eth0=slirp,,$HOME/bin/slirp 
  init=/bin/sh

Zdaj pa vklopimo omrežje:

mount -t proc proc proc/
mount -t sysfs sys sys/

ifconfig eth0 10.0.2.14 netmask 255.255.255.240 broadcast 10.0.2.15
route add default gw 10.0.2.2

Prva dva konfiguracijska ukaza /proc и /sys potrebno za delo ifconfig, ki nastavi omrežni vmesnik za komunikacijo s Slirp. Ekipa route nastavi usmerjevalno tabelo jedra tako, da prisili, da se ves promet pošlje skozi tunel Slirp. Preverimo to s poizvedbo DNS:

nslookup google.com 8.8.8.8
Server:    8.8.8.8
Address 1: 8.8.8.8 dns.google

Name:      google.com
Address 1: 172.217.12.206 lga25s63-in-f14.1e100.net
Address 2: 2607:f8b0:4006:81b::200e lga25s63-in-x0e.1e100.net

Deluje!

Opomba na .: Očitno je bila prvotna objava napisana na namizju z žično omrežno kartico ali kakšni drugi konfiguraciji, ki ni zahtevala dodatnih gonilnikov. Na prenosnem računalniku z WiFi 8265 podjetja Intel pride do napake pri dvigovanju omrežja

/ # ifconfig eth0 10.0.2.14 netmask 255.255.255.240 broadcast 10.0.2.15
slirp_tramp failed - errno = 2
ifconfig: ioctl 0x8914 failed: No such file or directory
/ #

Očitno jedro ne more komunicirati z gonilnikom omrežne kartice. Poskus prevajanja vdelane programske opreme v jedro žal ni popravil situacije. V času objave v tej konfiguraciji ni bilo mogoče najti rešitve. Na enostavnejših konfiguracijah (na primer v Virtualboxu) se vmesnik dvigne pravilno.

Avtomatizirajmo preusmeritev z naslednjim ukaznim skriptom:

#!/bin/sh
# init.sh

mount -t proc proc proc/
mount -t sysfs sys sys/
ifconfig eth0 10.0.2.14 netmask 255.255.255.240 broadcast 10.0.2.15
route add default gw 10.0.2.2

echo "networking set up"

exec /tini /bin/sh

In ga označite kot izvršljivega:

chmod +x init.sh

Nato bomo spremenili ukazno vrstico jedra:

linux 
  root=/dev/root 
  rootfstype=hostfs 
  rootflags=$HOME/prefix/uml-demo 
  rw 
  mem=64M 
  eth0=slirp,,$HOME/bin/slirp 
  init=/init.sh

In ponovimo:

SLiRP Ready ...
networking set up
/bin/sh: can't access tty; job control turned off

nslookup google.com 8.8.8.8
Server:    8.8.8.8
Address 1: 8.8.8.8 dns.google

Name:      google.com
Address 1: 172.217.12.206 lga25s63-in-f14.1e100.net
Address 2: 2607:f8b0:4004:800::200e iad30s09-in-x0e.1e100.net

Omrežje je stabilno!

docker datoteka

Da boste vse to lažje preverili, sem zbral Dockerfile, ki avtomatizira večino opisanih korakov in vam mora zagotoviti delujočo konfiguracijo. imam tudi vnaprej konfigurirano jedro, ki ima vse, kar je opisano v objavi. Vendar je pomembno razumeti, da sem tukaj orisal le minimalno nastavitev.

Upam, da vam je ta objava pomagala razumeti, kako zagnati gostujoče jedro. Je nekoliko zapleteno, vendar je bil namen zagotoviti izčrpen vodnik za gradnjo, namestitev in konfiguriranje uporabniškega načina. Linux v sodobnih različicah operacijskih sistemov te družine. Nadaljnji koraki bi morali vključevati namestitev storitev in druge programske opreme znotraj gostujočega sistema. Ker so slike Dockerjevih vsebnikov preprosto razvpite tarballe, bi morali biti sposobni izvleči sliko prek docker export, nato pa določite njegovo namestitveno pot v korenu datotečnega sistema gostujočega jedra. No, potem izvedite lupinski skript.

Posebna zahvala Rkeeneju iz #lobsters na Freenode. Brez njegove pomoči pri odpravljanju napak v Slirp ne bi prišel tako daleč. Nimam pojma, kako njegov sistem Slackware pravilno deluje s slirpom, ampak moj sistem deluje. Ubuntu in Alpine ni sprejel slirp-a in mi je ponudil binarni Rkeene. Ampak meni je dovolj, da vsaj nekaj deluje.

Vir: www.habr.com

Kupite zanesljivo gostovanje za strani z DDoS zaščito, VPS VDS strežniki 🔥 Kupite zanesljivo spletno gostovanje z zaščito DDoS, VPS VDS strežniki | ProHoster