Avtor GnuPG je ustanovil LibrePGP, fork standarda OpenPGP

Werner Koch, glavni razvijalec in ustvarjalec projekta GnuPG (GNU Privacy Guard), je ustanovil projekt LibrePGP, osredotočen na razvoj posodobljene specifikacije, alternativne standardu OpenPGP. Fork je bil ustvarjen kot odziv na spremembe, ki jih je delovna skupina IETF napovedala za naslednje posodobitve specifikacije OpenPGP (RFC-4880), ki jih je Koch štel za vprašljive z vidika ohranjanja združljivosti in zagotavljanja varnosti. Podporniki forka, razvijalci projektov GnuPG, RNP (izvedba OpenPGP za Thunderbird) in Gpg4win, se bojijo, da bi napovedane spremembe lahko bile usodne za obstoječe implementacije aplikacij na osnovi OpenPGP, katerih uporabniki se zanašajo na stabilnost specifikacije na dolgi rok in niso pripravljeni sprejeti sprememb, ki kršijo združljivost.

LibrePGP vključuje koristna izboljšanja, ki so se v zadnjih letih razvijala za prihodnjo različico specifikacije OpenPGP, hkrati pa izključuje spremembe, ki negativno vplivajo na zagotavljanje združljivosti. Na primer, v primerjavi z obstoječim standardom RFC-4880 je v LibrePGP sprejetih naslednjih nekaj zmožnosti:

  • Podpora za način šifriranja Camellia (RFC-5581),
  • Razširitve ECC (Elliptic Curve Cryptography) za OpenPGP (RFC-6637).
  • Obvezna podpora za hashe SHA2-256 (SHA-1 in MD5 sta uvrščena med ne priporočene, možnost dešifriranja podatkov brez ovrednotenja celovitosti pa je uvrščena med povsem zastarele).
  • Povečanje velikosti potrebnega odtisa (fingerprint) na 256 bitov.
  • Podpora za shemo digitalnih podpisov EdDSA in eliptične krivne BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 in X448.
  • Podpora za algoritem CRYSTALS-Kyber, odporen na napade kvantnih računalnikov.
  • Podpora za načine overjene šifriranja OCB (Offset codebook mode).
  • Izvedba pete različice formata digitalnih podpisov z zaščito metapodatkov.
  • Podpora za razširjene subpakete z digitalnimi podpisi.

Glavni elementi kritike nove specifikacije OpenPGP:

  • Delovna skupina IETF je namesto postopne inkrementalne posodobitve specifikacije poskušala na novo izumiti standard in v njega vpeljati pomembne spremembe, ki kršijo združljivost.
  • Vsiljevanje podpore za simetrični način šifriranja GCM (Galois/Counter Mode), ki ga je težko pravilno implementirati, pri tem pa ignorirati OCB (Offset Codebook Mode), katerega patenti so potekli pred leti.
  • Dodajanje opcijskih paketov s slučajnim dodatnim polnjenjem za zaščito pred analizo prometa. Po mnenju avtorjev LibrePGP takšni paketi z nepreverjenim začetnim slučajnim polnjenjem predstavljajo grožnjo za uporabo pri ustvarjanju skritih kanalov za prenos podatkov in obhodu sistemov za preprečevanje uhajanja podatkov. Ideja o vključitvi dodatnega polnjenja je bila prej zavrnjena kot predmet ravni aplikacij, ne šifriranja.
  • Uporaba spremenjene sheme šifriranja ECDH (sprememba formata OID), namesto že opisanega v RFC-6637 in implementiranega v PGP in GnuPG.
  • Odstranitev nekaterih praktično uporabljenih možnosti, kot so klasična metoda preklica ključev, zastavica 'm' za označevanje MIME podatkov in zastavica 't' za ločevanje besedilnih podatkov od binarnih (namesto zastavice 't' je prišla zastavica 'u' za besedilo v kodiranju UTF-8).
  • Zavrnitev vključitve zaščite metapodatkov podpisanega datoteke v nov format podpisov (na primer, možno je spremeniti ime datoteke, ne da bi kršili podpis).
  • Sporna možnost dodajanja 'soli' k podpisom (Salted signature) za izboljšanje zaščite pred trčenjem napadov z določenim prefiksom. Vrednost s soljo se lahko uporablja kot neizklopljiv skrit kanal za prenos 32 bajtov podatkov v podpisu.
  • Premik standarda proti osnovni uporabi za spletno komunikacijo, ignorirajoč potrebe po dolgotrajnem shranjevanju podatkov.

Podporniki OpenPGP so že objavili kritiko na kritiko. Vendar, če ne bo mogoče najti kompromisa, bi razkol lahko vodil k naraščanju nezdružljivosti v implementacijah OpenPGP/LibrePGP. Delno za reševanje tega problema so razvijalci OpenPGP v peti različici formata podpisov uskladili z LibrePGP in prešli na delo na šesti različici.

Izvor: opennet.ru

Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki 🔥 Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki | ProHoster