Kategorija: Novice interneta

Izšla je GNAT Community Edition 2021

Objavljen je paket razvojnih orodij v programskem jeziku Ada - GNAT Community Edition 2021. Vključuje prevajalnik, integrirano razvojno okolje GNAT Studio, statični analizator podmnožice jezika SPARK, razhroščevalnik GDB in nabor knjižnic. Paket se distribuira pod licenco GPL. Nova različica prevajalnika uporablja backend GCC 10.3.1 in ponuja vrsto novih možnosti. Dodana je implementacija naslednjih novosti prihajajočega standarda Ade […]

Na voljo je JingOS 0.9, distribucija za tablične računalnike.

Objavljen je izdanak distribucije JingOS 0.9, koja pruža okruženje posebno optimizirano za instalaciju na tablet računala i prijenosnike s dodirnim zaslonom. Projekt razvija kineska tvrtka Jingling Tech koja ima predstavništvo u Kaliforniji. Tim programera uključuje zaposlenike koji su ranije radili u tvrtkama Lenovo, Alibaba, Samsung, Canonical/Ubuntu i Trolltech. Veličina instalacijske slike iznosi 3 GB (x86_64). Postignuća projekta distribuiraju se pod licencom […]

Izdava OpenRGB 0.6, alata za upravljanje uređajima s RGB-osvetljenjem

Objavljen je novi izdanak OpenRGB 0.6, slobodnog alata za upravljanje uređajima s RGB-pozadinskim osvjetljenjem. Paket podržava matične ploče ASUS, Gigabyte, ASRock i MSI s RGB-podsklopom za osvjetljenje kućišta, modules memorije sa pozadinskim osvjetljenjem od ASUS-a, Patriot-a, Corsair-a i HyperX-a, grafičke kartice ASUS Aura/ROG, MSI GeForce, Sapphire Nitro i Gigabyte Aorus, razne kontrolere LED traka (ThermalTake, Corsair, NZXT Hue+), […]

Za jezik D predstavljen je runtime za programiranje mikrokontrolera

Dylan Graham predstavio je lagani runtime LWDR za programiranje na jeziku D mikrokontrolera opremljenih operacijskim sustavom stvarnog vremena (RTOS). Trenutna verzija usmjerena je na mikrokontrolere ARM Cortex-M. Razvoj ne nastoji pokriti sve mogućnosti D jezika, već pruža osnovne alate. Distribucija memorije vrši se ručno (new / delete), sakupljač smeća nije implementiran, ali postoji niz hookova za […]

Izdaja serverskih aplikacija NGINX Unit 1.24.0

Izdan je poslužitelj aplikacija NGINX Unit 1.24, koji se razvija kao rješenje za pokretanje web aplikacija na raznim programskim jezicima (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js i Java). Pod upravom NGINX Unit-a može se istovremeno izvršavati više aplikacija na različitim programskim jezicima, a parametre pokretanja moguće je dinamički mijenjati bez potrebe za uređivanjem konfiguracijskih datoteka i ponovnim pokretanjem. Kod […]

Izdanje Electron 13.0.0, platforme za izradu aplikacija na osnovu Chromium motora

Pripremljeno je izdanje platforme Electron 13.0.0, koja pruža samodostatni okvir za razvoj višekratnih korisničkih aplikacija, koristeći kao osnovne komponente Chromium, V8 i Node.js. Značajna promjena broja verzije povezana je s ažuriranjem na kodnu osnovu Chromium 91, platformu Node.js 14.16 i JavaScript motor V8 9.1. Među promjenama u novom izdanju: Dodano svojstvo process.contextIsolated za utvrđivanje izvođenja trenutnog […]

Izdanje biblioteke PCRE2 10.37

Izšel je novi sklop knjižnice PCRE2 10.37, ki ponuja nabor funkcij v jeziku C za izvajanje regularnih izrazov in metod za ujemanje vzorcev, ki so po sintaksi in semantiki podobni regularnim izrazom jezika Perl 5. PCRE2 je prenovljena različica izvirne knjižnice PCRE z nezdružljivim API-jem in razširjenimi zmogljivostmi. Knjižnico so razvili razvijalci poštnega strežnika Exim in se distribuira […]

Microsoft je izdal upravljalnik paketov Windows Package Manager 1.0, podoben apt in dnf.

Podjetje Microsoft je objavilo izdajo upravitelja paketov Windows Package Manager 1.0 (winget), ki ponuja sredstva za namestitev aplikacij z uporabo ukazne vrstice. Koda je napisana v jeziku C++ in se distribuira pod licenco MIT. Paketi se nameščajo iz repozitorija, ki ga podpira skupnost. Za razliko od namestitve programov iz kataloga Microsoft Store, winget omogoča namestitev aplikacij brez odvečne trženjske vsebine in […]

Izdaje upravitelja paketov Pacman 6.0 in namestitvenega orodja Archinstall 2.2.0

Na voljo so nove izdaje upravitelja paketov Pacman 6.0.0 in namestitvenega programa Archinstall 2.2.0, ki se uporabljata v distribuciji Arch Linux. Glavne spremembe v Pacman 6.0: dodana podpora za prenos datotek v več paralelnih tokovih. Izveden je izhodni niz za prikaz napredka prenosa podatkov. Za izklop prikaza napredka lahko v datoteki pacman.conf navedete možnost „—noprogressbar“. Omogočeno je samodejno preskakovanje ogledov, pri katerih […]

Odprt je koda storitve za preverjanje gesel HaveIBeenPwned

Troy Hunt je odprl izvorno kodo storitve za preverjanje kompromitiranih gesel „Have I Been Pwned?“ (haveibeenpwned.com), ki preverja bazo z 11,2 milijarde računov, ki so bili zlorabljeni zaradi vdorov na 538 spletnih mest. Sprva je bilo o nameri odpiranja kode projekta objavljeno avgusta lani, vendar se je postopek zavlekel in koda je bila objavljena šele zdaj. Koda storitve je napisana v […]

Mozilla je povzela načrte za podporo tretji različici Chrome manifestacije v Firefoxu

Podjetje Mozilla je objavilo načrt za implementacijo tretje različice manifestacije Chrome v Firefoxu, ki določa možnosti in vire, ki jih dopolnila ponujajo. Tretja različica manifestacije je bila deležna kritik zaradi kršenja delovanja številnih dopolnil, ki blokirajo neželeno vsebino in zagotavljajo varnost. V Firefoxu nameravajo implementirati skoraj vse možnosti in omejitve nove manifestacije, vključno z deklarativnim API-jem za filtriranje vsebine (declarativeNetRequest), […]

Protokol QUIC je prejel status predlaganega standarda

IETF (Internet Engineering Task Force), ki se ukvarja z razvojem protokolov in arhitekture interneta, je končal oblikovanje RFC za protokol QUIC in objavil povezane specifikacije pod identifikatorji RFC 8999 (neodvisne od različice lastnosti protokola), RFC 9000 (transport preko UDP), RFC 9001 (TLS-šifriranje komunikacijskega kanala QUIC) in RFC 9002 (upravljanje obremenitve in določanje izgube paketov pri prenosu podatkov). […]

Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki 🔥 Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki | ProHoster