Izdanje FreeBSD 12.3

Objavljeno je izdanje FreeBSD 12.3, koje je dostupno za arhitekture amd64, i386, powerpc, powerpc64, powerpcspe, sparc64, kao i armv6, armv7 i aarch64. Takođe su pripremljene slike za virtuelizacione sisteme (QCOW2, VHD, VMDK, raw) i oblačna okruženja Amazon EC2. Izdanje FreeBSD 13.1 se očekuje na proleće 2022. godine.

Ključne novosti:

  • Dodani su skriptovi "/etc/rc.final", koji se pokreću u zadnjoj fazi rada nakon završetka svih korisničkih procesa.
  • U paketu filtrova ipfw dodana je komanda dnctl za upravljanje postavkama sistema za ograničavanje saobraćaja dummynet.
  • Dodana je sysctl kern.crypto za upravljanje kriptosistemom jezgra, kao i debag utilita sysctl debug.uma_reclaim.
  • Dodana je sysctl net.inet.tcp.tolerate_missing_ts, koja dozvoljava TCP pakete bez vremenskih oznaka (opcija timestamp, RFC 1323/RFC 7323).
  • U jezgru GENERIC za arhitekturu amd64 uključena je opcija COMPAT_LINUXKPI i aktiviran je drajver mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • U bootloader dodana je mogućnost pokretanja operativnog sistema sa ram-diska, kao i podrška za ZFS opcije com.delphix:bookmark_written i com.datto:bookmark_v2.
  • U biblioteku fetch dodata je podrška za FTP proxy preko HTTPS.
  • U paketu menadžeru pkg za komande "bootstrap" i "add" implementirana je zastavica "-r" za navođenje repozitorijuma. Osigurana je upotreba promenljivih okruženja iz datoteke pkg.conf.
  • U utiliti growfs dodana je mogućnost rada sa fajl sistemima montiranim u režimu čitanja i pisanja.
  • U utiliti etcupdate implementiran je režim vraćanja promena za obnavljanje jedne ili više datoteka. Dodata je zastavica "-D" za navođenje ciljnog direktorijuma. Osigurano je vađenje podataka uz upotrebu privremenog direktorijuma i dodata je obrada SIGINT.
  • U utility freebsd-update i freebsd-version dodata je zastavica "-j" za podršku jail-okruženjima.
  • Utility cpuset sada se može koristiti u jail-okruženjima za promenu parametara podređenih jail.
  • U utiliti cmp dodane su opcije: "-b" (—print-bytes) za ispis različitih bajtova, "-i" (—ignore-initial) za ignorisanje određenog broja početnih bajtova, "-n" (—bytes) za ograničenje broja upoređivanih bajtova.
  • U utiliti daemon uvedena je zastavica "-H" za obradu SIGHUP i ponovnu otvorenost datoteke u kojoj se ređi lako vrši ispis (dodano za podršku newsyslog).
  • U utiliti fstyp, uz navođenje zastavice "-l", obezbeđeno je određenje i prikaz exFAT fajl sistema.
  • V utilitě mergemaster byla implementována podpora pro zpracování symbolických odkazů při aktualizaci.
  • Do utility newsyslog byl přidán příznak „E“ pro deaktivaci rotace prázdných logů.
  • V utilitě tcpdump se objevila možnost dekódování paketů na rozhraních pfsync.
  • V utilitě top byla přidána filtrovací příkaz „/“ pro zobrazení pouze procesů nebo argumentů, které odpovídají danému řetězci.
  • Do unzip byla přidána podpora pro archivy chráněné heslem.
  • Byla vylepšena podpora hardwaru. Byly přidány identifikátory PCI zařízení pro AHCI ovladače ASMedia ASM116x a I2C ovladače Intel Gemini Lake. Byla implementována podpora síťových adaptérů Mikrotik 10/25G a bezdrátových karet Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Byl přidán nový ovladač igc pro ethernetové kontrolery Intel I225 2.5G/1G/100MB/10MB.
  • Netgraph uzel ng_bridge byl upraven pro SMP systémy. Do uzlu ng_nat byla přidána podpora CGN (Carrier Grade NAT, RFC 6598). Byla poskytnuta možnost substituce uzlu ng_source kdekoli v Netgraph síti.
  • V ovladači rctl, používaném pro omezování zdrojů, byla přidána možnost nastavit limit pro využívání zdrojů na hodnotu 0.
  • Do rozhraní vlan byla přidána podpora pro prioritizaci provozu a správu šířky pásma ALTQ.
  • V ovladačích amdtemp a amdsmn byla implementována podpora pro CPU Zen 3 „Vermeer“ a APU Ryzen 4000 (Zen 2, „Renoir“).
  • Byly aktualizovány verze základního systému třetích aplikací: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Utilita unzip byla synchronizována s kódovým základem NetBSD.

Izvor: opennet.ru

Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki 🔥 Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki | ProHoster