Izdana je nova verzija laganog HTTP servera lighttpd 1.4.65, koji nastoji kombinirati visoke performanse, sigurnost, usklađenost sa standardima i fleksibilnost konfiguracije. Lighttpd je prikladan za korištenje u sustavima s visokim opterećenjem i fokusiran je na nisku potrošnju memorije i CPU resursa. Nova verzija donosi 173 izmjene. Kod projekta napisan je na jeziku C i distribuira se pod BSD licencom.
Glavne novosti:
- Dodana je podrška za WebSocket preko HTTP/2, kao i implementacija RFC 8441, koji opisuje mehanizam za pokretanje WebSocket protokola unutar jednog toka u HTTP/2 vezi.
- Implementirana je proširena shema upravljanja prioritetima koja omogućava klijentu da utječe na prioritet prenošenih serverom odgovora (RFC 9218), kao i da upravlja prioritetima prilikom preusmjeravanja zahtjeva. Za HTTP/2 osigurana je podrška za okvir PRIORITY_UPDATE.
- U postavkama lighttpd.conf dodana je podrška za uvjetno usklađivanje na početku (=^) i kraju (=$) niza. Ove provjere niza su znatno brže od regularnih izraza i dovoljne su za mnoge jednostavne provjere.
- U mod_webdav dodana je podrška za parcijalne operacije PUT (koje pokrivaju dio podataka pomoću zaglavlja Range). Za uključivanje možete koristiti opciju ‘webdav.opts += («partial-put-copy-modify’ => «enable»).
- U mod_accesslog dodana je opcija ‘accesslog.escaping = ‘json'’.
- U mod_deflate dodana je podrška za izgradnju s libdeflate.
- Povećana je brzina prijenosa tijela zahtjeva putem HTTP/2.
- Zadana vrijednost parametra server.max-keep-alive-requests promijenjena je s 100 na 1000.
- U popisu MIME tipova ‘application/javascript’ zamijenjen je s ‘text/javascript’ (RFC 9239).
Za budućnost je planirano uvođenje strožih postavki šifriranja za TLS i onemogućavanje zastarjelih šifri prema zadanim postavkama. Postavka CipherString bit će promijenjena sa vrijednosti ‘HIGH’ na ‘EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384’. Također je planirano uklanjanje zastarjelih TLS opcija: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Dodatno će se nastaviti čišćenje mini-modula koji se mogu zamijeniti fleksibilnijom Lua implementacijom mod_magnet. Konkretno, planirano je uklanjanje modula mod_evasive, mod_secdownload, mod_uploadprogress i mod_usertrack.
Izvor: opennet.ru
