Po petih mesecih razvoja je bila oblikovana izdaja knjižnice OpenSSL 3.3.0 z implementacijo protokolov SSL/TLS in različnih šifrirnih algoritmov. Podpora za OpenSSL 3.3 bo trajala do aprila 2026. Podpora za prejšnje različice OpenSSL 3.2, 3.1 in 3.0 LTS pa bo trajala do novembra 2025, marca 2025 in septembra 2026. Koda projekta je na voljo pod licenco Apache 2.0.
Glavne novosti OpenSSL 3.3.0:
- Nadaljevala se je integracija podpore za protokol QUIC (RFC 9000), ki predstavlja nadgradnjo protokola UDP, uporabljeno kot transport v protokolu HTTP/3. V novem izdanju:
- Dodana je podpora za sledenje QUIC povezavami prek diagnosticiranja v dnevnikih v formatu qlog.
- Dodana je podpora za polling v neblokirnem načinu QUIC povezav in pretočnih objektov.
- Uvedena je optimizirana generacija okvirjev za konec toka za QUIC povezave.
- Omogočena je možnost onemogočanja obdelave dogodkov QUIC pri klicih API-ju.
- Dodana je podpora za nastavitev časovnega omejevanja za neaktivnost pri QUIC.
- Dodana je API funkcija za poizvedbo velikosti in stopnje napolnjenosti zapisnega medija za QUIC tokove.
- Izvedene so bile razširitve za protokol upravljanja s certifikati CMP (Certificate Management Protocol), določene v specifikacijah RFC 9480 (opredelitev protokola CMPv3) in RFC 9483 (lahka profil za nizkoenergijske naprave).
- Dodana je možnost onemogočanja uporabe funkcije atexit med ciklom gradnje.
- Dodana je različica API-jev SSL_SESSION, ki ni dovzetna za težave iz leta 2038: vključene so funkcije SSL_SESSION_get_time_ex() in SSL_SESSION_set_time_ex(), ki uporabljajo 64-bitne vrste time_t na 32-bitnih sistemih.
- V funkciji EVP_PKEY_fromdata je bila omogočena avtomatska pridobitev parametrov kitajskega teorema o ostalih (CRT, Chinese Remainder Theorem).
- Dodana je možnost ignoriranja neznanih imen podpisnih algoritmov, nastavljenih v parametrih konfiguracije TLS SignatureAlgorithms in ClientSignatureAlgorithms.
- Dodana je možnost nastavitve prioritetne uporabe PSK-ključev na strežnikom TLS 1.3 med obnovitvijo seje.
- Dodana je funkcija EVP_DigestSqueeze(), ki omogoča skrajševanje velikosti SHAKE hasha (odstranitev višjih bitov) z več ponovitvami z različnimi velikostmi izhoda.
- Dodana je podpora za izvoz gradbenih datotek za CMake na Unix-podobnih sistemih in Windows (poleg izvoza na osnovi pkg-config).
- Izvedene so optimizacije zmogljivosti: Optimizirano delovanje algoritma AES-GCM na napravah s čipi Microsoft Azure Cobalt 100. V implementaciji AES-CTR je bila dodana podpora za pospeševanje z uporabo razširitev ARM Neoverse V1 in V2. Vključene so optimizacije AES in SHA3 za sisteme Apple s čipi M3. V različnih kriptografskih funkcijah so vključene vektorske razširitve RISC-V. Dodana je bila asemblerna implementacija md5 za CPU Loongarch64.
Izvor: opennet.ru
