Izdanje OpenBSD 6.9

Predstavljen je izvod slobodnog cross-platform UNIX-sličnog operativnog sistema OpenBSD 6.9. Obeležava se da je ovo 50. izdanja projekta, koji ove godine puni 26 godina. Projekat OpenBSD osnovao je Teo de Raadt 1995. godine nakon sukoba s programerima NetBSD, zbog kojeg je Teo izgubio pristup CVS repozitorijumu NetBSD. Nakon toga, Teo de Raadt je sa grupom istomišljenika stvorio novu otvorenu operativnu sistemu na osnovu stabla izvornih kodova NetBSD, čiji su glavni ciljevi razvoja prenosivost (podržano je 13 hardverskih platformi), standardizacija, ispravnost, aktivna bezbednost i integrisana kriptografska sredstva. Veličina kompletnog instalacionog ISO imidža osnovnog sistema OpenBSD 6.9 iznosi 544 MB.

Poleg samega operacijskega sistema je projekt OpenBSD znan po svojih komponentah, ki so se razširile v druge sisteme in se dokazale kot ena izmed najbolj varnih in kakovostnih rešitev. Med njimi so: LibreSSL (fork OpenSSL), OpenSSH, paketni filter PF, demoni usmerjanja OpenBGPD in OpenOSPFD, NTP strežnik OpenNTPD, poštni strežnik OpenSMTPD, multiplexer besedilnega terminala (analoga GNU screen) tmux, demon identd z implementacijo protokola IDENT, BSDL-alternativa paketu GNU groff — mandoc, protokol za organizacijo odpornosti sistemov CARP (Common Address Redundancy Protocol), lahki http strežnik, orodje za sinhronizacijo datotek OpenRSYNC.

Glavne izboljšave:

  • U drajver softraid dodat je mod RAID1C sa implementacijom programski RAID1 sa enkripcijom podataka.
  • U sastav su uključena dva nova pozadinska procesa — dhcpleased i resolvd, koji rade zajedno sa slaacd i unwind za automatsko podešavanje mrežnih interfejsa i određivanje imena u DNS. U dhcpleased je implementiran protokol DHCP za dobijanje IP adresa, a u resolvd je omogućeno upravljanje sadržajem resolv.conf na osnovu podataka o serverima imena, dobijenih od dhcpleased, slaacd i drajvera poput umb.
  • Dodata je osnovna podrška za Apple uređaje sa M1 procesorom. Uključuje prepoznavanje arm64 jezgra Apple Icestorm/Firestorm i dodana je podrška za bežične čipove BCM4378, korišćene u SoC Apple M1.
  • Poboljšana je podrška za platformu powerpc64, razvijenu za 64-bitne sisteme zasnovane na POWER8 i POWER9 procesorima. U poređenju sa prethodnim izdanjem, za powerpc64 je implementirana podrška za mehanizam zaštite RETGUARD, dodat je drajver astfb za framebuffer Aspeed BMC, rešeni su problemi sa radom drajvera radeondrm i amdgpu na sistemima sa AMD GPU-om, u gradnju jezgra za ram-disk dodana je mogućnost mrežnog boot-a, dodana je podrška za režime uštede energije CPU-a POWER9, dodana je podrška za izuzetke generisane tokom operacija sa pokretnim zarezom, realizovana je podrška za IPMI za PowerNV sisteme.
  • Za platforme ARM64 je podpora za CPU Cortex-A78AE, Cortex-X1 in Neoverse V1, implementirane so optimizirane različice klicev copyin, copyout in kcopy, dodan je gonilnik cryptox za podporo kriptoširitev ARMv8 ter gonilnik smmu za RM System MMU s podporo za Guard Page. Izboljšana je podpora za naprave Raspberry Pi, Rock Pi N10, NanoPi in Pinebook Pro.
  • V gonilniku video je dodana sysctl-parametri kern.video.record, ki po analogiji s kern.audio.record upravlja vključitev izhoda prazne slike pri poskusu zajema videa (za dovoljenje zajema je potrebno spremeniti vrednost na 1). Procesom je dovoljeno večkratno odpiranje naprave video (rešuje težave z uporabo spletnih kamer v Firefoxu in BigBlueButton).
  • Dodane so točke sledenja za klice malloc in free, ki omogočajo s pomočjo dt in btrace sledenje dejavnostim povezanimi z razporejanjem pomnilnika. V btrace je dodana možnost ‘-n’ za analizo programa brez izvajanja kakršnih koli dejanj.
  • Izboljšana je podpora za večprocesorske sisteme (SMP). Iz splošne blokade jedra je izpeljana implementacija UNIX-socketov, dodan je splošni mutex za serializacijo operacij z msgbuf, klic uvm_pagealloc je postavljen v kategorijo mp-safe, odpravljene pa so blokade klicev getppid in sendsyslog.
  • Popravljene so težave v komponentah DRM (Direct Rendering Manager), vključno z odpravo zrušitev v gonilniku radeondrm na sistemih Powerbook5/6 in RV350, vzpostavljena je podpora DRI3 v gonilnikih amdgpu in ati, za združljivost z Linuxom pa je implementirano ustvarjanje naprav v imeniku /dev/dri/.
  • Izvedene so izboljšave v hipervizorju VMM. V backendu za upravljanje virtualnih naprav vmd je dodana podpora za nalaganje stiskanih RAM-diskov.
  • Izvedene so izboljšave v zvočni podsystemi. Omogočeno je ločeno pritrjevanje zvočnih naprav sndio samo za predvajanje in samo za snemanje. V sndiod je vključen nizkopasovni filter z končno impulzno karakteristiko (KIK-filter) osmega reda, ki je odpravljen šum zaradi prekrivanja spektralnih komponent pri ponovnem vzorčenju. Privzeto je onemogočena funkcija samodejnega zmanjšanja glasnosti, ko nova aplikacija začne predvajati (autovolume), privzeta glasnost pa je nastavljena na raven 127. Dovoljeno je mešanje zvoka iz alternativnih naprav, ki se razlikujejo po ravni podpore funkcionalnosti v sndiod.
  • Privzeto je vklopljena gradnja in namestitev orodja za odpravljanje napak LLDB.
  • V rcctl, rc.subr in rc.d je bila dodana podpora za obdelovalec logger, ki omogoča organizacijo izhoda logov iz ozadja procesov, ki pošiljajo podatke v stdout/stderr.
  • Za touchpad je omogočeno prilagajanje postavitve gumbov prek wsconsctl. V wscons je bila izboljšana obdelava sočasnih dotikov.
  • Za naprave ARM64 je bila uvedena možnost uporabe APM za pridobivanje podatkov o porabi energije in stanju baterije. Dostop procesa apmd do datotečnega sistema je omejen z uporabo klica unveil.
  • Razširjena je podpora za strojno opremo. Dodani so novi gonilniki acpige (za obdelavo dogodkov ACPI, kot je pritisk na gumb za vklop), pchgpio (za GPIO krmilnike, s katerimi so opremljeni sodobni Intel PCH), ujoy (za igralne krmilnike), uhidpp (za naprave Logitech HID++). Dodana je podpora za razširitve AMD Vi in Intel VTD IOMMU za izolacijo PCI naprav in preprečevanje nepravilnega dostopa do pomnilnika. Dodana je podpora za računalnike Lynloong LM9002/9003 in LM9013. V gonilnike pcamux in imxiic je bila dodana podpora ACPI.
  • Izboljšana je podpora za omrežne adapterje: mvpp (SFP+ in 10G za Marvel Armada Ethernet), mvneta (1000base-x in 2500base-x), mvsw (Marvel SOHO stikala), rge (podpora Wake on LAN), Netgear ProSecure UTM25. Za brezžične gonilnike iwm, iwn in athn je bila dodana podpora RA (802.11n Tx Rate Adaptation). V brezžičnem skladu je bila uvedena samodejna izbira načinov 11a/b/g/n/ac pri uporabi omrežnega vmesnika kot dostopne točke.
  • V omrežnem skladu je implementiran gonilnik veb (Virtual Ethernet Bridge). Uvedena je podpora za način nadzora, pri katerem prispeli paketi na omrežni vmesnik niso predani omrežni skladbi za obdelavo, temveč se lahko nanje uporabljajo mehanizmi za analizo prometa, kot je BPF. Dodan je nov tip omrežnih vmesnikov — etherbridge. Omogočena je (ukaz route sourceaddr) preusmeritev izvornega naslova za programe, v obvijanju privzeti algoritem izbire naslova. IP-naslove Zagotavljena je samodejna aktivacija omrežnih vmesnikov ob vklopu načina samodejnega nastavljanja (AUTOCONF4 in AUTOCONF6).
  • V inštalatorju je bila implementirana dobava stisnjene slike ram-disk (bsd.rd) na vseh platformah, ki podpirajo tovrstno nalaganje.
  • Uvedena je izhodna funkcionalnost preko syslog za opozorilo o uporabi v printf nadomestitve za formatiranje nizov «%n».
  • V demonu usmerjanja OpenBGPD je bila dodana podpora za protokol RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Dodana je ukaz «bgpctl show rtr» za prikaz osnovnih informacij o RTR seansah.
  • Koda ospfd in ospf6d je bila prestrukturirana z namenom enotnosti z drugimi protokoli usmerjanja in enostavnejšega vzdrževanja. Omogočena je podpora za omrežne vmesnike v načinu točka-točka.
  • V vgrajenem HTTP strežniku httpd so bile implementirane nove možnosti «location (found|notfound)» za preverjanje obstoja virov.
  • V orodju rpki-client je bila dodana podpora za protokol RRDP (The RPKI Repository Delta Protocol, RFC 8182). Omogočeno je določanje več kot enega URI v datoteki TAL.
  • V orodju dig je bila dodana podpora za RFC 8914 (Extended DNS Error) in RFC 8976 (ZONEMD).
  • V dhclient-u je bila dodana možnost določanja možnosti v datotekah hostname.if, z uporabo vrstic «dhcp».
  • V demonu snmpd je bila implementirana popolna podpora za pretvorbo Trapv1 v Trapv2 (RFC 3584). V snmpd.conf so bila dodana nova ključna beseda read, write in notify. V orodju snmp je bila dodana podpora za SMI enumeracije.
  • V DNS resolverju unwind je bila dodana podpora za DNS64 in sprejemanje povezav preko TCP vtičnika.
  • V orodju ftp je bila dodana podpora za trajne preusmeritve (RFC 7538) in možnost pošiljanja glave If-Modified-Since pri pošiljanju zahtevkov preko HTTP/HTTPS.
  • V OpenSMTPD je bila dodana možnost «-a» za izvajanje avtentikacije pred pošiljanjem sporočila. Orodja za šifriranje so prešla na uporabo knjižnice libtls. Na poslušalnih soketih za TLS je bila omogočena nastavitev več certifikatov, izbranih glede na ime (SNI). domene (SNI).
  • V LibreSSL je bila dodana podpora za protokol DTLSv1.2. Omogočena je bila izgradnja le libtls (‘--enable-libtls-only’) brez libcrypto in libssl.
  • Posodobljen je paket OpenSSH. Podroben pregled izboljšav si lahko ogledate tukaj: OpenSSH 8.5, OpenSSH 8.6.
  • Število paketov za arhitekturo AMD64 je znašalo 11310, za aarch64 — 10943, za i386 — 10468. Med različicami aplikacij v paketih: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 in ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Posodobljene komponente tretjih razvijalcev, vključene v OpenBSD 6.9:

    • Grafični sklop Xenocara na osnovi X.Org 7.7 s xserver 1.20.10 + popravki, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ popravki)
    • GCC 4.2.1 (+ popravki) in 3.3.6 (+ popravki)
    • Perl 5.32.1 (+ popravki)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ popravki)
    • Gdb 6.3 (+ popravki)
    • Awk 18.12.2020
    • Expat 2.2.10

Nova pesem "Vetera Novis" je ob izidu OpenBSD 6.9.

Izvor: opennet.ru

Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki 🔥 Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki | ProHoster