Kategorija: Blog

Izdaja serverskih aplikacija NGINX Unit 1.24.0

Izdan je poslužitelj aplikacija NGINX Unit 1.24, koji se razvija kao rješenje za pokretanje web aplikacija na raznim programskim jezicima (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js i Java). Pod upravom NGINX Unit-a može se istovremeno izvršavati više aplikacija na različitim programskim jezicima, a parametre pokretanja moguće je dinamički mijenjati bez potrebe za uređivanjem konfiguracijskih datoteka i ponovnim pokretanjem. Kod […]

Izdanje Electron 13.0.0, platforme za izradu aplikacija na osnovu Chromium motora

Pripremljeno je izdanje platforme Electron 13.0.0, koja pruža samodostatni okvir za razvoj višekratnih korisničkih aplikacija, koristeći kao osnovne komponente Chromium, V8 i Node.js. Značajna promjena broja verzije povezana je s ažuriranjem na kodnu osnovu Chromium 91, platformu Node.js 14.16 i JavaScript motor V8 9.1. Među promjenama u novom izdanju: Dodano svojstvo process.contextIsolated za utvrđivanje izvođenja trenutnog […]

Izdanje biblioteke PCRE2 10.37

Izšel je novi sklop knjižnice PCRE2 10.37, ki ponuja nabor funkcij v jeziku C za izvajanje regularnih izrazov in metod za ujemanje vzorcev, ki so po sintaksi in semantiki podobni regularnim izrazom jezika Perl 5. PCRE2 je prenovljena različica izvirne knjižnice PCRE z nezdružljivim API-jem in razširjenimi zmogljivostmi. Knjižnico so razvili razvijalci poštnega strežnika Exim in se distribuira […]

Microsoft je izdal upravljalnik paketov Windows Package Manager 1.0, podoben apt in dnf.

Podjetje Microsoft je objavilo izdajo upravitelja paketov Windows Package Manager 1.0 (winget), ki ponuja sredstva za namestitev aplikacij z uporabo ukazne vrstice. Koda je napisana v jeziku C++ in se distribuira pod licenco MIT. Paketi se nameščajo iz repozitorija, ki ga podpira skupnost. Za razliko od namestitve programov iz kataloga Microsoft Store, winget omogoča namestitev aplikacij brez odvečne trženjske vsebine in […]

Izdaje upravitelja paketov Pacman 6.0 in namestitvenega orodja Archinstall 2.2.0

Na voljo so nove izdaje upravitelja paketov Pacman 6.0.0 in namestitvenega programa Archinstall 2.2.0, ki se uporabljata v distribuciji Arch Linux. Glavne spremembe v Pacman 6.0: dodana podpora za prenos datotek v več paralelnih tokovih. Izveden je izhodni niz za prikaz napredka prenosa podatkov. Za izklop prikaza napredka lahko v datoteki pacman.conf navedete možnost „—noprogressbar“. Omogočeno je samodejno preskakovanje ogledov, pri katerih […]

Odprt je koda storitve za preverjanje gesel HaveIBeenPwned

Troy Hunt je odprl izvorno kodo storitve za preverjanje kompromitiranih gesel „Have I Been Pwned?“ (haveibeenpwned.com), ki preverja bazo z 11,2 milijarde računov, ki so bili zlorabljeni zaradi vdorov na 538 spletnih mest. Sprva je bilo o nameri odpiranja kode projekta objavljeno avgusta lani, vendar se je postopek zavlekel in koda je bila objavljena šele zdaj. Koda storitve je napisana v […]

Mozilla je povzela načrte za podporo tretji različici Chrome manifestacije v Firefoxu

Podjetje Mozilla je objavilo načrt za implementacijo tretje različice manifestacije Chrome v Firefoxu, ki določa možnosti in vire, ki jih dopolnila ponujajo. Tretja različica manifestacije je bila deležna kritik zaradi kršenja delovanja številnih dopolnil, ki blokirajo neželeno vsebino in zagotavljajo varnost. V Firefoxu nameravajo implementirati skoraj vse možnosti in omejitve nove manifestacije, vključno z deklarativnim API-jem za filtriranje vsebine (declarativeNetRequest), […]

Protokol QUIC je prejel status predlaganega standarda

IETF (Internet Engineering Task Force), ki se ukvarja z razvojem protokolov in arhitekture interneta, je končal oblikovanje RFC za protokol QUIC in objavil povezane specifikacije pod identifikatorji RFC 8999 (neodvisne od različice lastnosti protokola), RFC 9000 (transport preko UDP), RFC 9001 (TLS-šifriranje komunikacijskega kanala QUIC) in RFC 9002 (upravljanje obremenitve in določanje izgube paketov pri prenosu podatkov). […]

Podjetje Virtuozzo je objavilo distribucijo VzLinux, ki je namenjena zamenjavi CentOS 8

Podjetje Virtuozzo (bivši oddelek podjetja Parallels), ki razvija serversko programsko opremo za virtualizacijo na podlagi odprtih projektov, je začelo javno distribucijo distribucije VzLinux, ki je bila prej uporabljena kot osnovni operacijski sistem za platformo virtualizacije, ki jo razvija podjetje, in različne komercialne izdelke. Od zdaj naprej je VzLinux na voljo vsem zainteresiranim in se pozicionira kot zamenjava za CentOS 8, pripravljeno za delovne uvedbe. Za prenos […]

Izdaja paketa Simply Linux 9.1.

Podjetje Bazalt SPO je napovedalo izdajo distribucije Simply Linux 9.1, ki temelji na deveti platformi ALT. Izdelek se distribuira v okviru licenčne pogodbe, ki ne prenese pravice do distribucije distribucije, vendar omogoča neomejeno uporabo sistema fizičnim in pravnim osebam. Distribucija se dobavlja v različicah za arhitekture x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) in lahko […]

Objavljena je baza podataka immudb 1.0, koja osigurava zaštitu od izmena podataka

Predstavljen je bil pomemben izid DBMS immudb 1.0, ki zagotavlja nespremenljivost in shranjevanje vseh kdorkoli dodanih podatkov ter nudi zaščito pred ponovnim spreminjanjem in omogoča kriptografske dokaze o lastništvu podatkov. Projekt je prvotno potekal kot specializirano NoSQL skladišče, ki upravlja s podatki v formatu ključ/vrednost, vendar se od izdaje 1.0 immudb pozicionira kot polnopravni DBMS z podporo za SQL. Koda […]

Razpoložljiv je paket AlmaLinux 8.4, ki nadaljuje razvoj CentOS 8.

Objavljen je izdanak distribucije AlmaLinux 8.4, usklađen s distribucijom Red Hat Enterprise Linux 8.4. Izdanja su pripremljena za arhitekturu x86_64 u obliku pokretačke (709 MB), minimalne (1.9 GB) i potpune slike (9.8 GB). Uskoro će biti objavljena izdanja i za arhitekturu ARM. Distribucija se smatra spremnom za radne implementacije i potpuno je identična RHEL-u po funkcionalnosti, uz […]

Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki 🔥 Kupite zanesljivo gostovanje za spletne strani z zaščito pred DDoS, VPS VDS strežniki | ProHoster