Versioni e sistemit operativ UNIX-like OpenBSD 6.9 është prezantuar. Ky është numri 50 i projektit, që këtë vit mbush 26 vjet. Projekti OpenBSD u themelua nga Theo de Raadt në 1995 pas një konflikti me zhvilluesit e NetBSD, si rezultat i të cilit Theo humbi qasjen në depot CVS të NetBSD. Pas kësaj, Theo de Raadt me një grup bashkëpunëtorësh krijoi një sistem operativ të ri të hapur mbi bazën e pemës së kodit burimor të NetBSD, me qëllime kryesore si portabiliteti (mbështetet 13 platforma harduerike), standardizimi, funksionimi i saktë, siguria aktive dhe mjete të integruara kriptografike. Madhësia e imazhit të plotë instalues ISO të sistemit bazë OpenBSD 6.9 është 544 MB.
PĂ«rveç sistemit operativ, projekti OpenBSD njihet pĂ«r komponentĂ«t e tij, tĂ« cilĂ«t janĂ« shpĂ«rndarĂ« nĂ« sisteme tĂ« tjera dhe janĂ« treguar si disa nga zgjidhjet mĂ« tĂ« sigurta dhe me cilĂ«si tĂ« lartĂ«. NdĂ«r to: LibreSSL (fork i OpenSSL), OpenSSH, filtri i paketave PF, demonĂ«t e ruterizimit OpenBGPD dhe OpenOSPFD, serveri NTP OpenNTPD, serveri i postĂ«s OpenSMTPD, shumĂ«kĂ«shtuesi i terminaleve tekstuale (analog i GNU screen) tmux, demo identd me pĂ«rvetĂ«simin e protokollit IDENT, alternativa BSDL e paketĂ«s GNU groff â mandoc, protokolli pĂ«r organizimin e sistemeve tĂ« qĂ«ndrueshme CARP (Protokolli i RedundancĂ«s sĂ« Adresave tĂ« Zakonshme), serveri http i lehtĂ«, utilitari i sinkronizimit tĂ« skedarĂ«ve OpenRSYNC.
Përmirësimet kryesore:
- Në drejtuesin softraid është shtuar një mod të RAID1C me realizimin e RAID1 programor me enkriptimin e të dhënave.
- NĂ« paketĂ« janĂ« pĂ«rfshirĂ« dy procese tĂ« reja tĂ« prapme â dhcpleased dhe resolvd, tĂ« cilat punojnĂ« sĂ« bashku me slaacd dhe unwind pĂ«r konfigurimin automatik tĂ« intervistave rrjet dhe pĂ«rcaktimin e emrave nĂ« DNS. NĂ« dhcpleased Ă«shtĂ« realizuar protokolli DHCP pĂ«r marrjen e adresave IP, ndĂ«rsa nĂ« resolvd Ă«shtĂ« siguruar menaxhimi i pĂ«rmbajtjes sĂ« resolv.conf nĂ« pĂ«rputhje me tĂ« dhĂ«nat pĂ«r serverĂ«t e emrave tĂ« marra nga dhcpleased, slaacd dhe drejtuesit si umb.
- ĂshtĂ« shtuar mbĂ«shtetje fillestare pĂ«r pajisjet Apple me procesorin M1. Kjo pĂ«rfshin njohjen e bĂ«rthamave arm64 tĂ« Apple Icestorm/Firestorm dhe mbĂ«shtetje pĂ«r çipat pa tel BCM4378 tĂ« pĂ«rdorur nĂ« SoC Apple M1.
- ĂshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r platformĂ«n powerpc64, e zhvilluar pĂ«r sisteme 64-bit bazuar nĂ« procesorĂ«t POWER8 dhe POWER9. Krahasuar me versionin e kaluar, pĂ«r powerpc64 Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r mekanizmin e mbrojtjes RETGUARD, Ă«shtĂ« shtuar drejtuesi astfb pĂ«r framebuffer-in Aspeed BMC, janĂ« zgjidhur problemet me drejtuesit radeondrm dhe amdgpu nĂ« sisteme me GPU AMD, nĂ« ndĂ«rtimet e bĂ«rthamĂ«s pĂ«r RAM-disk Ă«shtĂ« shtuar mundĂ«sia e ngjarjes rrjet, Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r modet e kursimit tĂ« energjisĂ« tĂ« CPU POWER9, dhe Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r pĂ«rjashtimet e gjeneruara gjatĂ« operacioneve me pikĂ« qĂ« duket, duke implementuar mbĂ«shtetje pĂ«r IPMI pĂ«r sistemet PowerNV.
- Platformat ARM64 mbĂ«shtet CPU Cortex-A78AE, Cortex-X1 dhe Neoverse V1, janĂ« realizuar variante tĂ« optimizuara pĂ«r ARM64 tĂ« thirrjeve copyin, copyout dhe kcopy, Ă«shtĂ« shtuar driveri cryptox pĂ«r mbĂ«shtetje tĂ« zgjerimeve kriptografike ARMv8, si dhe driveri smmu pĂ«r RM System MMU me mbĂ«shtetje pĂ«r Guard Page. ĂshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r pajisjet Raspberry Pi, Rock Pi N10, NanoPi dhe Pinebook Pro.
- Në driverin video është shtuar parametri sysctl kern.video.record, i cili, si në rastin e kern.audio.record, menaxhon aktivizimin e daljes së imazhit të zbrazët kur përpjeket të kapet video (për lejen e kapjes kërkohet të ndryshohet vlera në 1). Proceset janë lejuar të hapin shumë herë pajisjen video (zgjidh problemet me përdorimin e kamerave web në Firefox dhe BigBlueButton).
- JanĂ« shtuar piketat e ndjekjes pĂ«r thirrjet malloc dhe free, duke lejuar, me ndihmĂ«n e dt dhe btrace, ndjekjen e aktivitetit tĂ« lidhur me shpĂ«rndarjen e memories. NĂ« btrace Ă«shtĂ« shtuar opsioni â-nâ pĂ«r analizimin e programit pa ekzekutimin e ndonjĂ« veprimi.
- ĂshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r sistemet shumĂ«procelore (SMP). Nga bllokimi i pĂ«rgjithshĂ«m i bĂ«rthamĂ«s Ă«shtĂ« nxjerrĂ« implementimi i soketeve UNIX, Ă«shtĂ« shtuar njĂ« mutex i pĂ«rbashkĂ«t pĂ«r serializimin e operacioneve me msgbuf, thirrja uvm_pagealloc Ă«shtĂ« transformuar nĂ« njĂ« thirrje mp-safe, dhe janĂ« hequr bllokimet nga thirrjet getppid dhe sendsyslog.
- Janë korrigjuar problemet në komponentët DRM (Direct Rendering Manager), duke përfshirë eliminimin e crash-eve në driverin radeondrm në sistemet Powerbook5/6 dhe RV350, është vendosur mbështetje DRI3 në driverat amdgpu dhe ati, për të siguruar pajtueshmërinë me Linux është realizuar krijimi i pajisjeve në katalogun /dev/dri/.
- Janë bërë përmirësime në hipervizorin VMM. Në backend-in e menaxhimit të makinave virtuale vmd është shtuar mbështetje për ngarkimin e disqeve RAM të kompresuar.
- JanĂ« pĂ«rmirĂ«suar funksionet e sistemit tĂ« zĂ«rit. ĂshtĂ« ofruar mundĂ«sia e lidhjes sĂ« veçantĂ« tĂ« pajisjeve tĂ« zĂ«rit sndio vetĂ«m pĂ«r reproduktim dhe vetĂ«m pĂ«r regjistrim. NĂ« sndiod Ă«shtĂ« aktivizuar njĂ« filtĂ«r me frekuencĂ« tĂ« ulĂ«t me karakteristika impulsive (KIK-filtĂ«r) i rendit tĂ« tetĂ«, qĂ« ka lejuar eliminimin e zhurmave nga mbivendosjet e spektreve gjatĂ« risampling. Si parazgjedhje, Ă«shtĂ« çaktivizuar funksioni automatike i uljes sĂ« volumit kur njĂ« program i ri fillon pĂ«r tĂ« luajtur (autovolume), me njĂ« nivel tĂ« volumit 127 si vlerĂ« tĂ« parazgjedhur. ĂshtĂ« lejuar miksimi i zĂ«rit nga pajisje alternative, tĂ« cilat kanĂ« nivele tĂ« ndryshme funksionaliteti nĂ« sndiod.
- Aktivizuar si parazgjedhje ndihmuesi dhe instalimi i ndihmuesit LLDB.
- Në rcctl, rc.subr dhe rc.d është shtuar mbështetje për trajtuesin logger, duke mundësuar organizimin e daljes së protokolleve nga proceset në sfond që dërgojnë të dhëna në stdout/stderr.
- Për touchpad-et është ofruar mundësia për të përshtatur konfigurimin e butonave përmes wsconsctl. Në wscons është përmirësuar trajtimi i prekjeve të shumta.
- Për pajisjet ARM64 është realizuar mundësia e përdorimit të APM për marrjen e të dhënave mbi konsumimin e energjisë dhe karikimin e baterisë. Për të kufizuar qasjen e procesit apmd në sistemin e skedarëve, është përdorur thirrja unveil.
- ĂshtĂ« zgjeruar mbĂ«shtetja pĂ«r pajisje. JanĂ« shtuar drivera tĂ« rinj acpige (pĂ«r trajtimin e ngjarjeve ACPI, siç Ă«shtĂ« shtypja e butonit tĂ« energjisĂ«), pchgpio (pĂ«r kontrolluesit GPIO qĂ« janĂ« tĂ« pajisur me Intel PCH moderne), ujoy (pĂ«r kontrolluesit e lojĂ«rave), uhidpp (pĂ«r pajisjet Logitech HID++). ĂshtĂ« shtuar mbĂ«shtetje pĂ«r zgjatjet AMD Vi dhe Intel VTD IOMMU pĂ«r izolimin e pajisjeve PCI dhe bllokimin e qasjes tĂ« pasaktĂ« nĂ« memorie. ĂshtĂ« shtuar mbĂ«shtetje pĂ«r kompjuterĂ«t Lynloong LM9002/9003 dhe LM9013. NĂ« driverat pcamux dhe imxiic Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r ACPI.
- ĂshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r adapterĂ«t rrjetĂ«: mvpp (SFP+ dhe 10G pĂ«r Marvel Armada Ethernet), mvneta (1000base-x dhe 2500base-x), mvsw (pĂ«r ndĂ«rlidhĂ«sit Marvel SOHO), rge (mbĂ«shtetje pĂ«r Wake on LAN), Netgear ProSecure UTM25. PĂ«r driverĂ«t wireless iwm, iwn dhe athn Ă«shtĂ« shtuar mbĂ«shtetje RA (802.11n Tx Rate Adaptation). NĂ« strukturĂ«n wireless Ă«shtĂ« vendosur zgjedhja automatike e modesh 11a/b/g/n/ac gjatĂ« pĂ«rdorimit tĂ« ndĂ«rfaqes rrjetĂ« si pikĂ« qasjeje.
- NĂ« strukturĂ«n rrjetĂ« Ă«shtĂ« realizuar driveri veb (Virtual Ethernet Bridge). ĂshtĂ« realizuar mbĂ«shtetje pĂ«r modin e monitoringut, ku paketat qĂ« vijnĂ« nĂ« ndĂ«rfaqen rrjetĂ« nuk i kalojnĂ« strukturĂ«s rrjetĂ« pĂ«r pĂ«rpunim, por mund t'i nĂ«nshtrohen mekanizmave tĂ« analizĂ«s sĂ« trafikut, si BPF. ĂshtĂ« shtuar njĂ« lloj i ri ndĂ«rfaqesh rrjetĂ« â etherbridge. ĂshtĂ« ofruar mundĂ«sia (komanda route sourceaddr) pĂ«r tĂ« ripĂ«rcaktuar burimin Adresa IP pĂ«r programet, duke kaluar mbi algoritmin standard tĂ« zgjedhjes sĂ« adresĂ«s. ĂshtĂ« siguruar ngjitja automatike e ndĂ«rfaqeve rrjetĂ« kur aktivizohet moda e vetĂ«konfigurimit (AUTOCONF4 dhe AUTOCONF6).
- Në installer është realizuar ofrimi i një imazhi të kompresuar ram-disk (bsd.rd) në të gjitha platformat që mbështesin një ngarkesë të tillë.
- ĂshtĂ« realizuar dalja pĂ«rmes syslog e njĂ« paralajmĂ«rimi pĂ«r pĂ«rdorimin nĂ« printf tĂ« zĂ«vendĂ«simit tĂ« formatimit tĂ« vargjeve "%n".
- Në demonin e rutimit OpenBGPD është shtuar mbështetje për protokollin RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Për të shfaqur informacionin kryesor rreth seancave RTR është shtuar comanda "bgpctl show rtr".
- ĂshtĂ« bĂ«rĂ« njĂ« restrukturim i kodit ospfd dhe ospf6d me qĂ«llim unifikimin e tyre me demonĂ«t e tjerĂ« tĂ« rutimit dhe thjeshtimin e mbĂ«shtetjes. ĂshtĂ« vendosur mbĂ«shtetje pĂ«r ndĂ«rfaqet rrjetore nĂ« modin pikĂ«-pikĂ«.
- Në serverin e integruar HTTP httpd janë implementuar mundësi të reja "location (found|notfound)" për të kontrolluar ekzistencën e burimeve.
- NĂ« utilitarin rpki-client Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r protokollin RRDP (The RPKI Repository Delta Protocol, RFC 8182). ĂshtĂ« realizuar mundĂ«sia e specifikimit tĂ« mĂ« shumĂ« se njĂ« URI nĂ« skedarin TAL.
- Në utilitarin dig është implementuar mbështetje për RFC 8914 (Extended DNS Error) dhe RFC 8976 (ZONEMD).
- Në dhclient është shtuar mundësia e specifikimit të opsioneve në skedarët hostname.if, duke përdorur rreshtat "dhcp".
- Në demonin snmpd është realizuar mbështetje e plotë për konvertimin e Trapv1 në Trapv2 (RFC 3584). Në snmpd.conf janë shtuar fjalë kyçe të reja read, write dhe notify. Në utilitarin snmp është realizuar mbështetje për enumerimet SMI.
- Në DNS resolver unwind është shtuar mbështetje për DNS64 dhe pranimin e lidhjeve përmes portit TCP.
- Në utilitarin ftp është shtuar mbështetje për rikthimet e përhershme (RFC 7538) dhe mundësia e dërgimit të titullit If-Modified-Since gjatë dërgimit të kërkesave përmes HTTP/HTTPS.
- Në OpenSMTPD është shtuar opsioni "-a" për të kryer autentifikimin para dërgimit të mesazhit. Mjetet e enkriptimit janë transferuar për të përdorur bibliotekën libtls. Në soketët dëgjues për TLS është realizuar mundësia e konfigurimit të certifikatave të shumta, të zgjedhura në përputhje me emrin (SNI). e domenit (SNI).
- NĂ« LibreSSL Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r protokollin DTLSv1.2. ĂshtĂ« realizuar mundĂ«sia e ndĂ«rtimit vetĂ«m tĂ« libtls (â--enable-libtls-onlyâ) pa libcrypto dhe libssl.
- Paketa OpenSSH është përditësuar. Një pasqyrë e detajuar e përmirësimeve mund të shihet këtu: OpenSSH 8.5, OpenSSH 8.6.
- Numri i portave pĂ«r arkitekturĂ«n AMD64 ishte 11310, pĂ«r aarch64 â 10943, pĂ«r i386 â 10468. NĂ« mesin e versioneve tĂ« aplikacioneve nĂ« porte: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 dhe ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.
Janë përditësuar komponentët e zhvilluesve të tretë, të cilët janë përfshirë në OpenBSD 6.9:
- Grafikët e stekut Xenocara mbi bazën e X.Org 7.7 me xserver 1.20.10 + patches, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
- LLVM/Clang 10.0.1 (+ patches)
- GCC 4.2.1 (+ patch) dhe 3.3.6 (+ patch)
- Perl 5.32.1 (+ patch)
- NSD 4.3.6
- Unbound 1.13.1
- Ncurses 5.7
- Binutils 2.17 (+ patch)
- Gdb 6.3 (+ patch)
- Awk 18.12.2020
- Expat 2.2.10
Me dalimi i lansimit të versionit OpenBSD 6.9, është e lidhur kënga e re "Vetera Novis".
Burimi: opennet.ru
