Protokolli QUIC mori statusin e standardit të propozuar

Komiteti IETF (Internet Engineering Task Force), i cili merret me zhvillimin e protokollëve dhe arkitekturës së internetit, përfundoi përgatitjen e RFC për protokollin QUIC dhe publikoi specifikimet e lidhura me të me identifikuesit RFC 8999 (tipare të protokollit të pavarura nga versioni), RFC 9000 (transport mbi UDP), RFC 9001 (kriptimi TLS i kanalit të komunikimit QUIC) dhe RFC 9002 (menaxhimi i ngarkesës dhe përcaktimi i humbjes së paketave gjatë transmetimit të të dhënave).

RFC mori statusin "Standart i Propozimit", pas së cilës do të fillojë puna për t'i dhënë RFC statusin e standartit bërë (Draft Standard), që në fakt do të thotë stabilizimin e plotë të protokollit dhe marrjen e parasysh të gjithë komenteve të shprehura. Protokolli HTTP/3, i cili përcakton përdorimin e protokollit QUIC si transport për HTTP/2, aktualisht është në fazën e specifikimit të bërë, por së shpejti do të standardizohet gjithashtu në IETF.

Pritet që standardizimi i QUIC të japë një shtysë për adoptimin më të gjerë të këtij protokolli, si dhe për zhvillimin e zgjerimeve të bazuara mbi të, si WebTransport (teknologji për dërgimin dhe marrjen e të dhënave midis shfletuesit dhe server) dhe MASQUE (teknologji për proxy të lidhjeve, që zgjeron mundësitë e SOCKS dhe HTTP CONNECT, duke përdorur HTTPS mbi QUIC si transport).

Kujtojmë, protokolli QUIC (Quick UDP Internet Connections) është zhvilluar që nga viti 2013 nga kompania Google si një alternativë për lidhjen TCP+TLS për Web, që zgjidh problemet me kohën e gjatë të krijimit dhe rregullimit të lidhjeve në TCP dhe eleminon vonesat gjatë humbjes së paketave në procesin e transmetimit të të dhënave. QUIC është një shtresë mbi protokollin UDP, që mbështet shumë lidhje dhe ofron metoda kriptimi, ekuivalente me TLS/SSL. Gjatë zhvillimit të standartit në IETF, janë bërë ndryshime në protokoll, duke çuar në ekzistencën e dy degëve paralele, një për HTTP/3, dhe tjetra e mbështetur nga Google (Chrome mbështet të dy variantet, ndërsa Firefox mbështet variantin IETF).

Karakteristikat kryesore të QUIC:

  • Siguri e lartĂ«, e ngjashme me TLS (nĂ« thelb QUIC ofron mundĂ«sinĂ« e pĂ«rdorimit tĂ« TLS mbi UDP);
  • Kontrolli mbi integritetin e rrjedhĂ«s, qĂ« parandalon humbjen e pacakove;
  • MundĂ«sia pĂ«r tĂ« vendosur menjĂ«herĂ« njĂ« lidhje (0-RTT, nĂ« rreth 75% tĂ« rasteve tĂ« dhĂ«nat mund tĂ« transmetohen menjĂ«herĂ« pas dĂ«rgimit tĂ« paketĂ«s sĂ« vendosjes sĂ« lidhjes) dhe pĂ«r tĂ« siguruar vonesa minimale midis dĂ«rgimit tĂ« kĂ«rkesĂ«s dhe marrjes sĂ« pĂ«rgjigjes (RTT, Round Trip Time);
  • PĂ«rdorimi i njĂ« numri tjetĂ«r sekonda pĂ«r dĂ«rgimin e paketave pĂ«rsĂ«ritĂ«se, gjĂ« qĂ« lejon shmangien e dyshimeve nĂ« pĂ«rcaktimin e paketave tĂ« pranuara dhe eliminon vonesat;
  • Humorja e paketĂ«s ndikon vetĂ«m nĂ« dĂ«rgesĂ«n e fluksit lidhur me tĂ« dhe nuk ndalon dĂ«rgimin e tĂ« dhĂ«nave nĂ« flukset qĂ« dĂ«rgohen paralelisht nĂ«pĂ«rmjet lidhjes aktuale;
  • Mjetet pĂ«r korrigjimin e gabimeve, qĂ« minimizojnĂ« vonesat pĂ«r shkak tĂ« dĂ«rgimit pĂ«rsĂ«ritĂ«s tĂ« paketave tĂ« humbura. PĂ«rdorimi i kodeve speciale pĂ«r korrigjimin e gabimeve nĂ« nivelin e paketĂ«s pĂ«r tĂ« reduktuar situatat qĂ« kĂ«rkojnĂ« dĂ«rgim pĂ«rsĂ«ritĂ«s tĂ« tĂ« dhĂ«nave tĂ« paketĂ«s sĂ« humbur.
  • KufijtĂ« e bllokave kriptografikĂ« janĂ« pĂ«rputhur me kufijtĂ« e paketave QUIC, duke zvogĂ«luar ndikimin e humbjeve tĂ« paketave nĂ« dekodimin e pĂ«rmbajtjes sĂ« paketave tĂ« ardhshme;
  • Mungesa e problemeve me bllokimin e radhĂ«s TCP;
  • MbĂ«shtetje pĂ«r identifikuesin e lidhjes, qĂ« lejon zvogĂ«limin e kohĂ«s pĂ«r vendosjen e lidhjes pĂ«rsĂ«ritĂ«se pĂ«r klientĂ«t mobilĂ«;
  • MundĂ«sia e lidhjes sĂ« mekanizmave tĂ« zgjeruar tĂ« kontrollit tĂ« ngarkesĂ«s sĂ« lidhjes;
  • PĂ«rdorimi i teknikave tĂ« parashikimit tĂ« kapacitetit nĂ« çdo drejtim pĂ«r tĂ« siguruar intensitetin optimal tĂ« dĂ«rgimit tĂ« paketave, duke parandaluar rĂ«nien nĂ« njĂ« gjendje ngarkese, ku humbjet e paketave vĂ«rehen;
  • Rritje e dukshme e performancĂ«s dhe kapacitetit krahasuar me TCP. PĂ«r shĂ«rbimet video si YouTube, aplikimi i QUIC ka treguar njĂ« reduktim prej 30% tĂ« operacioneve tĂ« ri-buffering gjatĂ« shikimit tĂ« videove.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster