Ka ndodhi lansimi i serverit të lehtë http lighttpd 1.4.65, që përpiqet të kombinojë performancën e lartë, sigurinë, përputhshmërinë me standardet dhe fleksibilitetin e konfigurimit. Lighttpd është i përshtatshëm për përdorim në sisteme me ngarkesë të lartë dhe është fokusuar në konsum të ulët të memorjes dhe burimeve të CPU. Në këtë version janë prezantuar 173 ndryshime. Kodi i projektit është shkruar në gjuhën C dhe shpërndahet nën licencën BSD.
Novitetet kryesore:
- ĂshtĂ« shtuar mbĂ«shtetje pĂ«r WebSocket mbi HTTP/2, si dhe Ă«shtĂ« realizuar RFC 8441, qĂ« pĂ«rshkruan mekanizmin pĂ«r aktivizimin e protokollit WebSockets nĂ« njĂ« rrjedhĂ« brenda lidhjes HTTP/2.
- ĂshtĂ« realizuar njĂ« skemĂ« e zgjeruar e menaxhimit tĂ« prioritetit, qĂ« i lejon klientit tĂ« ndikojĂ« nĂ« prioritetin e tĂ« dhĂ«nave tĂ« dĂ«rguara server (RFC 9218), si dhe tĂ« menaxhojĂ« prioritetet gjatĂ« pĂ«rmirĂ«simeve tĂ« kĂ«rkesave. PĂ«r HTTP/2 Ă«shtĂ« siguruar mbĂ«shtetje pĂ«r kornizĂ«n PRIORITY_UPDATE.
- Në konfigurimet lighttpd.conf është shtuar mbështetje për krahasime të kushtëzuara me lidhjen në fillim (=^) dhe fundin (=$) e vargut. Këto kontrolle të vargut janë shumë më të shpejta se shprehjet e rregullta dhe janë të mjaftueshme për shumë kontrolle të thjeshta.
- NĂ« mod_webdav Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r operacione tĂ« pjesshme PUT (duke pĂ«rfshirĂ« pjesĂ« tĂ« tĂ« dhĂ«nave me anĂ« tĂ« titullit Range). PĂ«r ta pĂ«rfshirĂ«, mund tĂ« pĂ«rdorni opsionin âwebdav.opts += («partial-put-copy-modifyâ => «enable»).
- NĂ« mod_accesslog Ă«shtĂ« shtuar opsioni âaccesslog.escaping = âjsonâ.
- Në mod_deflate është shtuar mbështetje për ndërtim me libdeflate.
- është përshpejtuar dërgimi i trupit të kërkesës përmes HTTP/2.
- Vlera e parametrave server.max-keep-alive-requests është ndryshuar nga 100 në 1000.
- Në listën e MIME-tipopve, «application/javascrit» është zëvendësuar me «text/javascript» (RFC 9239).
Në të ardhmen, është planifikuar përdorimi i cilësimeve më të rrepta të enkriptimit për TLS dhe çaktivizimi për default i enkriptimeve të vjetra. Cilësimi CipherString do të ndryshohet nga vlera «HIGH» në «EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384». Gjithashtu, planifikohet që opsionet e vjetra TLS të hiqen: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Për më tepër, do të vazhdojë pastrimi i mini-moduleve, të cilat mund të zëvendësohen me një realizim më fleksibël Lua të mod_magnet. Në veçanti, është e planifikuar të eliminohen modulët mod_evasive, mod_secdownload, mod_uploadprogress dhe mod_usertrack.
Burimi: opennet.ru
