Shpërndarja OpenBSD 7.2

Lëshohet versioni i sistemit operativ UNIX të lirë OpenBSD 7.2. Projekti OpenBSD u themelua nga Theo de Raadt në vitin 1995, pas një konflikti me zhvilluesit e NetBSD, që rezultoi në mbylljen e qasjes së Theo-s në repo-n e NetBSD. Pas kësaj, Theo de Raadt së bashku me një grup mbështetësish krijoi një sistem operativ të ri të hapur bazuar në kodin burimor të NetBSD, me qëllimet kryesore të zhvillimit që të ishin portabiliteti (mbështeten 13 platforma hardueri), standardizimi, funksionimi i saktë, siguria proaktive dhe mjetet e integruara kriptografike. Madhësia e imazhit ISO të plotë për sistemin bazë OpenBSD 7.2 është 556 MB.

PĂ«rveç sistemit operativ, projekti OpenBSD njihet pĂ«r komponentĂ«t e tij, tĂ« cilĂ«t janĂ« shpĂ«rndarĂ« nĂ« sisteme tĂ« tjera dhe janĂ« treguar si disa nga zgjidhjet mĂ« tĂ« sigurta dhe me cilĂ«si tĂ« lartĂ«. NdĂ«r to: LibreSSL (fork i OpenSSL), OpenSSH, filtri i paketave PF, demonĂ«t e ruterizimit OpenBGPD dhe OpenOSPFD, serveri NTP OpenNTPD, serveri i postĂ«s OpenSMTPD, shumĂ«kĂ«shtuesi i terminaleve tekstuale (analog i GNU screen) tmux, demo identd me pĂ«rvetĂ«simin e protokollit IDENT, alternativa BSDL e paketĂ«s GNU groff — mandoc, protokolli pĂ«r organizimin e sistemeve tĂ« qĂ«ndrueshme CARP (Protokolli i RedundancĂ«s sĂ« Adresave tĂ« Zakonshme), serveri http i lehtĂ«, utilitari i sinkronizimit tĂ« skedarĂ«ve OpenRSYNC.

Përmirësimet kryesore:

  • ËshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r sistemet e bazuara nĂ« arkitekturĂ«n ARM, duke pĂ«rfshirĂ« mbĂ«shtetje pĂ«r çipat ARM tĂ« Apple M2 dhe Ampere Altra. ËshtĂ« shtuar mbĂ«shtetje pĂ«r laptopin Lenovo ThinkPad x13s dhe pajisje tĂ« tjera tĂ« bazuara nĂ« SoC Qualcomm Snapdragon 8cx Gen 3 (SC8280XP).
  • ËshtĂ« shtuar mundĂ«sia e ngarkimit nĂ« mjediset Oracle Cloud tĂ« bĂ«rthamĂ«s pĂ«r ram-diskun (bsd.rd) dhe bĂ«rthamĂ«s pĂ«r sisteme shumĂ«proçesorĂ«sh (bsd.mp).
  • ËshtĂ« pĂ«rfshirĂ« pajisja kstat, e cila eksporton statistikĂ«n e punĂ«s sĂ« bĂ«rthamĂ«s dhe mund tĂ« shikohet me utilitarin kstat.
  • PĂ«r çdo bĂ«rthamĂ« procesori me mbĂ«shtetje pĂ«r MPERF/APERF janĂ« realizuar sensorĂ«t e frekuencĂ«s sĂ« CPU-sĂ«. Kur punoni nga bateria, Ă«shtĂ« aktivizuar shkallĂ«zimi i frekuencĂ«s sĂ« CPU-sĂ« nĂ« varĂ«si tĂ« ngarkesĂ«s.
  • NjĂ« mbĂ«shtetje fillestare pĂ«r modalitetin e gjumit Ă«shtĂ« shtuar nĂ« sistemet ARM64. Kufiri pĂ«r numrin e CPU-ve tĂ« mbĂ«shtetur Ă«shtĂ« rritur nĂ« 256. ËshtĂ« realizuar mundĂ«sia e kalimit nga konsola e bazuar nĂ« framebuffer (glass console) nĂ« konsolĂ«n e bazuar nĂ« portin serial (serial console).
  • Kodi pĂ«r identifikimin e CPU 386sx/386dx, NexGen, Rise dhe procesorĂ«ve tĂ« vjetĂ«r Cyrix tĂ« prodhuar para çipit Cyrix M2 Ă«shtĂ« hequr.
  • ËshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r sistemet shumĂ«proçesorĂ«sh (SMP). Funksionet e kufizimit tĂ« kapacitetit (rate limit), kĂ«rkimi i regjistrave ARP dhe route timer janĂ« realizuar nĂ« njĂ« shpĂ«rndarje mp-safe. ËshtĂ« realizuar mundĂ«sia e ekzekutimit paralel tĂ« operacioneve tĂ« tilla si rindĂ«rtimi i paketeve IPv4 dhe ridrejtimi i paketeve IP. Bllokimet e soketeve, qĂ« pĂ«rdorin mutex, janĂ« shtuar nĂ« funksionet e pĂ«rpunimit tĂ« paketeve tĂ« ardhshme UDP dhe IP. Funksionet sistemike kbind dhe pledge janĂ« liruar nga bllokimet. JanĂ« realizuar bllokimet e soketeve UNIX, qĂ« veprojnĂ« nĂ« nivelin e soketeve tĂ« veçanta.
  • Implementimi i framewrokut drm (Menaxher Direkte i Renderimit) Ă«shtĂ« sinkronizuar me kernelin Linux 5.15.69 (nĂ« versionin e kaluar — 5.15.26). NĂ« driverin inteldrm Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r çipet Intel tĂ« bazuara nĂ« mikroarkitekturĂ« Alder Lake dhe Raptor Lake. ËshtĂ« implementuar mbĂ«shtetje pĂ«r framebufferĂ«t qĂ« nuk janĂ« tĂ« pĂ«rshtatur nĂ« kufirin e faqes sĂ« memories (nĂ« pĂ«rdorim, pĂ«r shembuj, nĂ« MacBook Pro 2021 14″ dhe 16″).
  • JanĂ« bĂ«rĂ« pĂ«rmirĂ«sime nĂ« hipervizorin VMM. NĂ« vmd Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r menaxherĂ«t nĂ« hapĂ«sirĂ«n e pĂ«rdoruesit tĂ« bazuar nĂ« MMIO. NĂ« vmm, emulimi i porteve tĂ« hyrjes/daljes Ă«shtĂ« zhvendosur nĂ« hapĂ«sirĂ«n e pĂ«rdoruesit. Strukturat dhe ndĂ«rfaqet e brendshme nĂ« vmd, vmctl dhe vmm janĂ« unifikuar. ËshtĂ« shtuar mundĂ«sia e monitorimit makinat virtuale nĂ«pĂ«rmjet SNMP AgentX, duke pĂ«rdorur parametrat VM-MIB (RFC7666).
  • Variabli $rcexec nĂ« skenaret e inicializimit rc.d Ă«shtĂ« zĂ«vendĂ«suar me funksionin rc_exec. ËshtĂ« shtuar njĂ« variabĂ«l e re daemon_execdir, qĂ« lejon ndryshimin e katalogut para ekzekutimit tĂ« funksionit rc_exec. NĂ« rc.d dhe rcctl Ă«shtĂ« shtuar njĂ« veprim i ri configtest pĂ«r kontrollin e sintaksĂ«s sĂ« konfigurimit.
  • Grupi pĂ«rfshin utilitarin ts, i cili i shton linjave qĂ« pranohet pĂ«rmes hyrjes standarde, kohĂ«n qĂ« reflekton momentin e marrjes sĂ« çdo linje.
  • NĂ« utilitarin ps Ă«shtĂ« shtuar njĂ« opsion "-f" pĂ«r hierarkinĂ« e grumbullimit tĂ« proceseve, qĂ« pasqyron lidhjen mes proceseve prind dhe fĂ«mijĂ«.
  • NĂ« utilitarin openrsync Ă«shtĂ« implementuar opsioni "—contimeout" pĂ«r pĂ«rcaktimin e njĂ« kohĂ«zgjatjeje pĂ«r vendosjen e lidhjes.
  • NĂ« utilitarin pkg_add, keqkategoritimi Ă«shtĂ« pĂ«rfshirĂ« si veprim i parazgjedhur, Ă«shtĂ« optimizuar puna me paketat dhe Ă«shtĂ« siguruar njĂ« qĂ«ndruar progrese gjatĂ« transferimit tĂ« tĂ« dhĂ«nave.
  • NĂ« fdisk Ă«shtĂ« pĂ«rmirĂ«suar puna me tabelat GPT dhe MBR, janĂ« shtuar paralajmĂ«rime pĂ«r vendosjen e papĂ«rshtatshme tĂ« pjesĂ«ve MBR dhe GPT.
  • NĂ« utilitarin disklabel Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r fjalinĂ« kyçe raid nĂ« shabllonĂ«t pĂ«r vendosjen automatike tĂ« pjesĂ«ve me RAID. ËshtĂ« ndĂ«rprerĂ« mbĂ«shtetje pĂ«r redaktimin e informacionit rreth geometrisĂ« sĂ« disku. ËshtĂ« ndĂ«rprerĂ« mbĂ«shtetje pĂ«r atributet ‘bs’ (pĂ«rmasat e bllokut tĂ« ngarkesĂ«s), ‘sb’ (pĂ«rmasat e superbllokut) dhe d[0-4] (tĂ« dhĂ«nat e disku).
  • NĂ« katalogun /usr/share/btrace Ă«shtĂ« vendosur njĂ« pĂ«rzgjedhje e skripteve tĂ« dobishme btrace pĂ«r ndjekjen dinamike dhe inspektimin e aplikacioneve.
  • NĂ« bibliotekĂ«n audio sndio Ă«shtĂ« shtuar funksioni sio_flush pĂ«r ndalimin e menjĂ«hershĂ«m tĂ« reproduktimit.
  • Grupi pĂ«rfshin utilitarin llvm-profdata pĂ«r punĂ«n me tĂ« dhĂ«nat e profilit.
  • NĂ« utilitarin wc Ă«shtĂ« pĂ«rshpejtuar numĂ«rimi i fjalĂ«ve.
  • MbĂ«shtetje e re pĂ«r pajisje tĂ« reja, pĂ«rfshirĂ« shoferĂ« tĂ« rinj:
    • aplaudio (sistemi audio i Apple).
    • aplmca (kontrollues MCA Apple).
    • aplsart (Apple SART).
    • alpdc, apldchidev, apldckbd, apldcms, aplrtk (klaviatura dhe trackpad Apple M2).
    • qcgpio, qciic (kontrolluesit GPIO dhe GENI I2C pĂ«r Qualcomm Snapdragon).
    • sfgpio, stfclock, stfpinctrl, stftemp (shoferĂ«t pĂ«r GPIO, temporizatorĂ« dhe sensorĂ«t e bordit SiFive).
    • sxirintc (kontrolluesi i ndĂ«rprerjeve pĂ«r çipat Allwinner).
    • gpiorestart (shoferi pĂ«r rinisje pĂ«rmes GPIO).
    • NĂ« ipmi, mbĂ«shtetje e zgjeruar pĂ«r sensorĂ«t e furnizimit.
    • NĂ« ehci, mbĂ«shtetje e shtuar pĂ«r kontrolluesin e pĂ«rdorur nĂ« pllakat Marvell 3720.
  • NĂ« shoferin igc pĂ«r adaptuesit e Ethernet-it me gigabit Intel I225, Ă«shtĂ« pĂ«rfshirĂ« pĂ«rshpejtimi harduerik i llogaritjeve tĂ« checksum pĂ«r IPv4, TCP dhe UDP. NĂ« shoferin ix pĂ«r adaptuesit e Ethernet-it Intel 82598/82599/X540/X550 Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r pĂ«rshpejtimin harduerik tĂ« pĂ«rpunimit tĂ« segmenteve TCP (Large Receive Offloading), duke u aktivizuar pĂ«rmes opsionit tso nĂ« ifconfig.
  • NĂ« shoferin iwx, Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r çipat Intel AX210/AX211 dhe Ă«shtĂ« zgjeruar gama e pajisjeve wireless qĂ« identifikohen.
  • Shtuar mundĂ«sia pĂ«r tĂ« ngarkuar nga pjesĂ«t e RAID 1 software (softraid) nĂ« sistemet amd64, sparc64 dhe arm64.
  • NĂ« snmpd dhe xlock, Ă«shtĂ« zbatuar ndarja e privilegjeve.
  • NĂ« funksionet bind dhe connect pĂ«r soketĂ«t UNIX, Ă«shtĂ« siguruar izolimi mbi bazĂ«n e thirrjeve sistemore unveil.
  • Shtuar thirrja e re sistemore ypconnect pĂ«r krijimin e njĂ« soketi pĂ«r lidhjen me server YP, duke pĂ«rdorur adresĂ«n IP nga skedari i bllokuar ypbinding. NĂ« ypldap Ă«shtĂ« shtuar moda 'local bind', ku bĂ«het lidhja e soketit RPC me ndĂ«rfaqen loopback, pĂ«r tĂ« eliminuar lidhjet eksternal me serverin.
  • Programet e vendosura nĂ« katalogun /sbin hcpleased, mountd, nfsd, pflogd, resolvd, slaacd dhe unwind janĂ« transferuar nĂ« pĂ«rdorimin e lidhjes dinamike pĂ«r tĂ« pĂ«rfituar nga masat e reja tĂ« sigurims, tĂ« aplikueshme pĂ«r skedarĂ«t e ekzekutueshĂ«m qĂ« lidhen dinamikisht.
  • NĂ« stacks e rrjetit janĂ« realizuar thirrjet sistemore sendmmsg dhe recvmmsg, tĂ« cilat lejojnĂ« nĂ« kuadĂ«r tĂ« njĂ« thirrjeje sistemore shpĂ«rndarjen dhe leximin e menjĂ«hershĂ«m tĂ« shumĂ« mesazheve, tĂ« cilat mĂ« parĂ« do tĂ« kĂ«rkonin thirrje tĂ« ndara sendmsg dhe recvmsg.
  • NĂ« filtrin e paketave pf, Ă«shtĂ« ndryshuar pĂ«rpunimi i paketave IGMP dhe ICMP6 MLD (Multicast Listener Discovery), i cili ka mundĂ«suar funksionimin me paketat multicast menaxhuese nĂ« konfigurimin e parazgjedhur. ËshtĂ« realizuar njĂ« kontroll mĂ« i fortĂ« i mesazheve IGMP/MLD.
  • NĂ« IPsec Ă«shtĂ« pĂ«rmirĂ«suar puna me certifikatat. NĂ« iked Ă«shtĂ« pĂ«rmirĂ«suar pĂ«rputhshmĂ«ria me OpenIKED. KomandĂ«s ikectl show stats i Ă«shtĂ« shtuar njĂ« pĂ«rcjellje e statistikave pĂ«r lidhjet e suksesshme dhe tĂ« dĂ«shtuar me iked.
  • NĂ« bgpd Ă«shtĂ« shtuar filtri max-communities pĂ«r tĂ« kufizuar numrin e komuniteteve tĂ« lejuara, Ă«shtĂ« zbatuar RFC 9234 (Parandalimi dhe Detektimi i RrugĂ«ve duke PĂ«rdorur Roli nĂ« Mesazhet UPDATE dhe OPEN), Ă«shtĂ« siguruar mbĂ«shtetje e plotĂ« pĂ«r RFC 7911 (Reklamimi i RrugĂ«ve tĂ« Shumta nĂ« BGP), ndihmat statike janĂ« zĂ«vendĂ«suar me pemĂ« RB pĂ«r ta rritur performancĂ«n e sistemeve tĂ« mĂ«dha. ËshtĂ« shtuar procesi bgplgd me implementimin e serverit FastCGI qĂ« ofron REST API pĂ«r komandat bgpctl.
  • NĂ« rpki-client Ă«shtĂ« lejuar pĂ«rdorimi i mĂ« shumĂ« se njĂ« URI CRL nĂ« certifikata, Ă«shtĂ« implementuar parametri skiplist pĂ«r tĂ« injoruar domenet, Ă«shtĂ« shtuar mundĂ«sia e verifikimit tĂ« ASPA (Autonomous System Provider Authorization) dhe skedarĂ«ve sig, Ă«shtĂ« zbatuar dekodimi TAL (RFC 8630), Ă«shtĂ« rritur kontrolli i certifikatave EE, Ă«shtĂ« pĂ«rmirĂ«suar pĂ«rputhshmĂ«ria me specifikimet HTTP.
  • NĂ« snmpd Ă«shtĂ« lejuar pĂ«rdorimi i emrave tĂ« objekteve nĂ« snmpd.conf, pĂ«rveç OID. ËshtĂ« implementuar mundĂ«sia e pĂ«rcaktimit tĂ« njĂ« liste tĂ« zezĂ« pĂ«r pĂ«rjashtimin e nĂ«npemĂ«ve nga dalja. ËshtĂ« shtuar mbĂ«shtetje pĂ«r agjentin master nĂ« zbatimin e protokollit AgentX.
  • NĂ« httpd janĂ« ofruar definita tĂ« reja MIME-tipa.
  • Utilita ftp Ă«shtĂ« kaluar nĂ« pĂ«rdorimin e lidhjeve qĂ« trajtohen nĂ« modin jo-bllokues pĂ«rmes ppoll.
  • NĂ« tmux (“terminal multiplexer”) Ă«shtĂ« shtuar mundĂ«sia e pĂ«rdorimit tĂ« ACL pĂ«r organizimin e lidhjes sĂ« shumĂ« pĂ«rdoruesve pĂ«rmes njĂ« socket.
  • Paketet LibreSSL dhe OpenSSH janĂ« pĂ«rditĂ«suar. Mund tĂ« shihni njĂ« pĂ«rmbledhje tĂ« hollĂ«sishme tĂ« pĂ«rmirĂ«simeve nĂ« rishikimet LibreSSL 3.6.0 dhe OpenSSH 9.1.
  • Numri i porteve pĂ«r arkitekturĂ«n AMD64 ka arritur 11451 (ishte 11301), pĂ«r aarch64 — 11261 (ishte 11081), pĂ«r i386 — 10225 (ishte 10136). NdĂ«r versionet e aplikacioneve nĂ« porte:
    • Asterisk 16.28.0, 18.14.0 dhe 19.6.0
    • Audacity 2.4.2
    • CMake 3.24.2
    • Chromium 105.0.5195.125
    • Emacs 28.2
    • FFmpeg 4.4.2
    • GCC 8.4.0 dhe 11.2.0
    • GHC 9.2.4
    • GNOME 42.4
    • Go 1.19.1
    • JDK 8u342, 11.0.16 dhe 17.0.4
    • KDE Gear 22.08.1
    • KDE Frameworks 5.98.0
    • Krita 5.1.1
    • LLVM/Clang 13.0.0
    • LibreOffice 7.4.1.2
    • Lua 5.1.5, 5.2.4 dhe 5.3.6
    • MariaDB 10.9.3
    • Mono 6.12.0.182
    • Mozilla Firefox 105.0.1 dhe ESR 102.3.0
    • Mozilla Thunderbird 102.3.0
    • Mutt 2.2.7 dhe NeoMutt 20220429
    • Node.js 16.17.1
    • OCaml 4.12.1
    • OpenLDAP 2.6.3
    • PHP 7.4.30, 8.0.23 dhe 8.1.10
    • Postfix 3.7.2
    • PostgreSQL 14.5
    • Python 2.7.18, 3.9.14 dhe 3.10.7
    • Qt 5.15.6 dhe 6.3.1
    • R 4.2.1
    • Ruby 2.7.6, 3.0.4 dhe 3.1.2
    • Rust 1.63.0
    • SQLite 3.39.3
    • Shotcut 22.06.23
    • Sudo 1.9.11.2
    • Suricata 6.0.6
    • Tcl/Tk 8.5.19 dhe 8.6.12
    • TeX Live 2021
    • Vim 9.0.0192 dhe Neovim 0.7.2
    • Xfce 4.16
  • JanĂ« pĂ«rditĂ«suar komponentĂ«t nga zhvilluesit e tretĂ« qĂ« bĂ«jnĂ« pjesĂ« nĂ« OpenBSD 7.2:
    • Stoku grafik Xenocara bazuar nĂ« X.Org 7.7 me xserver 1.21.4 + patches, freetype 2.12.1, fontconfig 2.13.94, Mesa 22.1.7, xterm 372, xkeyboard-config 2.20, fonttosfnt 1.2.2.
    • LLVM/Clang 13.0.0 (+ patch)
    • GCC 4.2.1 (+ patch) dhe 3.3.6 (+ patch)
    • Perl 5.32.1 (+ patch)
    • NSD 4.6.0
    • Unbound 1.16.3
    • Ncurses 5.7
    • Binutils 2.17 (+ patch)
    • Gdb 6.3 (+ patch)
    • Awk 12.9.2022
    • Expat 2.4.9

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster