Lëshimi i OpenSSL 3.2.0 me mbështetje klienti për protokollin QUIC

Pas pas tetë muaj zhvillimi, u formua publikimi i bibliotekës OpenSSL 3.2.0 me zbatimin e protokolleve SSL/TLS dhe algoritmeve të ndryshëm të enkriptimit. Mbështetja për OpenSSL 3.2 do të zhvillohet deri më 23 nëntor 2025. Mbështetja për degët e mëparshme OpenSSL 3.1 dhe 3.0 LTS do të vazhdojë deri në mars 2025 dhe nëntor 2026 përkatësisht. Mbështetja për degën 1.1.1 u përfundua këtë nëntor. Kodi i projektit shpërndahet nën licencën Apache 2.0.

Novitetet kryesore në OpenSSL 3.2.0:

  • MbĂ«shtetje klienti pĂ«r protokollin QUIC (RFC 9000) Ă«shtĂ« shtuar, i cili pĂ«rdoret si transport nĂ« protokollin HTTP/3. Zbatimi pĂ«rfshin, ndĂ«r tĂ« tjera, mundĂ«sinĂ« e transmetimit tĂ« disa kanaleve pĂ«rmes njĂ« lidhjeje. KomponentĂ«t pĂ«r tĂ« pĂ«rdorur QUIC nĂ« sistemet do tĂ« pĂ«rfshihen nĂ« publikimin e OpenSSL 3.3, qĂ« planifikohet tĂ« publikohet jo mĂ« vonĂ« se 30 prill 2024.

    QUIC është një shtesë mbi protokollin UDP që mbështet multipleximin e disa lidhjeve dhe ofron metoda enkriptimi ekuivalente me TLS/SSL. Protokolli u krijua në vitin 2013 nga Google si një alternativë ndaj lidhjes TCP+TLS për Uebin, duke adresuar problemet me kohën e gjatë për mbajtjen dhe negociatën e lidhjeve në TCP dhe duke eliminuar vonesat gjatë humbjes së pakove gjatë transmetimit të të dhënave.

  • NĂ« TLS Ă«shtĂ« zbatuar mbĂ«shtetje pĂ«r zgjerimin pĂ«r kompresimin e certifikatave nĂ« fazĂ«n e negociatĂ«s sĂ« lidhjes (RFC 8879), e cila lejon pĂ«rshpejtimin e krijimit tĂ« lidhjes pasi qĂ« transmetimi i tĂ« dhĂ«nave tĂ« certifikatave zĂ« njĂ« pjesĂ« tĂ« madhe tĂ« trafikut gjatĂ« fazĂ«s sĂ« negociatĂ«s. MbĂ«shtetet kompresimi duke pĂ«rdorur bibliotekat zlib, zstd dhe Brotli.
  • MbĂ«shtetje pĂ«r variantin e caktuar tĂ« nĂ«nshkrimeve dixhitale ECDSA (Deterministic ECDSA, RFC 6979) Ă«shtĂ« shtuar, ku nĂ« vend tĂ« njĂ« sekuence rastĂ«sore gjatĂ« krijimit tĂ« nĂ«nshkrimit pĂ«rdoret hesh HMAC-SHA256 nga çelĂ«si privat dhe teksti i mesazhit tĂ« nĂ«nshkruar, i cili lejon qĂ« gjithmonĂ« tĂ« merret e njĂ«jta nĂ«nshkrim nĂ« operacione tĂ« ndryshme nĂ«nshkrimi, por nuk lejon rrjedhjen e tĂ« dhĂ«nave qĂ« mund tĂ« pĂ«rdoren pĂ«r tĂ« zbuluar çelĂ«sin privat (çelĂ«si privat mund tĂ« zbulohet nĂ«se tĂ« paktĂ«n dy nĂ«nshkrime pĂ«r tĂ« dhĂ«na tĂ« ndryshme janĂ« formuar duke pĂ«rdorur njĂ« sekuencĂ« rastĂ«sore qĂ« pĂ«rsĂ«ritet).
  • MbĂ«shtetje pĂ«r variante tĂ« zgjeruara tĂ« nĂ«nshkrimeve dixhitale me çelĂ«sin publik Ed25519 dhe Ed448: Ed25519ctx, Ed25519ph dhe Ed448ph (RFC 8032) Ă«shtĂ« shtuar.
  • ËshtĂ« shtuar mbĂ«shtetje pĂ«r modalitetin e enkriptimit AES-GCM-SIV (RFC 8452), i cili kombinon performancĂ«n e lartĂ« tĂ« modalitetit GCM (Galois/Counter Mode) me qĂ«ndrueshmĂ«rinĂ« ndaj rrjedhjeve kur ripĂ«rdoret kodi i rastĂ«sishĂ«m nonce.
  • ËshtĂ« realizuar funksioni pĂ«r formimin e çelĂ«sit Argon2 (RFC 9106), i cili fitoi nĂ« 2015 nĂ« konkursin pĂ«r funksione hash pĂ«r fjalĂ«kalime. ËshtĂ« shtuar mundĂ«sia pĂ«r pĂ«rdorimin e njĂ« grumbulli me shtylla.
  • ËshtĂ« shtuar mbĂ«shtetje pĂ«r enkriptimin hibrid mbi mekanizmin HPKE (Hybrid Public Key Encryption, RFC 9180), i cili bashkon thjeshtĂ«sinĂ« e transferimit tĂ« çelĂ«sit nĂ« enkriptimin me çelĂ«s publik me performancĂ«n e lartĂ« tĂ« enkriptimit simetrik (tĂ« dhĂ«nat enkriptohen me njĂ« çelĂ«s simetrik tĂ« shpejtĂ«, ndĂ«rsa çelĂ«si vetĂ« enkriptohet me njĂ« çelĂ«s asimetrik mĂ« tĂ« ngadaltĂ«).
  • NĂ« TLS Ă«shtĂ« realizuar mundĂ«sia e pĂ«rdorimit tĂ« çelĂ«sve tĂ« hapur "tĂ« raw" (RFC 7250).
  • ËshtĂ« shtuar mbĂ«shtetje pĂ«r mekanizmin e hapjes sĂ« shpejtĂ« tĂ« TCP-sĂ« (TFO — TCP Fast Open, RFC 7413), i cili lejon reduktimin e numrit tĂ« hapave pĂ«r vendosjen e lidhjes duke kombinuar nĂ« njĂ« kĂ«rkesĂ« hapin e parĂ« dhe tĂ« dytĂ« tĂ« procesit klasik 3-hapĂ«sh tĂ« pajtimit tĂ« lidhjes dhe ofron mundĂ«sinĂ« pĂ«r dĂ«rgimin e tĂ« dhĂ«nave nĂ« fazĂ«n fillestare tĂ« vendosjes sĂ« lidhjes.
  • NĂ« TLS Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r skemat e nĂ«nshkrimit digjital tĂ« plug-inn, qĂ« lejojnĂ« pĂ«rdorimin e implementimeve tĂ« jashtme tĂ« algoritmeve, pĂ«r shembull, pĂ«r pĂ«rdorim nĂ« algoritma tĂ« qĂ«ndrueshĂ«m ndaj pĂ«rzgjedhjes nĂ« kompjuterĂ«t kuantikĂ«.
  • NĂ« TLS 1.3 Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r kurbat eliptike tĂ« mbrojtura Brainpool.
  • ËshtĂ« shtuar mbĂ«shtetje pĂ«r instruksionet e procesorit SM4-XTS.
  • NĂ« platformĂ«n Windows Ă«shtĂ« realizuar mundĂ«sia e pĂ«rdorimit tĂ« depozitĂ«s sistemore tĂ« certifikatave rrĂ«njĂ«sore (pĂ«r mĂ« shumĂ«, Ă«shtĂ« çaktivizuar si parazgjedhje). PĂ«r tĂ« aksesuar certifikatat nĂ« depozitĂ«n Windows Ă«shtĂ« propozuar URI "org.openssl.winstore:///".

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster