Pas njĂ« viti pĂ«rvoje nĂ« zhvillim, Ă«shtĂ« publikuar rrelease i degĂ«s sĂ« re stabile tĂ« serverit tĂ« postĂ«s Postfix â 3.10.0. NĂ« tĂ« njĂ«jtĂ«n kohĂ«, Ă«shtĂ« njoftuar pĂ«r ndĂ«rprerjen e mbĂ«shtetjes pĂ«r degĂ«n Postfix 3.6, e lĂ«shuar nĂ« fillim tĂ« vitit 2021. Kodi i projektit Ă«shtĂ« shkruar nĂ« gjuhĂ«n C dhe shpĂ«rndahet nĂ«n licencat EPL 2.0 (Licenca Publike Eclipse) dhe IPL 1.0 (Licenca Publike IBM).
Postfix është një nga projektet e rralla që kombinon sigurinë, besueshmërinë dhe performancën e lartë, të cilat janë arritur falë arkitekturës shumëprocesore që izolon procesorët e ndarë, si dhe një politike strikte për formatimin e kodit dhe auditi i patches. Për të mbrojtur nga gabimet në punën me kujtesën, projekti përdor variante të mbrojtura të funksioneve për të alokuar dhe liruar kujtesë, si dhe një grup funksionesh abstrakte për punën me buferat (kontrollohet dalja jashtë kufijve të buferave dhe qasja në kujtesën e liruar), operacionet me skedarë, formatimin e daljes, input/output me bufer dhe manipulimin e zinxhirëve (duke përfshirë mundësitë për punë me zinxhirë me madhësi të rastësishme dhe ndryshimin automatik të madhësisë së zinxhirëve).
Sipas njĂ« anketimi tĂ« automatizuar nĂ« shkurt, rreth 550 mijĂ« postash serverĂ«sh, Postfix pĂ«rdoret nĂ« 37.64% (njĂ« vit mĂ« parĂ« 36.81%) tĂ« serverĂ«ve tĂ« postĂ«s, pjesa e Exim Ă«shtĂ« 56.03% (njĂ« vit mĂ« parĂ« 56.61%), Sendmail â 3.39% (3.60%), MailEnable â 1.80% (1.82%), MDaemon â 0.39% (0.40%), Microsoft Exchange â 0.19% (0.19%), OpenSMTPD â 0.10% (0.09%).

Novitetet kryesore:
- ĂshtĂ« shtuar mundĂ«sia e pĂ«rdorimit tĂ« algoritmeve kriptografikĂ« TLS qĂ« janĂ« tĂ« qĂ«ndrueshĂ«m ndaj pĂ«rpjekjeve tĂ« thyerjes me kompjuterĂ« kuantikĂ«. PĂ«r tĂ« pĂ«rdorur kĂ«ta algoritma, nevojitet pĂ«rdorimi i degĂ«s sĂ« bibliotekĂ«s OpenSSL 3.5, e cila ende nuk Ă«shtĂ« liruar pĂ«r pĂ«rdorim. PĂ«r tĂ« zgjedhur algoritmet postkuantore, nĂ« Postfix nuk Ă«shtĂ« futur njĂ« sintaksĂ« e re pĂ«r grupet TLS, por Ă«shtĂ« mbĂ«shtetur nĂ« konfigurimet e OpenSSL qĂ« do tĂ« pĂ«rdoren gjatĂ« konfigurimit tĂ« parametrave 'tls_eecdh_auto_curves' dhe 'tls_ffdhe_auto_groups' nĂ« vlera tĂ« zbrazĂ«ta.
- ĂshtĂ« shtuar mbĂ«shtetje pĂ«r titullin e mesazheve 'TLS-Required: no' (RFC 8689), sipas tĂ« cilit shpĂ«rndarja do tĂ« realizohet edhe nĂ«se nuk Ă«shtĂ« e mundur tĂ« realizohet politika e sigurisĂ« TLS e vendosur nĂ« konfigurim. Me kĂ«tĂ« titull, klienti SMTP funksionon nĂ« mĂ«nyrĂ«n 'smtp_tls_security_level = may', dmth. nuk kontrollon certifikatĂ«n. serverĂ« dhe mund tĂ« kthehet nĂ« lidhjen me transmetimin e tĂ« dhĂ«nave nĂ« tekst tĂ« hapur. NĂ« degĂ«n e ardhshme tĂ« rĂ«ndĂ«sishme tĂ« Postfix, pritet implementimi i zgjerimit SMTP REQUIRETLS.
- Shtuar mbështetje për protokollin TLS-RPT (Transport Layer Security Reporting), që lejon ndjekjen e dështimeve gjatë dorëzimit të mesazheve që ndodhin nëse nuk është e mundur të vendoset një lidhje e koduar, e cila parashikohet të përdorë zgjerimet DANE (DNS-based Authentication of Named Entities) ose MTA-STS (MTA Strict Transport Security). Pronari i domain-it të postës përcakton në DNS parametrat për TLS-RPT, pas së cilës serverët e postës do të dërgojnë raporte me informacion rreth lidhjeve TLS të suksesshme dhe dështake tek MX-serverët që menaxhojnë domain-in. Implementimi bazuar në bibliotekën libtlsrpt.
- Shtuar cilësimin «smtpd_hide_client_session = yes», i cili çaktivizon shtimin e informacionit mbi seancën e klientit gjatë vendosjes nga serveri SMTP të titullit «Received:». Shembulli i titullit të shkurtuar: «Received: from mail.example.com (Postfix) id postfix-queue-id for <user@example.com>; Ditë, dd Mon yyyy hh:mm:ss tz-offset (zona)».
- Shtuar mundĂ«sia pĂ«r MIME-kodimin (RFC 2047) e emrave nĂ« titujt e gjeneruar nga Postfix «From:», qĂ« pĂ«rmbajnĂ« simbole qĂ« nuk janĂ« ASCII. Schemi e propozuar pĂ«r kodimin lejon qĂ« tĂ« shmanget pĂ«rdorimi i zgjerimit SMTPUTF8 (RFC 6531), i cili nuk mbĂ«shtetet nga tĂ« gjitha aplikacionet. Rezultati i MIME-kodimit duket si â»=?charset?Q?gibberish?=:â. PĂ«r tĂ« pĂ«rcaktuar kodimin origjinal tĂ« emrave Ă«shtĂ« shtuar parametri «full_name_encoding_charset», i cili nga e zakonshmja vendoset nĂ« utf8.
- E ndryshuar logjika e trajtimit të lidhjeve dështake kur në cilësimet e «mysql:» ose «pgsql:» është përcaktuar vetëm një server. Një server i tillë tani perceptohet si një balancues ngarkese dhe në rast dështimi të vetëm, kërkesa e përsëritur dërgohet menjëherë, pa pritur 60 sekonda.
- Në Milter është implementuar pasqyrimi në log të informacionit me arsyen e vendosjes së mesazhit në karantinë.
- Në serverin SMTP është siguruar që të regjistrohet identifikatori i radhës ose vlera «NOQUEUE» kur mbyllet lidhja për shkak të skadimit të kohës, ndërprerjes ose tejkalimit të kufirit të numrit të gabimeve. Procesi i pastrimit në këtë rast jep në log «queueid: canceled» për mesazhet me një transaksion të nisur, por jo të përfunduar.
- Në klientin Dovecot SASL, kur regjistrohen në log mesazhi "Mekanizmi i autentikimit është i pavlefshëm", tani shfaqet mekanizmi i autentikimit që nuk mund të përdoret. Serveri SMTP tani shfaq vlerat e konfigurimeve sasl_method, sasl_username dhe sasl_sender gjatë regjistrimit të mesazheve 'reject'.
- Për shkak të ndryshimit të protokollit të brendshëm të përdorur në agjentin e dorëzimit, pas përditësimit të versionit Postfix, kërkohet një ri-ngarkim me komandën "postfix reload" ose komandat "postfix stop" dhe "postfix start". Në rastin e kundërt, do të shfaqet një paralajmërim në log "atribut i papritur smtputf8 nga xxx socket (pritet: sendopts)".
Burimi: opennet.ru
