Pas pas 11 muajsh zhvillimi, konsorciumi ISC ka publikuar versionin e parë të qëndrueshëm të degës së re të serverit DNS BIND 9.16. Mbështetje për degën 9.16 do të ofrohet për tre vitet e ardhshme deri në tremujorin e dytë të vitit 2023 në kuadër të ciklit të zgjeruar të mbështetjes. Përditësimet për degën LTS të kaluar 9.11 do të vazhdojnë të lëshohen deri në dhjetor 2021. Mbështetja për degën 9.14 do të ndalojë pas tre muajsh.
Main :
- KASP (Politika e ĂelĂ«sit dhe NĂ«nshkrimit) Ă«shtĂ« shtuar, njĂ« mĂ«nyrĂ« e thjeshtuar pĂ«r menaxhimin e çelĂ«save dhe nĂ«nshkrimeve dixhitale DNSSEC, e bazuar nĂ« caktimin e rregullave tĂ« pĂ«rcaktuara pĂ«rmes direktivĂ«s 'dnssec-policy'. Kjo direktivĂ« lejon konfiguroimin e gjenerimit tĂ« çelĂ«save tĂ« rinj tĂ« nevojshĂ«m pĂ«r zonat DNS dhe aplikimin automatik tĂ« çelĂ«save ZSK dhe KSK.
- Sistemi i rrjetit është rishikuar ndjeshëm, i cili është kaluar në mekanizmin e përpunimit asinkron të kërkesave, të zbatuar mbi bibliotekën .
Rishikimi deri tani nuk ka sjellë ndryshime të dukshme, por në lëshimet e ardhshme do të ofrojë mundësinë për të realizuar disa optimizime të rëndësishme të performancës dhe për të shtuar mbështetje për protokolle të reja, si DNS mbi TLS. - Procesi i menaxhimit të lidhjeve të besueshme DNSSEC (Trust anchor, lidhja e hapur e çelësit për verifikimin e autenticitetit të kësaj zone) është përmirësuar. Në vend të konfigurimeve të trusted-keys dhe managed-keys, të cilat tani janë shpallur të vjetra, është propozuar një direktivë e re trust-anchors që lejon menaxhimin e të dy llojeve të çelësave.
Kur përdoret trust-anchors me fjalë kyçe initial-key, sjellja e kësaj direktive është identike me managed-keys, dmth. përcakton konfigurimin e lidhjes besuese në përputhje me RFC 5011. Kur përdoret trust-anchors me fjalë kyçe static-key, sjellja është e ngjashme me direktivën trusted-keys, dmth. përcakton një çelës të përhershëm që nuk azhurnohet automatikisht. Gjithashtu, në trust-anchors ofrohen dy fjalë kyçe të tjera initial-ds dhe static-ds që lejojnë përdorimin e lidhjeve besuese në formatin (Delegation Signer) në vend të DNSKEY, i cili lejon konfigurimin e lidhjeve për çelësa që nuk janë publikuar ende (në të ardhmen, organizata IANA planifikon të përdorë formatin DS për çelësa të zonave themelore).
- Në utilitetet dig, mdig dhe delv është shtuar opsioni '+yaml' për daljen në formatin YAML.
- Në utilitetin dig është shtuar opsioni '+[no]unexpected', që lejon pranimin e përgjigjeve nga hoste të ndryshëm nga serveri, të cilit i është dërguar kërkesa.
- Në utilitarin dig u shtua opsioni «+[no]expandaaaa», i cili, kur është i caktuar, tregon adresat IPv6 në rekordet AAAA në përfaqësimin e plotë 128-bitësh, në vend të formatit RFC 5952.
- U shtua mundësia për të kaluar mes grupeve të kanaleve të statistikave.
- Rekordet DS dhe CDS tani gjenerohen vetëm mbi bazën e hash-eve SHA-256 (gjenerimi mbi bazën e SHA-1 është ndërprerë).
- Për Cookies DNS (RFC 7873) është përdorur si standard algoritmi SipHash 2-4, ndërsa mbështetje për HMAC-SHA është ndërprerë (AES mbetet).
- Daljet e komandave dnssec-signzone dhe dnssec-verify tani drejtohen në rrjedhën standarde të daljes (STDOUT), ndërsa në STDERR dalin vetëm informacionet mbi gabimet dhe paralajmërimet (kur caktohet opsioni «-f», gjithashtu del zona e nënshkruar). Për të heshtur daljen, u shtua opsioni «-q».
- Kodi i validimit të DNSSEC është rishikuar dhe është çliruar nga dyfishimi i kodit me sisteme të tjera të nënshkrimit.
- PĂ«r tĂ« shkarkuar statistikĂ«n nĂ« formatin JSON tani mund tĂ« pĂ«rdoret vetĂ«m biblioteka JSON-C. Opsioni i konfigurimit «âwith-libjson» Ă«shtĂ« rinomuar nĂ« «âwith-json-c».
- NĂ« skriptin e konfigurimit nuk caktohet mĂ« si standard parametri «âsysconfdir» nĂ« /etc, dhe «âlocalstatedir» nĂ« /var, nĂ«se nuk ceket parametri «âprefix». Tani pĂ«rdoren si standard rrugĂ«t $prefix/etc dhe $prefix/var, tĂ« aplikueshme nĂ« Autoconf.
- Kodi me implementimin e shërbimit DLV (Domain Look-aside Verification, opsioni dnssec-lookaside) është hequr, i cili ishte shpallur i vjetruar në BIND 9.12, dhe trajtuesi i lidhur me të dlv.isc.org ishte ndalur në vitin 2017. Heqja e DLV lehtësoi kodin BIND nga kompliksitete të panevojshme.
Burimi: opennet.ru
