Lëshimi i FreeBSD 13.0.

Pas dy vjet e gjysmë pas formimit të degës 12.x u prezantua lëshimi FreeBSD 13.0, i cili është përgatitur për arkitekturën amd64, i386, powerpc, powerpc64, powerpc64le, powerpcspe, armv6, armv7, aarch64 dhe riscv64. Shtesë janë formuar imazhe për sisteme virtualizimi (QCOW2, VHD, VMDK, raw) dhe ambientet cloud të Amazon EC2, Google Compute Engine dhe Vagrant.

Novitetet kryesore:

  • Ka ndodhur kalimi nĂ« realizimin e unifikuar tĂ« sistemit tĂ« skedarĂ«ve ZFS nga projekti OpenZFS. Mes mundĂ«sive qĂ« janĂ« bĂ«rĂ« tĂ« disponueshme nĂ« FreeBSD pas kalimit nĂ« OpenZFS janĂ«: sistemi i zgjatur i kuotave, enkriptimi i grupeve tĂ« dhĂ«nash, pĂ«rzgjedhja e veçantĂ« e klasave tĂ« alokimit tĂ« bllokĂ«ve, pĂ«rdorimi i instruksioneve procesorike vektoriale pĂ«r tĂ« pĂ«rshpejtuar realizimin e RAIDZ dhe llogaritjen e kontrolleve tĂ« shenjave, mbĂ«shtetje pĂ«r algoritmin e kompresimit ZSTD, moda multihost (MMP, Multi Modifier Protection), pĂ«rmirĂ«simi i mjetit tĂ« vijĂ«s sĂ« komandĂ«s, korrigjimi i shumĂ« gabimeve qĂ« lidhen me gjendjen e konkurrencĂ«s dhe bllokimet.
  • Porti pĂ«r arkitekturĂ«n ARM64 (AArch64) Ă«shtĂ« kaluar nĂ« nivelin e parĂ« tĂ« mbĂ«shtetjes (Tier 1), i cili mbulohet nga ekipet pĂ«rgjegjĂ«se pĂ«r zgjidhjen e dobĂ«sive, pĂ«rgatitjen e lĂ«shimeve dhe mbĂ«shtetje pĂ«r portet. Niveli i parĂ« i mbĂ«shtetjes pĂ«rfshin formimin e paketave tĂ« instalimit, pĂ«rditĂ«simeve binare dhe paketave tĂ« gatshme, si dhe ofrimin e garancive pĂ«r zgjidhjen e problemeve specifike dhe ruajtjen e invariancĂ«s ABI pĂ«r ambientin pĂ«rdorues dhe bĂ«rthamĂ«n (pĂ«rveç disa nĂ«n-sistemeve).
  • Arkitektura i386 Ă«shtĂ« kaluar nĂ« nivelin e dytĂ« tĂ« mbĂ«shtetjes sĂ« platformave (Tier 2), ku do tĂ« vazhdojĂ« formimi i paketave tĂ« instalimit, pĂ«rditĂ«simeve binare dhe paketave tĂ« gatshme, por nuk garanton zgjidhjen e problemeve specifike. Lloji i CPU-sĂ« (CPUTYPE) pĂ«r arkitekturĂ«n i386 Ă«shtĂ« ndryshuar nga 486 nĂ« 686 si parazgjedhje (nĂ«se dĂ«shirohet, paketat pĂ«r i486 dhe i586 mund tĂ« formohen vetĂ«).
  • KomponentĂ«t clang, lld, lldb, compiler-rt, llvm, libunwind dhe libc++ janĂ« pĂ«rditĂ«suar nĂ« versionin 11.
  • Zhvillimi Ă«shtĂ« kaluar nga sistemi i centralizuar i menaxhimit tĂ« kodit burimor Subversion nĂ« sistemin decentralizuar Git.
  • JanĂ« pastruar sistemin bazĂ« nga aplikacionet e shpĂ«rndara nĂ«n licencĂ«n GPL. Nga struktura e kodit burimor janĂ« hequr binutils 2.17 dhe gcc 4.2.1, tĂ« gjitha arkitekturave tĂ« mbĂ«shtetura janĂ« kaluar nĂ« mjetin LLVM/clang. JanĂ« pĂ«rfshirĂ« variante tĂ« shpĂ«rndara nĂ«n licencĂ«n BSD tĂ« utiliteteve grep dhe dtc (Device Tree Compiler), tĂ« cilat zĂ«vendĂ«sojnĂ« versionet nĂ«n licencĂ«n GPL. ËshtĂ« hequr procesi automat i montimit amd, funksionaliteti i tĂ« cilit tani realizohet nĂ«pĂ«rmjet autofs. ËshtĂ« hequr utilita ctm, pĂ«r tĂ« cilĂ«n rekomandohet tĂ« pĂ«rdoret porta misc/ctm.
  • ËshtĂ« ridizajnuar stoku i ruterĂ«ve, nĂ« tĂ« cilin u shtua mbĂ«shtetje pĂ«r objektet nexthop, qĂ« ruajnĂ« tĂ« dhĂ«nat e gjendjes, tĂ« cilat pĂ«rdoren pĂ«r dĂ«rgimin e paketave nĂ« destinacionin e dĂ«shiruar. U shtua mundĂ«sia e lidhjes sĂ« algoritmeve tĂ« kĂ«rkimit tĂ« rrugĂ«ve tĂ« pĂ«rdorura. U shtuan algoritmet e kĂ«rkimit tĂ« rrugĂ«ve nga DPDK (Data Plane Development Kit) librte, qĂ« lehtĂ«sojnĂ« punĂ«n me tabela tĂ« mĂ«dha ruterimi. PĂ«r kĂ«rkesat proxyarp u angazhua ndĂ«rfaqja fib. U shtua mundĂ«sia e ndryshimit nĂ« numrin fib nĂ« kohĂ« reale pĂ«rmes sysctl net.fibs. U realizua mbĂ«shtetje pĂ«r rrugĂ«t e pĂ«rkohshme pĂ«r IPv4 dhe IPv6 (me jetĂ«gjatĂ«si tĂ« caktuar).
  • ËshtĂ« ridizajnuar dhe bĂ«rĂ« mĂ« e shkallĂ«zueshme mbĂ«shtetje pĂ«r ruterimin me Multipath, nĂ« tĂ« cilin koha e kĂ«rkimit nuk varet nga madhĂ«sia e listĂ«s (O(1)). Realizimi i ri i Multipath tani Ă«shtĂ« i lidhur me parametrin e bĂ«rthamĂ«s ROUTE_MPATH, i cili zĂ«vendĂ«soi RADIX_MPATH dhe Ă«shtĂ« pĂ«rfshirĂ« automatikisht. PĂ«r menaxhimin e Multipath Ă«shtĂ« propozuar sysctl net.route.multipath.
  • ËshtĂ« riorganizuar korniza e kriptografisĂ« e realizuar nĂ« nivelin e bĂ«rthamĂ«s, e cila suporton algoritme kriptografike moderne dhe ka thjeshtĂ«suar ndĂ«rfaqen pĂ«r pĂ«rdorimin e enkriptimit nĂ« drejtues dhe komponente tĂ« tjera tĂ« bĂ«rthamĂ«s. JanĂ« hequr algoritmet e pĂ«rjetshme ARC4, Blowfish, CAST128, DES, DES, MD5-HMAC dhe Skipjack. NĂ« IPsec dhe Kerberos Ă«shtĂ« ndalur mbĂ«shtetja pĂ«r algoritmet e shpallura tĂ« vjetra nĂ« RFC 8221 dhe RFC 6649/8429, duke pĂ«rfshirĂ« 3DES. JanĂ« hequr algoritmet e mĂ«parshme tĂ« shpallura tĂ« vjetra nĂ« nĂ«n-sistemin e enkriptimit tĂ« diskĂ«ve geli dhe cryptodev.
  • NĂ« bĂ«rthamĂ«n GENERIC Ă«shtĂ« pĂ«rfshirĂ« mbĂ«shtetje pĂ«r drejtuesit aesni dhe armv8crypto pĂ«r pĂ«rshpejtimin e enkriptimit tĂ« disqeve bazuar nĂ« geli me ndihmĂ«n e instruksioneve AES-NI pĂ«r arkitekturĂ«n amd64/i386 dhe AES-XTS pĂ«r ARM64.
  • ËshtĂ« shtuar shoferi qat pĂ«r akceleratorĂ«t e enkriptimit Intel QuickAssist (QAT) dhe shoferi ossl me implementimin e procedurave tĂ« pĂ«rshpejtuara tĂ« enkriptimit nga OpenSSL, tĂ« optimizuara me kod nĂ« assembler. NĂ« shoferin armv8crypto Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r AES-XTS dhe AES-GCM duke pĂ«rdorur instruksionet pĂ«rkatĂ«se tĂ« procesorĂ«ve ARMv8.
  • ËshtĂ« shtuar implementimi i TLS (kTLS), qĂ« funksionon nĂ« nivelin e bĂ«rthamĂ«s FreeBSD, i cili lejon njĂ« rritje tĂ« konsiderueshme tĂ« performancĂ«s sĂ« enkriptimit pĂ«r soket TCP. MbĂ«shteten versionet e TLS nga 1.0 nĂ« 1.3. PĂ«r enkriptim pĂ«rdoren shoferĂ«t e kripto-bĂ«rthamĂ«s me mbĂ«shtetje pĂ«r AES-CBC ose AES-GCM. PĂ«r tĂ« pĂ«rdorur kTLS nĂ« hapĂ«sirĂ«n e pĂ«rdoruesit kĂ«rkohet ribĂ«rja e OpenSSL me opsionin WITH_OPENSSL_KTLS.
  • ËshtĂ« shtuar njĂ« lloj i ri i tamponĂ«ve tĂ« rrjetit mbuf (network data buffer), i cili mund tĂ« pĂ«rfaqĂ«sojĂ« nĂ« njĂ« tampon disa faqe fizike tĂ« papĂ«rshkruara tĂ« memories, qĂ« lejon rritjen e performancĂ«s sĂ« thirrjes sendfile(2) duke reduktuar madhĂ«sinĂ« e listave mbuf nĂ« tamponĂ«t e soketĂ«ve.
  • NĂ« stek TCP Ă«shtĂ« integruar mbĂ«shtetje pĂ«r algoritmin e reduktimit proporcional tĂ« intensitetit tĂ« dĂ«rgimeve tĂ« paketave (Proportional Rate Reduction, RFC 6937), i cili lejon rikthimin mĂ« tĂ« shpejtĂ« te parametrat optimalĂ« tĂ« rrjedhĂ«s pas problemeve tĂ« pĂ«rkohshme nĂ« transmetimin e tĂ« dhĂ«nave. PĂ«r tĂ« çaktivizuar PRR, ekziston sysctl net.inet.tcp.do_prr.
  • JanĂ« zgjeruar mundĂ«sitĂ« e hipervizorit Bhyve: ËshtĂ« shtuar mbĂ«shtetje pĂ«r ndarjen e skedarĂ«ve duke pĂ«rdorur VirtIO-9p (VirtFS). ËshtĂ« realizuar mundĂ«sia e punĂ«s me snapshot-et. makinat virtualeËshtĂ« shtuar mbĂ«shtetje pĂ«r pajisjet PCI HDAudio dhe porte tĂ« tjera seriale COM3 dhe COM4. JanĂ« eliminuar modelet e vjetra tĂ« pajisjeve bvmconsole dhe bvmdebug. Stabiliteti i punĂ«s me klientĂ«t VNC Ă«shtĂ« rritur, duke pĂ«rfshirĂ« aplikacionin pĂ«r macOS "Screen Sharing".
  • NĂ« shoferĂ«t VirtIO Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r specifikimin VirtIO V1, qĂ« pĂ«rmirĂ«son pajtueshmĂ«rinĂ« e sistemeve mikpritĂ«se me FreeBSD me emulatorĂ« dhe hipervizorĂ« tĂ« ndryshĂ«m.
  • PĂ«r proceset e lidhura me mjediset jail Ă«shtĂ« siguruar transformimi i lidhjeve me CPU (lidhja fillestare me procesin cpuset do tĂ« zĂ«vendĂ«sohet duke marrĂ« parasysh cpuset e jail-it dhe kufizimet e vendoshura).
  • ËshtĂ« shtuar mundĂ«sia pĂ«r ndĂ«rtimin e sistemit bazĂ« FreeBSD nĂ« ambientet tĂ« bazuara nĂ« sisteme tĂ« tjera operative. Nevoja pĂ«r ndĂ«rtimin nĂ« sisteme tĂ« tjera operative rezulton nga dĂ«shira pĂ«r tĂ« pĂ«rdorur mjetet e testimit pĂ«r FreeBSD qĂ« janĂ« lidhur me Linux ose macOS.
  • ËshtĂ« propozuar njĂ« stek i ri MMC/SD, i bazuar nĂ« kuadronin CAM dhe qĂ« lejon lidhjen e pajisjeve me ndĂ«rfaqen SDIO (Secure Digital I/O). PĂ«r shembull, SDIO pĂ«rdoret nĂ« modulat WiFi dhe Bluetooth pĂ«r shumĂ« plaka, si Raspberry Pi 3. Steku i ri gjithashtu lejon pĂ«rdorimin e ndĂ«rfaqes CAM pĂ«r dĂ«rgimin e komandave SD nga aplikacionet nĂ« hapĂ«sirĂ«n e pĂ«rdoruesit, duke ofruar mundĂ«sinĂ« pĂ«r tĂ« krijuar pajisje tĂ« drejtuara nga pĂ«rdoruesi.
  • ËshtĂ« pĂ«rmirĂ«suar funksionimi i shtresĂ«s pĂ«r pĂ«rputhshmĂ«rinĂ« me Linux. SkedarĂ«t DTS (Device Tree Sources) janĂ« sinkronizuar me bĂ«rthamĂ«n Linux 5.8.
  • ËshtĂ« shtuar mbĂ«shtetje pĂ«r NFSv4.2 (RFC-7862) dhe Ă«shtĂ« realizuar mundĂ«sia e funksionimit tĂ« NFS mbi njĂ« kanal tĂ« koduar tĂ« komunikimit tĂ« bazuar nĂ« TLS 1.3, nĂ« vend tĂ« pĂ«rdorimit tĂ« Kerberos (rezhimi sec=krb5p), i cili ishte i kufizuar nĂ« kodimin vetĂ«m tĂ« mesazheve RPC dhe ishte realizuar vetĂ«m nĂ« mĂ«nyrĂ« programore.
  • ËshtĂ« hequr versioni i vjetruar i debugger GDB, i cili mĂ« parĂ« ishte instaluar nĂ« katalogun /usr/libexec dhe pĂ«rdorej nĂ« utilitarin crashinfo. NĂ« vend tĂ« GDB tĂ« parainstaluar pĂ«r tĂ« marrĂ« informacion tĂ« detajuar mbi shkaqet e dĂ«shtimit, tani Ă«shtĂ« e rekomandueshme tĂ« instalohet njĂ« version i freskĂ«t i GDB nga portet ose paketat. ËshtĂ« ndĂ«rprerĂ« mbĂ«shtetja pĂ«r debugin e proceseve pĂ«rmes procfs. ËshtĂ« shtuar njĂ« drejtpĂ«rdrejtĂ«si netgdb, e cila lejon qasjen nĂ« debuggerin e bĂ«rthamĂ«s pĂ«rmes rrjetit.
  • Nga libc Ă«shtĂ« hequr funksioni i pasigurt gets (qĂ« nga standardi C11 ky funksion Ă«shtĂ« pĂ«rjashtuar nga specifikimi) dhe Ă«shtĂ« realizuar rregullimi i porteve qĂ« ende pĂ«rdorin kĂ«tĂ« funksion. JanĂ« hequr funksionet cap_random (duhet tĂ« pĂ«rdoret getrandom).
  • ËshtĂ« shtuar njĂ« thirrje e re sistemike copy_file_range, e cila Ă«shtĂ« e pĂ«rshtatshme me realizimin nga bĂ«rthama Linux dhe lejon shpejtimin e kopjimit tĂ« tĂ« dhĂ«nave nga njĂ« skedare nĂ« njĂ« tjetĂ«r, pĂ«rmes kryerjes sĂ« veprimit vetĂ«m nĂ« anĂ«n e bĂ«rthamĂ«s pa lexuar paraprakisht tĂ« dhĂ«nat nĂ« memorien e procesit. Kjo thirrje sistemike gjithashtu pĂ«rdoret nĂ« server NFSv4.2 pĂ«r kryerjen lokale tĂ« operacioneve tĂ« kopjimit nĂ« server (pa transfertĂ« pĂ«r klientin).
  • NĂ« mekanizmin e hyrjes/daljes asinkrone POSIX AIO, Ă«shtĂ« pĂ«rfshirĂ« mbĂ«shtetje pĂ«r funksionet e vektorizuara. VeçanĂ«risht, janĂ« shtuar thirrjet sistemike aio_writev dhe aio_readv, qĂ« lejojnĂ« zbatimin e ekuivalenteve vektorizuara tĂ« funksioneve aio_read dhe aio_write.
  • ËshtĂ« ndalur mbĂ«shtetja pĂ«r komponentĂ«t e hapĂ«sirĂ«s sĂ« pĂ«rdoruesit pĂ«r ndihmĂ«n e formatit tĂ« skedarĂ«ve ekzekutivĂ« a.out nĂ« sistemet me arkitekturĂ« i386. ËshtĂ« hequr utilita elf2aout.
  • Utilitat ping dhe ping6 janĂ« bashkuar. NĂ« ping Ă«shtĂ« shtuar mundĂ«sia pĂ«r tĂ« vendosur parametrat e cilĂ«sisĂ« sĂ« shĂ«rbimit (QoS) pĂ«rmes IP DSCP dhe Ethernet PCP.
  • NĂ« utilitĂ«n freebsd-update Ă«shtĂ« siguruar shfaqja e progresit tĂ« shkarkimit tĂ« skedarĂ«ve dhe janĂ« shtuar komandat updatesready dhe showconfig pĂ«r tĂ« kontrolluar disponueshmĂ«rinĂ« e pĂ«rditĂ«simeve dhe pĂ«r tĂ« parĂ« konfigurimin.
  • ËshtĂ« bĂ«rĂ« njĂ« punĂ« e madhe pĂ«r tĂ« pĂ«rmirĂ«suar mbĂ«shtetje pĂ«r sistemet NUMA (Non-Uniform Memory Access).
  • JanĂ« pĂ«rditĂ«suar driverĂ«t grafikĂ« dhe komponentĂ«t e pirgjeve grafike. Probleme me funksionimin e mjediseve qĂ« bazohen nĂ« Protokollin Wayland janĂ« zgjidhur.
  • ËshtĂ« shtuar njĂ« nĂ«n-sistem backlight pĂ«r krijimin e driverĂ«ve pĂ«r kontrollin e ndriçimit. ËshtĂ« shtuar driver-i pwm-backlight pĂ«r kontrollin e ndriçimit tĂ« Pinebook dhe Pinebook Pro.
  • MbĂ«shtetja pĂ«r protokollin SCTP Ă«shtĂ« zhvendosur nĂ« njĂ« modul tĂ« veçantĂ« sctp.ko, i cili nĂ« bĂ«rthamĂ«n GENERIC Ă«shtĂ« i çaktivizuar si parazgjedhje.
  • PĂ«r pajisjet hyrĂ«se Ă«shtĂ« propozuar njĂ« driver i ri usbhid, qĂ« pĂ«rdor rregullin hid pĂ«r punĂ«n me pajisjet USB HID, nĂ« vend tĂ« driverĂ«ve ukbd, ums dhe uhid.
  • NĂ« drejtuesin cpufreq Ă«shtĂ« implementuar mbĂ«shtetja pĂ«r teknologjinĂ« Intel Speed Shift.
  • ËshtĂ« shtyrĂ« mbĂ«shtetje pĂ«r kĂ«to pllakĂ«za tĂ« reja tĂ« bazuara nĂ« CPU 64-bit ARMv8, duke pĂ«rfshirĂ« SoC Broadcom BCM5871X dhe NXP LS1046A.
  • PĂ«r arkitekturĂ«n AMD64 Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r adresat virtuale 57-bit (LA57). ËshtĂ« shtuar mbĂ«shtetje pĂ«r CPU x86 kineze Hygon Dhyana, bazuar nĂ« teknologjitĂ« AMD.
  • Porti pĂ«r arkitekturĂ«n powerpc64 Ă«shtĂ« kaluar nĂ« pĂ«rdorimin e LLVM dhe ABI ELFv2 (skedarĂ«t binarĂ« nga versionet e kaluara tĂ« FreeBSD nuk do tĂ« mund tĂ« pĂ«rdoren nĂ« FreeBSD 13). PĂ«r powerpc64 janĂ« portuar driverĂ«t virtio, ixl, mrsas, aacraid, cpld.
  • JanĂ« hequr driverĂ«t pĂ«r adaptuesit Ethernet tĂ« vjetĂ«ruar:
    • bm(4) BMAC
    • cs(4) Crystal Semiconductor CS8900/CS8920
    • de(4) DEC DC21x4x
    • ed(4) NE-2000 dhe WD-80×3
    • ep(4) 3Com Etherlink III (3c5x9) ISA
    • ex(4) Intel EtherExpress Pro/10 dhe Pro/10+
    • fe(4) Fujitsu MB86960A/MB86965A
    • hme(4) Sun Microelectronics STP2002-STQ
    • pcn(4) AMD PCnet
    • sf(4) Starfire
    • sn(4) SMC 91Cxx
    • tl(4) Texas Instruments ThunderLAN
    • tx(4) SMC 83c17x
    • txp(4) 3Com 3XP Typhoon/Sidewinder (3CR990)
    • vx(4) 3Com EtherLink III/Fast EtherLink III (3c59x) PCI
    • wb(4) Winbond W89C840F
    • xe(4) Xircom PCMCIA
  • JanĂ« hequr driverĂ«t ubsec (krypto-akseleratorĂ«t Broadcom BCM58xx), ufm (FM-tunerĂ«t me ndĂ«rfaqe USB), ctau (Cronix Tau), cx (Cronix Sigma) dhe vpo (SCSI me port paralel).

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster