Autori i GnuPG themeloi LibrePGP, një fork i standartit OpenPGP.

Werner Koch, zhvilluesi kryesor dhe krijuesi i projektit GnuPG, ka themeluar projektin LibrePGP, i fokusuar në zhvillimin e specifikimit të përmirësuar, alternativ standardit OpenPGP. Fork-u u krijua si përgjigje ndaj ndryshimeve të parashikuara nga grupi punues IETF për përditësimin e ardhshëm të specifikimit OpenPGP dhe të cilat Koch i perceptoi si problematike për ruajtjen e përputhshmërisë dhe siguritë. Zhvilluesit që mbështetën fork-un, duke përfshirë ata të projekteve GnuPG, RNP (implementimi OpenPGP nga Thunderbird) dhe Gpg4win, kanë frikë se ndryshimet e planifikuara do të jenë shkatërruese për implementimet ekzistuese të aplikacioneve të bazuara në OpenPGP, përdoruesit e të cilëve shpresojnë për stabilitetin e specifikimit në afat të gjatë dhe nuk janë të gatshëm të pranojnë ndryshime që shkelin përputhshmërinë.

LibrePGP përfshin përmirësime të dobishme, të zhvilluara në vitet e fundit për versionin e ardhshëm të specifikimit OpenPGP, por përjashton ndryshimet që ndikojnë negativisht në sigurimin e përputhshmërisë. Për shembull, krahasuar me standardin aktual RFC-4880, në LibrePGP janë pranuar mundësi të tilla si:

  • MbĂ«shtetje pĂ«r algoritmin e enkriptimit Camellia (RFC-5581),
  • Zgjerime ECC (Elliptic Curve Cryptography) pĂ«r OpenPGP (RFC-6637).
  • MbĂ«shtetje e detyrueshme pĂ«r hash SHA2-256 (SHA-1 dhe MD5 janĂ« klasifikuar si tĂ« papĂ«rshkueshĂ«m, ndĂ«rsa mundĂ«sia pĂ«r tĂ« deshifruar tĂ« dhĂ«nat pa verifikimin e integritetit Ă«shtĂ« klasifikuar si plotĂ«sisht e vjetruar).
  • Rritje deri nĂ« 256 bit tĂ« madhĂ«sisĂ« sĂ« gjurmĂ«s verifikuese (fingerprint).
  • MbĂ«shtetje pĂ«r skemĂ«n e nĂ«nshkrimeve digjitale EdDSA dhe pĂ«r elliptic curves BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 dhe X448.
  • MbĂ«shtetje pĂ«r algoritmin CRYSTALS-Kyber, tĂ« qĂ«ndrueshĂ«m ndaj sulmeve nga kompjuterĂ«t kuantik.
  • MbĂ«shtetje pĂ«r mĂ«nyrat e enkriptimit tĂ« autentifikuar OCB (Offset codebook mode).
  • Zbatimi i versionit tĂ« pestĂ« tĂ« formatit tĂ« nĂ«nshkrimeve digjitale me mbrojtje metadata.
  • MbĂ«shtetje pĂ«r nĂ«npaketa tĂ« zgjeruara me nĂ«nshkrime digjitale.

Elementet kryesore të kritikës së specifikimit të ri OpenPGP:

  • Grupi punues IETF, nĂ« vend qĂ« tĂ« bĂ«jĂ« njĂ« pĂ«rditĂ«sim graduale tĂ« specifikimit, u pĂ«rpoq tĂ« ri-inxiste standartin dhe tĂ« bĂ«nte ndryshime tĂ« rĂ«ndĂ«sishme qĂ« shkelin pĂ«rputhshmĂ«rinĂ«.
  • Imponimi mbĂ«shtetjes pĂ«r modin simetrik tĂ« enkriptimit GCM (Galois/Counter Mode), i cili Ă«shtĂ« i vĂ«shtirĂ« pĂ«r tu implementuar saktĂ«, duke injoruar kĂ«shtu modin OCB (Offset codebook mode), pĂ«r tĂ« cilin patentat skaduan disa vjet mĂ« parĂ«.
  • Shtimi i pakove opsionale me mbushje tĂ« rastĂ«sishme pĂ«r tĂ« mbrojtur nga analizimi i trafikut. Sipas krijuesve tĂ« LibrePGP, kĂ«to paketa me mbushje tĂ« rastĂ«sishme tĂ« pa verifikueshme krijojnĂ« rreziqe tĂ« pĂ«rdoren pĂ«r tĂ« krijuar kanale tĂ« fshehtĂ« tĂ« transfertĂ«s dhe pĂ«r tĂ« anashkaluar sistemet e parandalimit tĂ« rrjedhjeve tĂ« tĂ« dhĂ«nave. MĂ« parĂ«, ideja e pĂ«rfshirjes sĂ« mbushjes ishte refuzuar, duke u konsideruar si njĂ« çështje nĂ« nivel aplikacioni, e jo enkriptimi.
  • PĂ«rdorimi i njĂ« skeme tĂ« modifikuar tĂ« enkriptimit ECDH (ndryshimi i formatit OID), nĂ« vend tĂ« pĂ«rdorimit tĂ« versionit tĂ« pĂ«rshkruar nĂ« RFC-6637 dhe tĂ« realizuar nĂ« PGP dhe GnuPG.
  • Heqja e disa mundĂ«sive tĂ« pĂ«rdorura nĂ« praktikĂ«, si metoda klasike e revokimit tĂ« çelĂ«save, flagu "m" pĂ«r tĂ« shĂ«nuar tĂ« dhĂ«nat MIME dhe flagu "t" pĂ«r tĂ« ndarĂ« tĂ« dhĂ«nat tekst nga ato binarĂ« (nĂ« vend tĂ« flagut "t" ka ardhur flagu "u" pĂ«r tekst nĂ« kodimin UTF-8).
  • Refuzimi pĂ«r tĂ« pĂ«rfshirĂ« nĂ« formatin e ri tĂ« nĂ«nshkrimeve mbrojtjen e metadatat e skedarit tĂ« nĂ«nshkruar (pĂ«r shembull, Ă«shtĂ« e mundur tĂ« ndryshosh emrin e skedarit pa prishur nĂ«nshkrimin).
  • MundĂ«sia e dyshimtĂ« pĂ«r tĂ« shtuar "krip" nĂ« nĂ«nshkrime (Salted signature) pĂ«r tĂ« pĂ«rforcuar mbrojtjen nga sulmet e kolizionit me njĂ« prefiks tĂ« caktuar. Vlera e kripuar mund tĂ« pĂ«rdoret si njĂ« kanal i fshehtĂ« i papĂ«rjashtueshĂ«m pĂ«r tĂ« transmetuar 32 byte tĂ« dhĂ«nash nĂ« nĂ«nshkrim.
  • ShkallĂ«zimi i standardit drejt pĂ«rdorimit kryesor pĂ«r komunikim online, duke injoruar nevojat pĂ«r ruajtjen afatgjatĂ« tĂ« tĂ« dhĂ«nave.

Përkrahësit e OpenPGP tashmë kanë publikuar kritikë mbi kritikën. Si rezultat, nëse nuk gjendet një kompromis, ndarja mund të çojë në rritjen e mosmarrëveshjeve në realizimet e OpenPGP/LibrePGP. Pjesërisht për të zgjidhur këtë problem, zhvilluesit e OpenPGP e kanë konzistuar versionin e pestë të formatit të nënshkrimeve në një formë të përputhshme me LibrePGP dhe kanë kaluar në punën për versionin e gjashtë.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster