Ofruar biblioteka nghttp3 1.0 me implementimin e protokollit HTTP/3

Ndërmarrja e parë e stabilizuar e projektit nghttp3, që zhvillon një bibliotekë në gjuhën C me implementimin e protokollit HTTP/3. Një variant i zhvilluar nga i njëjti projekt për protokollin HTTP/2 përdoret si baza e modulit mod_http2, që përfshihet në serverin http Apache. Progreset e projektit janë po ashtu të angazhuara në utilitarin Curl. Kodi i bibliotekës shpërndahet nën licencën MIT.

Standardi HTTP/3 përcakton përdorimin e protokollit QUIC (Quick UDP Internet Connections) si transport për HTTP/2. QUIC është një shtesë mbi protokollin UDP, e cila mbështet shumëfishimin e disa lidhjeve dhe ofron metodat e enkriptimit, ekuivalente me TLS/SSL. Protokolli u krijua në vitin 2013 nga Google si një alternativë ndaj lidhjes TCP+TLS për Web-in, që zgjidh problemet me kohën e gjatë të instalimit dhe negocimit të lidhjeve në TCP dhe eliminoi vonesat gjatë humbjes së paketave gjatë transferimit të të dhënave.

NĂ« nghttp3 ofrohet njĂ« implementim i pavarur i specifikimeve RFC 9114 (HTTP/3 mbi protokollin QUIC), RFC 920 (teknologjia e kompresimit tĂ« titujve QPACK), RFC 9220 (transmetimi i WebSockets mbi HTTP/3) dhe RFC 9218 (skema e zgjerueshme pĂ«r menaxhimin e prioriteteve tĂ« dĂ«rgimit tĂ« pĂ«rgjigjeve nĂ« kĂ«rkesat e klientit). Biblioteka nuk varet nga staket e caktuara QUIC dhe mbĂ«shtet punĂ«n mbi implementime tĂ« ndryshme tĂ« protokollit tĂ« transportit QUIC. NdĂ«rkohĂ«, projekti gjithashtu zhvillon njĂ« implementim tĂ« vetin tĂ« protokollit QUIC — ngtcp2, i cili aplikohet si i default. Si backend pĂ«r enkriptimin e tĂ« dhĂ«nave nĂ« ngtcp2 mbĂ«shteten quictls, GnuTLS, BoringSSL, Picotls dhe wolfSSL. NĂ« tĂ« njĂ«jtĂ«n kohĂ« me nghttp3 1.0 Ă«shtĂ« publikuar edhe lĂ«shimi i parĂ« stabil i ngtcp2 1.0.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster