Protokolli HTTP/3.0 mori statusin e standardit të propozuar

Komiteti IETF (Internet Engineering Task Force), qĂ« merret me zhvillimin e protokolleve dhe arkitekturĂ«s sĂ« internetit, pĂ«rfundoi formimin e RFC pĂ«r protokollin HTTP/3.0 dhe publikoi spesifikimet pĂ«rkatĂ«se me identifikuesit RFC 9114 (protokolli) dhe RFC 9204 (teknologjia e kompresimit tĂ« titujve QPACK pĂ«r HTTP/3). Specifikimi HTTP/3.0 mori statusin e ‘Standardit tĂ« Propozuar’, pas sĂ« cilĂ«s do tĂ« fillojĂ« puna pĂ«r t’i dhĂ«nĂ« RFC statusin e standardit tĂ« projektit (Draft Standard), i cili nĂ« fakt do tĂ« thotĂ« stabilizim tĂ« plotĂ« tĂ« protokollit dhe marrjen parasysh tĂ« tĂ« gjitha vĂ«rejtjeve tĂ« shtruara. NjĂ«kohĂ«sisht, u publikuan variante tĂ« pĂ«rditĂ«suara tĂ« specifikimeve pĂ«r protokollet HTTP/1.1 (RFC 9112) dhe HTTP/2.0 (RFC 9113), si dhe dokumente qĂ« pĂ«rcaktojnĂ« semantikĂ«n e kĂ«rkesave HTTP (RFC 9110) dhe titujt e menaxhimit tĂ« keqkodimit (RFC 9111).

Protokolli HTTP/3 përcakton përdorimin e protokollit QUIC (Quick UDP Internet Connections) si transport për HTTP/2. QUIC paraqet një shtresë mbi protokollin UDP, që mbështet shumë lidhje dhe ofron metoda enkriptimi, ekuivalente me TLS/SSL. Protokolli u krijua në vitin 2013 nga Google si një alternativë për TCP+TLS për Webin, duke zgjidhur problemet me kohën e madhe të vendosjes dhe negociatës së lidhjeve në TCP, dhe eliminon vonesat gjatë humbjes së pacakove gjatë procesit të transferimit të të dhënave.

Protokolli HTTP/3.0 mori statusin e standardit të propozuar

Aktualisht mbështetje për QUIC dhe HTTP/3.0 është tashmë implementuar në të gjithë shfletuesit web të njohur (në Chrome, Firefox dhe Edge mbështetje për HTTP/3 është e aktivizuar si parazgjedhje, ndërsa në Safari kërkon aktivizimin e cilësimit 'Advanced > Experimental Features > HTTP/3'). Në anën e serverit, implementimet e HTTP/3 janë të disponueshme për nginx (në një degë të veçantë dhe në formën e një moduli të veçantë), Caddy, IIS dhe LiteSpeed. Mbështetje për HTTP/3 gjithashtu ofron rrjeti i shpërndarjes së përmbajtjes Cloudflare.

Karakteristikat kryesore të QUIC:

  • Siguri e lartĂ«, e ngjashme me TLS (nĂ« thelb QUIC ofron mundĂ«sinĂ« e pĂ«rdorimit tĂ« TLS mbi UDP);
  • Kontrolli mbi integritetin e rrjedhĂ«s, qĂ« parandalon humbjen e pacakove;
  • MundĂ«sia pĂ«r tĂ« vendosur menjĂ«herĂ« njĂ« lidhje (0-RTT, nĂ« rreth 75% tĂ« rasteve tĂ« dhĂ«nat mund tĂ« transmetohen menjĂ«herĂ« pas dĂ«rgimit tĂ« paketĂ«s sĂ« vendosjes sĂ« lidhjes) dhe pĂ«r tĂ« siguruar vonesa minimale midis dĂ«rgimit tĂ« kĂ«rkesĂ«s dhe marrjes sĂ« pĂ«rgjigjes (RTT, Round Trip Time);
    Protokolli HTTP/3.0 mori statusin e standardit të propozuar
  • PĂ«rdorimi i njĂ« numri tjetĂ«r sekonda pĂ«r dĂ«rgimin e paketave pĂ«rsĂ«ritĂ«se, gjĂ« qĂ« lejon shmangien e dyshimeve nĂ« pĂ«rcaktimin e paketave tĂ« pranuara dhe eliminon vonesat;
  • Humorja e paketĂ«s ndikon vetĂ«m nĂ« dĂ«rgesĂ«n e fluksit lidhur me tĂ« dhe nuk ndalon dĂ«rgimin e tĂ« dhĂ«nave nĂ« flukset qĂ« dĂ«rgohen paralelisht nĂ«pĂ«rmjet lidhjes aktuale;
  • Mjetet pĂ«r korrigjimin e gabimeve, qĂ« minimizojnĂ« vonesat pĂ«r shkak tĂ« dĂ«rgimit pĂ«rsĂ«ritĂ«s tĂ« paketave tĂ« humbura. PĂ«rdorimi i kodeve speciale pĂ«r korrigjimin e gabimeve nĂ« nivelin e paketĂ«s pĂ«r tĂ« reduktuar situatat qĂ« kĂ«rkojnĂ« dĂ«rgim pĂ«rsĂ«ritĂ«s tĂ« tĂ« dhĂ«nave tĂ« paketĂ«s sĂ« humbur.
  • KufijtĂ« e bllokave kriptografikĂ« janĂ« pĂ«rputhur me kufijtĂ« e paketave QUIC, duke zvogĂ«luar ndikimin e humbjeve tĂ« paketave nĂ« dekodimin e pĂ«rmbajtjes sĂ« paketave tĂ« ardhshme;
  • Mungesa e problemeve me bllokimin e radhĂ«s TCP;
  • MbĂ«shtetje pĂ«r identifikuesin e lidhjes, qĂ« lejon zvogĂ«limin e kohĂ«s pĂ«r vendosjen e lidhjes pĂ«rsĂ«ritĂ«se pĂ«r klientĂ«t mobilĂ«;
  • MundĂ«sia e lidhjes sĂ« mekanizmave tĂ« zgjeruar tĂ« kontrollit tĂ« ngarkesĂ«s sĂ« lidhjes;
  • PĂ«rdorimi i teknikave tĂ« parashikimit tĂ« kapacitetit nĂ« çdo drejtim pĂ«r tĂ« siguruar intensitetin optimal tĂ« dĂ«rgimit tĂ« paketave, duke parandaluar rĂ«nien nĂ« njĂ« gjendje ngarkese, ku humbjet e paketave vĂ«rehen;
  • Rritje e dukshme e performancĂ«s dhe kapacitetit krahasuar me TCP. PĂ«r shĂ«rbimet video si YouTube, aplikimi i QUIC ka treguar njĂ« reduktim prej 30% tĂ« operacioneve tĂ« ri-buffering gjatĂ« shikimit tĂ« videove.

Nga ndryshimet në specifikimin e HTTP/1.1, mund të theksohet ndalimi i përdorimit të veçantë të simbolit të kthimit të karikës (CR) jashtë trupit përmbajtësor, dmth, në elementët e protokollit, simboli CR mund të përdoret vetëm së bashku me simbolin e kalimit të radhës (CRLF). Algoritmi i rregullimit të kërkesave chunked është përmirësuar për të thjeshtuar ndarjen e fushave të bashkangjitura dhe seksionit të titujve. Janë shtuar rekomandime për përpunimin e përmbajtjeve të paqartësisë për të bllokuar sulmet e klasës 'HTTP Request Smuggling', që lejojnë ndërhyrjen në përmbajtjen e kërkesave të përdoruesve të tjerë në fluxin midis front-end dhe back-end.

Në përditësimin e specifikimeve HTTP/2.0, mbështetja për TLS 1.3 është përcaktuar qartë. Schema e definicionit të prioritetit dhe fushat e lidhura në tituj janë klasifikuar si të destinuara për t'u konsideruar të vjetëruara. Mënyra e rifreskimit të lidhjes me HTTP/1.1, e cila nuk ka gjetur përhapje, është shpallur e vjetëruar. Kërkesat për verifikimin e emrave të fushave dhe vlerave janë reduktuar. Disa lloje kadri dhe parametra të rezervuar më parë janë rekomanduar për t'u përdorur. Fushat e ndaluara të titujve që lidhen me lidhjen janë përcaktuar më në detaje.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster