Implementimi i algoritmeve kriptografike GOST në gjuhën Java

ËshtĂ« publikuar biblioteka crypto-gost me implementimin e algoritmeve kriptografikĂ« GOST nĂ« gjuhĂ«n Java, e cila nuk pĂ«rdor varĂ«si tĂ« tjera. NĂ« krahasim me implementimin e algoritmeve GOST nga biblioteka Castle Bouncy Castle, nĂ« crypto-gost Ă«shtĂ« rritur performanca e enkriptimit me algoritmin "Kuznechik", janĂ« zgjidhur disa çështje tĂ« sigurisĂ« dhe janĂ« ofruar mbĂ«shtetje tĂ« thjeshta qĂ« nuk kĂ«rkojnĂ« njohuri tĂ« thella nĂ« kriptografi. Kodi ofrohet nĂ«n njĂ« licencĂ« tĂ« veçantĂ« qĂ« lejon shpĂ«rndarjen, modifikimin dhe krijimin e punimeve tĂ« pjesshme pa kufizime.

Algoritmet e mbështetura:

  • GOST R 34.11-2012 (RFC 6986) — funksioni hash "Streebog" 256 dhe 512 bit.
  • GOST R 34.12-2015 — shifra bllok "Kuznechik", çelĂ«si 256 bit.
  • GOST R 34.13-2015 — modulet e enkriptimit CBC, CFB, CTR (GAMMA), OFB; mbushja e imituar (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — nĂ«nshkrimi elektronik 256 dhe 512 bit.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 dhe HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — modalitĂ  AEAD pĂ«r Kuznechik (RFC 9058). E pĂ«rputhshme me OpenSSL.
  • SCrypt (RFC 7914) — funksioni pĂ«rformues i çelĂ«sit i bazuar nĂ« fjalĂ«kalim.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster