Pas pesë muajsh zhvillimi u paraqit lëshimi i OpenSSH 8.5, një zbatim të hapur të klientit dhe serverit për punën sipas protokolleve SSH 2.0 dhe SFTP.
Zhvilluesit e OpenSSH kujtuan pĂ«r kalimin e ardhshĂ«m nĂ« kategorinĂ« e algoritmeve tĂ« vjetruar, tĂ« cilat pĂ«rdorin hash SHA-1, pĂ«r shkak tĂ« rritjes sĂ« efikasitetit tĂ« sulmeve ndaj kolizionit me njĂ« prefiks tĂ« caktuar (kostoja e gjetjes sĂ« njĂ« kolizioni vlerĂ«sohet nĂ« rreth 50 mijĂ« dollarĂ«). NĂ« njĂ« nga lĂ«shimet e ardhshme planifikojnĂ« tĂ« çaktivizojnĂ« si paraprakisht mundĂ«sinĂ« e pĂ«rdorimit tĂ« algoritmit tĂ« nĂ«nshkrimit digjital nga çelĂ«si publik âssh-rsaâ, i cili pĂ«rmendet nĂ« RFC e origjinĂ«s pĂ«r protokollin SSH dhe mbetet i zakonshĂ«m nĂ« praktikĂ«.
PĂ«r tĂ« kontrolluar pĂ«rdorimin e ssh-rsa nĂ« sistemet tuaja, mund tĂ« provoni tĂ« lidheni pĂ«rmes ssh me opsionin â-oHostKeyAlgorithms=-ssh-rsaâ. MegjithatĂ«, çaktivizimi i nĂ«nshkrimeve digjitale âssh-rsaâ si paraprakisht nuk do tĂ« thotĂ« njĂ« heqje tĂ« plotĂ« tĂ« pĂ«rdorimit tĂ« çelĂ«save RSA, pasi pĂ«rveç SHA-1 protokolli SSH lejon pĂ«rdorimin e algoritmeve tĂ« tjerĂ« pĂ«r llogaritjen e hash-it. NĂ« veçanti, pĂ«rveç âssh-rsaâ, do tĂ« mbetet mundĂ«sia e pĂ«rdorimit tĂ« çiftĂ«ve ârsa-sha2-256â (RSA/SHA256) dhe ârsa-sha2-512â (RSA/SHA512).
PĂ«r tĂ« lehtĂ«suar kalimin nĂ« algoritme tĂ« reja, nĂ« OpenSSH 8.5 Ă«shtĂ« pĂ«rfshirĂ« si paraprakisht konfigurimi UpdateHostKeys, i cili lejon automatikisht klientĂ«t tĂ« kalojnĂ« nĂ« algoritme mĂ« tĂ« sigurta. Me kĂ«tĂ« konfigurim aktivizohet njĂ« zgjerim i veçantĂ« i protokollit âhostkeys@openssh.comâ, i cili lejon serverin, pas pĂ«rfundimit tĂ« autentifikimit, tĂ« informojĂ« klientin pĂ«r tĂ« gjithĂ« çelĂ«sat e disponueshĂ«m tĂ« hostit. Klienti mund tĂ« pasqyrojĂ« kĂ«to çelĂ«sa nĂ« skedarin e tij ~/ .ssh/known_hosts, i cili lejon organizimin e pĂ«rditĂ«simit tĂ« çelĂ«save tĂ« hostit dhe lehtĂ«son ndĂ«rrimin e çelĂ«save. server.
Përdorimi i UpdateHostKeys është i kufizuar nga disa kushte, të cilat në të ardhmen mund të hiqen: çelësi duhet të përmendet në UserKnownHostsFile dhe të mos përdoret në GlobalKnownHostsFile; çelësi duhet të jetë i pranishëm vetëm nën një emër; nuk duhet të përdoret një certifikatë e çelësit të hostit; në known_hosts nuk duhet të aplikohen maska sipas emrit të hostit; duhet të jetë çaktivizuar konfigurimi VerifyHostKeyDNS; parameteri UserKnownHostsFile duhet të jetë aktiv.
Mes algoritmet e rekomanduara për migrim përmenden rsa-sha2-256/512 bazuar në RFC8332 RSA SHA-2 (mbështetet që nga OpenSSH 7.2 dhe përdoret si parazgjedhje), ssh-ed25519 (mbështetet që nga OpenSSH 6.5) dhe ecdsa-sha2-nistp256/384/521 bazuar në RFC5656 ECDSA (mbështetet që nga OpenSSH 5.7).
Ndryshime të tjera:
- Ndryshimet lidhur me sigurinë:
- Në ssh-agent është eliminuar një cenueshmëri e shkaktuar nga çlirimi i përsëritur i një zone kujtese të çliruar tashmë (double-free). Problemi shfaqet që nga versioni OpenSSH 8.2 dhe potencialisht mund të shfrytëzohet nëse një sulmues ka qasje në soketin ssh-agent në sistemin lokal. Shfrytëzimi vështirësohet nga fakti që vetëm root dhe përdoruesi origjinal kanë qasje në soket. Skema më e mundshme sulmi është ridrejtimi i agentit në një llogari që kontrollohet nga keqbërësi, ose në një host, ku keqbërësi ka qasje root.
- Në sshd është shtuar një mbrojtje nga kalimi i parametrave shumë të mëdhenj me emrin e përdoruesit në nën-sistemin PAM, e cila lejon bllokimin e cenueshmërive në modulet sistemore PAM (Pluggable Authentication Module). Për shembull, ndryshimi lejon parandalimin e përdorimit të sshd si një vektor për eksploitimin e një cenueshmërie të fundit të zbuluar root në Solaris (CVE-2020-14871).
- Ndryshimet që potencialisht e dëmtojnë kompatibilitetin:
- Në ssh dhe sshd është rishikuar metoda eksperimentale e ndërrimit të çelësave, e qëndrueshme ndaj përpjekjeve për t'u thyer nga kompjuterët kuantike. Kompjuteri kuantik zgjidh shumë më shpejt problemin e faktorëve primarë të numrave natyrorë, i cili është në thelb i bazuar në algoritmet moderne të enkriptimit asimetrik dhe është efektivisht i pa zgjidhshëm në procesorët klasikë. Metoda e përdorur bazohet në algoritmin NTRU Prime, të zhvilluar për sistemet kriptografike pas-kvantum, dhe metodën e ndërrimit të çelësave mbi bazën e kurbave eliptike X25519. Në vend të sntrup4591761x25519-sha512@tinyssh.org, metoda tani identifikohet si sntrup761x25519-sha512@openssh.com (algoritmi sntrup4591761 është zëvendësuar me sntrup761).
- Në ssh dhe sshd është ndryshuar rendi i shpalljes së algoritmeve të suportuar për nënshkrimet dixhitale. Tani e para ofrohet ED25519 në vend të ECDSA.
- Në ssh dhe sshd, vendosja e parametrave të cilësisë së shërbimit TOS/DSCP për seancat interaktive tani bëhet para vendosjes së lidhjes TCP.
- Në ssh dhe sshd është ndaluar mbështetja e algoritmit rijndael-cbc@lysator.liu.se, i cili është identik me aes256-cbc dhe është përdorur deri në miratimin e RFC-4253.
- Mezauro është çaktivizuar për parazgjedhjen CheckHostIP, i cili ka përfitim të vogël, por përdorimi i tij e komplikon ndjeshëm rotacionin e çelësave për hostet pas balancuesve të ngarkesës.
- Në sshd janë shtuar cilësimet PerSourceMaxStartups dhe PerSourceNetBlockSize për të kufizuar intensitetin e nisjes së përpunuesve përkatësisht adresës së klientit. Këto parametra lejojnë menaxhimin më të saktë të kufizimeve të nisjes së proceseve, krahasuar me cilësimin e përgjithshëm MaxStartups.
- Në ssh dhe sshd është shtuar një cilësim i ri LogVerbose, që lejon ngritjen e detyrueshme të nivelit të informacionit të regjistrimit të ndihmës, me mundësinë e filtrimit sipas modeleve, funksioneve dhe skedave.
- Në ssh, kur pranohet një çelës hosti i ri, janë shfaqur të gjitha emrat e hosteve dhe IP-adresat, që janë të asocuar me çelësin.
- Në ssh është e lejuar të specifikohet opsioni UserKnownHostsFile=none për të çaktivizuar përdorimin e skedarit known_hosts gjatë identifikimit të çelësave të hostit.
- Në ssh_config për ssh është shtuar cilësimi KnownHostsCommand, që lejon marrjen e të dhënave known_hosts nga dalja e komandës së specifikuar.
- Në ssh_config për ssh është shtuar opsioni PermitRemoteOpen, i cili lejon kufizimin e destinacionit gjatë përdorimit të opsionit RemoteForward me SOCKS.
- Në ssh për çelësat FIDO është siguruar një kërkesë për PIN në rast të dështimit të operacionit të nënshkrimit digjital për shkak të PIN-it të pasaktë dhe mungesës së kërkesës për PIN nga përdoruesi (për shembull, kur nuk arriti të merrte të dhëna biometrike të sakta dhe pajisja u kthye në futjen manuale të PIN-it).
- Në sshd është shtuar mbështetje për thirrje të tjera sistemore në mekanizmin e izolimit të procesit të bazuar në seccomp-bpf në platformën Linux.
- U azhurnua utilitari contrib/ssh-copy-id.
Burimi: opennet.ru
