Lëshimi i FreeBSD 12.3

U lançuar versioni FreeBSD 12.3, i cili është publikuar për arkitekturat amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 dhe armv6, armv7 dhe aarch64. Për më tepër, janë përgatitur imazhe për sisteme virtualizimi (QCOW2, VHD, VMDK, raw) dhe për mjedise cloud në Amazon EC2. Versioni FreeBSD 13.1 pritet në pranverën e vitit 2022.

Novitetet kryesore:

  • Shtuar skripti /etc/rc.final, i cili ekzekutohet nĂ« fazĂ«n e fundit tĂ« funksionimit pas pĂ«rfundimit tĂ« tĂ« gjitha proceseve tĂ« pĂ«rdoruesit.
  • NĂ« filtrin e paketave ipfw Ă«shtĂ« pĂ«rfshirĂ« komanda dnctl pĂ«r tĂ« menaxhuar konfigurimet e sistemit tĂ« kufizimit tĂ« trafikut dummynet.
  • Shtuar sysctl kern.crypto pĂ«r tĂ« menaxhuar nĂ«n-sistemin kriptografik tĂ« bĂ«rthamĂ«s, si dhe sysctl debug.uma_reclaim pĂ«r debug.
  • Shtuar sysctl net.inet.tcp.tolerate_missing_ts, i cili lejon TCP-paketat pa vula kohore (opsioni timestamp, RFC 1323/RFC 7323).
  • NĂ« bĂ«rthamĂ«n GENERIC pĂ«r arkitekturĂ«n amd64 Ă«shtĂ« aktivizuar opsioni COMPAT_LINUXKPI dhe Ă«shtĂ« aktivizuar driver-i mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • NĂ« ngritĂ«s Ă«shtĂ« shtuar mundĂ«sia pĂ«r tĂ« ngarkuar sistemin operativ nga ram-disku, si dhe Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r opsionet ZFS com.delphix:bookmark_written dhe com.datto:bookmark_v2.
  • NĂ« bibliotekĂ«n fetch Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r prokurimin FTP mbi HTTPS.
  • NĂ« menaxherin e paketave pkg pĂ«r komandat 'bootstrap' dhe 'add' Ă«shtĂ« realizuar flamuri '-r' pĂ«r tĂ« specificuar depozitarin. ËshtĂ« siguruar pĂ«rdorimi i variablave tĂ« mjedisit nga skedari pkg.conf.
  • NĂ« utilitarin growfs Ă«shtĂ« bĂ«rĂ« e mundur punimi me sisteme skedarĂ«sh tĂ« montuara nĂ« modalitetin leximi dhe shkrimi.
  • NĂ« utilitarin etcupdate Ă«shtĂ« realizuar njĂ« mod pĂ«r kthimin pas pĂ«r tĂ« rikuperuar njĂ« ose mĂ« shumĂ« skedarĂ«. Shtuar flamuri '-D' pĂ«r tĂ« specifikuar dosjen e destinacionit. Siguruar ekstraktimin e tĂ« dhĂ«nave duke pĂ«rdorur njĂ« dosje tĂ« pĂ«rkohshme dhe shtuar trajtimin e SIGINT.
  • NĂ« utilitetet freebsd-update dhe freebsd-version Ă«shtĂ« shtuar flamuri '-j' pĂ«r mbĂ«shtetje tĂ« mjediseve jail.
  • Utilitari cpuset tani mund tĂ« pĂ«rdoret nĂ« mjediset jail pĂ«r tĂ« ndryshuar parametrat e jail-ve fĂ«mijĂ«.
  • NĂ« utilitarin cmp janĂ« shtuar opsionet: '-b' (—print-bytes) pĂ«r tĂ« shfaqur bajtĂ«t e ndryshĂ«m, '-i' (—ignore-initial) pĂ«r tĂ« injoruar njĂ« numĂ«r tĂ« caktuar bajtĂ«sh fillestarĂ«, '-n' (—bytes) pĂ«r tĂ« kufizuar numrin e bajtĂ«ve tĂ« krahasuar.
  • NĂ« utilitarin daemon Ă«shtĂ« shtuar flamuri '-H' pĂ«r trajtimin e SIGHUP dhe pĂ«r tĂ« hapur pĂ«rsĂ«ri skedarin ku bĂ«het output (shtuar pĂ«r mbĂ«shtetje tĂ« newsyslog).
  • NĂ« utilitarin fstyp, me specifikimin e flamurit '-l', Ă«shtĂ« siguruar pĂ«rkufizimi dhe shfaqja e sistemeve skedarĂ«sh exFAT.
  • NĂ« utilitarin mergemaster Ă«shtĂ« realizuar pĂ«rpunimi i lidhjeve simbolike gjatĂ« procesit tĂ« pĂ«rditĂ«simit.
  • NĂ« utilitarin newsyslog Ă«shtĂ« shtuar flama "E" pĂ«r tĂ« çaktivizuar rrotullimin e log-ve bosh.
  • NĂ« utilitarin tcpdump ka ardhur mundĂ«sia pĂ«r dekodimin e paketave nĂ« ndĂ«rfaqet pfsync.
  • NĂ« utilitarin top Ă«shtĂ« shtuar komanda filtrues "/" pĂ«r tĂ« treguar vetĂ«m proceset ose argumentet qĂ« pĂ«rputhen me vargun e dhĂ«nĂ«.
  • NĂ« unzip Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r arkivat e mbrojtura me fjalĂ«kalim.
  • ËshtĂ« pĂ«rmirĂ«suar mbĂ«shtetja pĂ«r pajisjet. JanĂ« shtuar identifikuesit PCI pĂ«r kontrollet AHCI ASMedia ASM116x dhe kontrollet I2C pĂ«r Intel Gemini Lake. ËshtĂ« realizuar mbĂ«shtetje pĂ«r adaptatorĂ«t e rrjetit Mikrotik 10/25G dhe kartat e wireless Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. ËshtĂ« shtuar njĂ« drejtues i ri igc pĂ«r kontrollet ethernet Intel I225 2.5G/1G/100MB/10MB.
  • Nod Netgraph ng_bridge Ă«shtĂ« adaptuar pĂ«r sistemet SMP. NĂ« nodin ng_nat Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r CGN (Carrier Grade NAT, RFC 6598). ËshtĂ« ofruar mundĂ«sia e zĂ«vendĂ«simit tĂ« nodit ng_source nĂ« çdo pjesĂ« tĂ« rrjetit Netgraph.
  • NĂ« drejtuesin rctl, i pĂ«rdorur pĂ«r kufizimin e burimeve, Ă«shtĂ« shtuar mundĂ«sia e vendosjes sĂ« kufizimit tĂ« konsumit tĂ« burimeve nĂ« vlerĂ«n 0.
  • NĂ« ndĂ«rfaqen vlan Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r sistemin e prioritizimit tĂ« trafikut dhe menaxhimin e kapacitetit ALTQ.
  • NĂ« drejtuesit amdtemp dhe amdsmn Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r CPU-nĂ« Zen 3 "Vermeer" dhe APU-nĂ« Ryzen 4000 (Zen 2, "Renoir").
  • ËshtĂ« pĂ«rditĂ«suar versioni i aplikacioneve tĂ« tjera tĂ« pĂ«rfshira nĂ« sistemin bazĂ«: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Utilitari unzip Ă«shtĂ« sinkronizuar me bazĂ«n e kodit tĂ« NetBSD.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster