Pas pesë muajsh zhvillimi, është përgatitur versioni OpenSSL 3.3.0 me implementimin e protokolleve SSL/TLS dhe algoritmeve të ndryshme të enkriptimit. Mbështetja për OpenSSL 3.3 do të vazhdojë deri në prill 2026. Mbështetja për degët e mëparshme OpenSSL 3.2, 3.1 dhe 3.0 LTS do të zgjasë përkatësisht deri në nëntor 2025, mars 2025 dhe shtator 2026. Kodi i projektit shpërndahet nën licencën Apache 2.0.
Risitë kryesore në OpenSSL 3.3.0:
- ĂshtĂ« vazhduar integrimi i mbĂ«shtetjes pĂ«r protokollin QUIC (RFC 9000), i cili Ă«shtĂ« njĂ« shtresĂ« mbi protokollin UDP dhe pĂ«rdoret si transport nĂ« protokollin HTTP/3. NĂ« versionin e ri:
- ĂshtĂ« shtuar mbĂ«shtetja pĂ«r gjurmimin e lidhjeve QUIC pĂ«rmes mbajtjes sĂ« njĂ« logu diagnostikues nĂ« formatin qlog.
- ĂshtĂ« shtuar mbĂ«shtetja pĂ«r polling nĂ« modalitet jo-bllokues pĂ«r lidhjet QUIC dhe objektet e rrjedhĂ«s.
- ĂshtĂ« implementuar mundĂ«sia e gjenerimit tĂ« optimizuar tĂ« frame-ve tĂ« pĂ«rfundimit tĂ« rrjedhĂ«s pĂ«r lidhjet QUIC.
- ĂshtĂ« ofruar mundĂ«sia pĂ«r tĂ« çaktivizuar pĂ«rpunimin e ngjarjeve QUIC gjatĂ« kryerjes sĂ« thirrjeve ndaj API.
- ĂshtĂ« shtuar mbĂ«shtetja pĂ«r konfigurimin e timeout-it tĂ« pasivitetit pĂ«r QUIC.
- ĂshtĂ« shtuar njĂ« API pĂ«r tĂ« kĂ«rkuar madhĂ«sinĂ« dhe nivelin e mbushjes sĂ« buferit tĂ« shkrimit pĂ«r rrjedhat QUIC.
- Janë implementuar zgjerimet e protokollit të menaxhimit të certifikatave CMP (Certificate Management Protocol), të përcaktuara në specifikimet RFC 9480 (përcaktimi i protokollit CMPv3) dhe RFC 9483 (profil i lehtë për pajisje me fuqi të kufizuar).
- ĂshtĂ« shtuar mundĂ«sia pĂ«r tĂ« çaktivizuar pĂ«rdorimin e funksionit atexit nĂ« fazĂ«n e kompilimit.
- ĂshtĂ« shtuar njĂ« variant i API-sĂ« SSL_SESSION qĂ« nuk preket nga problemi i vitit 2038: janĂ« shtuar funksionet SSL_SESSION_get_time_ex() dhe SSL_SESSION_set_time_ex(), tĂ« cilat pĂ«rdorin tipin 64-bitĂ«sh time_t nĂ« sistemet 32-bitĂ«she.
- Në funksionin EVP_PKEY_fromdata është implementuar mundësia për marrjen automatike të parametrave të Teoremës Kineze të Mbetjeve (CRT, Chinese Remainder Theorem).
- ĂshtĂ« shtuar mundĂ«sia pĂ«r tĂ« injoruar emrat e panjohur tĂ« algoritmeve tĂ« nĂ«nshkrimit, tĂ« pĂ«rcaktuar nĂ« parametrat e konfigurimit TLS SignatureAlgorithms dhe ClientSignatureAlgorithms.
- ĂshtĂ« shtuar mundĂ«sia pĂ«r tĂ« konfiguruar pĂ«rdorimin me pĂ«rparĂ«si tĂ« çelĂ«save PSK nĂ« server TLS 1.3 gjatĂ« rikthimit tĂ« sesionit.
- ĂshtĂ« shtuar funksioni EVP_DigestSqueeze(), i cili lejon zvogĂ«limin e madhĂ«sisĂ« sĂ« hash-it SHAKE (heqjen e biteve mĂ« tĂ« larta), duke pĂ«rdorur disa iteracione me madhĂ«si tĂ« ndryshme tĂ« daljes.
- ĂshtĂ« shtuar mbĂ«shtetja pĂ«r eksportimin e skedarĂ«ve tĂ« build-it pĂ«r CMake nĂ« sistemet e ngjashme me Unix dhe Windows (pĂ«rveç eksportit tĂ« bazuar nĂ« pkg-config).
- JanĂ« bĂ«rĂ« optimizime tĂ« performancĂ«s: ĂshtĂ« optimizuar funksionimi i algoritmit AES-GCM nĂ« pajisjet me çipat Microsoft Azure Cobalt 100. NĂ« implementimin e AES-CTR Ă«shtĂ« shtuar mbĂ«shtetja pĂ«r pĂ«rshpejtim duke pĂ«rdorur zgjerimet ARM Neoverse V1 dhe V2. JanĂ« aktivizuar optimizimet AES dhe SHA3 pĂ«r sistemet Apple me çipat M3. NĂ« funksione tĂ« ndryshme kriptografike janĂ« pĂ«rdorur zgjerimet vektoriale RISC-V. ĂshtĂ« shtuar implementimi nĂ« assembler i md5 pĂ«r CPU Loongarch64.
Burimi: opennet.ru
