Publikimi i bibliotekës kriptografike OpenSSL 3.3.0

Pas pesë muajsh zhvillimi, është përgatitur versioni OpenSSL 3.3.0 me implementimin e protokolleve SSL/TLS dhe algoritmeve të ndryshme të enkriptimit. Mbështetja për OpenSSL 3.3 do të vazhdojë deri në prill 2026. Mbështetja për degët e mëparshme OpenSSL 3.2, 3.1 dhe 3.0 LTS do të zgjasë përkatësisht deri në nëntor 2025, mars 2025 dhe shtator 2026. Kodi i projektit shpërndahet nën licencën Apache 2.0.

Risitë kryesore në OpenSSL 3.3.0:

  • ËshtĂ« vazhduar integrimi i mbĂ«shtetjes pĂ«r protokollin QUIC (RFC 9000), i cili Ă«shtĂ« njĂ« shtresĂ« mbi protokollin UDP dhe pĂ«rdoret si transport nĂ« protokollin HTTP/3. NĂ« versionin e ri:
    • ËshtĂ« shtuar mbĂ«shtetja pĂ«r gjurmimin e lidhjeve QUIC pĂ«rmes mbajtjes sĂ« njĂ« logu diagnostikues nĂ« formatin qlog.
    • ËshtĂ« shtuar mbĂ«shtetja pĂ«r polling nĂ« modalitet jo-bllokues pĂ«r lidhjet QUIC dhe objektet e rrjedhĂ«s.
    • ËshtĂ« implementuar mundĂ«sia e gjenerimit tĂ« optimizuar tĂ« frame-ve tĂ« pĂ«rfundimit tĂ« rrjedhĂ«s pĂ«r lidhjet QUIC.
    • ËshtĂ« ofruar mundĂ«sia pĂ«r tĂ« çaktivizuar pĂ«rpunimin e ngjarjeve QUIC gjatĂ« kryerjes sĂ« thirrjeve ndaj API.
    • ËshtĂ« shtuar mbĂ«shtetja pĂ«r konfigurimin e timeout-it tĂ« pasivitetit pĂ«r QUIC.
    • ËshtĂ« shtuar njĂ« API pĂ«r tĂ« kĂ«rkuar madhĂ«sinĂ« dhe nivelin e mbushjes sĂ« buferit tĂ« shkrimit pĂ«r rrjedhat QUIC.
  • JanĂ« implementuar zgjerimet e protokollit tĂ« menaxhimit tĂ« certifikatave CMP (Certificate Management Protocol), tĂ« pĂ«rcaktuara nĂ« specifikimet RFC 9480 (pĂ«rcaktimi i protokollit CMPv3) dhe RFC 9483 (profil i lehtĂ« pĂ«r pajisje me fuqi tĂ« kufizuar).
  • ËshtĂ« shtuar mundĂ«sia pĂ«r tĂ« çaktivizuar pĂ«rdorimin e funksionit atexit nĂ« fazĂ«n e kompilimit.
  • ËshtĂ« shtuar njĂ« variant i API-sĂ« SSL_SESSION qĂ« nuk preket nga problemi i vitit 2038: janĂ« shtuar funksionet SSL_SESSION_get_time_ex() dhe SSL_SESSION_set_time_ex(), tĂ« cilat pĂ«rdorin tipin 64-bitĂ«sh time_t nĂ« sistemet 32-bitĂ«she.
  • NĂ« funksionin EVP_PKEY_fromdata Ă«shtĂ« implementuar mundĂ«sia pĂ«r marrjen automatike tĂ« parametrave tĂ« TeoremĂ«s Kineze tĂ« Mbetjeve (CRT, Chinese Remainder Theorem).
  • ËshtĂ« shtuar mundĂ«sia pĂ«r tĂ« injoruar emrat e panjohur tĂ« algoritmeve tĂ« nĂ«nshkrimit, tĂ« pĂ«rcaktuar nĂ« parametrat e konfigurimit TLS SignatureAlgorithms dhe ClientSignatureAlgorithms.
  • ËshtĂ« shtuar mundĂ«sia pĂ«r tĂ« konfiguruar pĂ«rdorimin me pĂ«rparĂ«si tĂ« çelĂ«save PSK nĂ« server TLS 1.3 gjatĂ« rikthimit tĂ« sesionit.
  • ËshtĂ« shtuar funksioni EVP_DigestSqueeze(), i cili lejon zvogĂ«limin e madhĂ«sisĂ« sĂ« hash-it SHAKE (heqjen e biteve mĂ« tĂ« larta), duke pĂ«rdorur disa iteracione me madhĂ«si tĂ« ndryshme tĂ« daljes.
  • ËshtĂ« shtuar mbĂ«shtetja pĂ«r eksportimin e skedarĂ«ve tĂ« build-it pĂ«r CMake nĂ« sistemet e ngjashme me Unix dhe Windows (pĂ«rveç eksportit tĂ« bazuar nĂ« pkg-config).
  • JanĂ« bĂ«rĂ« optimizime tĂ« performancĂ«s: ËshtĂ« optimizuar funksionimi i algoritmit AES-GCM nĂ« pajisjet me çipat Microsoft Azure Cobalt 100. NĂ« implementimin e AES-CTR Ă«shtĂ« shtuar mbĂ«shtetja pĂ«r pĂ«rshpejtim duke pĂ«rdorur zgjerimet ARM Neoverse V1 dhe V2. JanĂ« aktivizuar optimizimet AES dhe SHA3 pĂ«r sistemet Apple me çipat M3. NĂ« funksione tĂ« ndryshme kriptografike janĂ« pĂ«rdorur zgjerimet vektoriale RISC-V. ËshtĂ« shtuar implementimi nĂ« assembler i md5 pĂ«r CPU Loongarch64.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster