Lëshimi i bibliotekës kriptografike OpenSSL 4.0.0

U publikua biblioteka OpenSSL 4.0.0, e cila ofron implementimin e protokolleve TLS dhe algoritmeve të ndryshëm të enkriptimit. OpenSSL 4.0 është klasifikuar si një version me mbështetje të zakonshme, ku përditësimet publikohen për një periudhë prej 13 muajsh. Mbështetje për deget e mëparshme OpenSSL 3.6, 3.5 LTS, 3.4 dhe 3.0 LTS do të vazhdojë deri në nëntor 2026, prill 2030, tetor 2026 dhe shtator 2026 përkatësisht. Kodi i projektit shpërndahet nën licencën Apache 2.0.

Novitetet kryesore:

  • Shtuar mbĂ«shtetje pĂ«r zgjerimin TLS ECH (Encrypted ClientHello, RFC 9849), i cili Ă«shtĂ« i dizajnuar pĂ«r tĂ« enkriptuar informacionin mbi parametrit e seancave TLS, siç Ă«shtĂ« emri i kĂ«rkuar i domain-it. Ndryshe nga zgjerimi ESNI (Encrypted Server Name Indication), nĂ« ECH nuk enkriptohen vetĂ«m fushat e veçanta, por e tĂ«rĂ« mesazhi TLS ClientHello enkriptohet, gjĂ« qĂ« lejon bllokimin e rrjedhjeve pĂ«rmes fushave qĂ« nuk mbulohen nga ESNI, si pĂ«r shembull fusha PSK (Pre-Shared Key).
  • Shtuar mbĂ«shtetje pĂ«r algoritme tĂ« caktuara nĂ« RFC 8998 qĂ« pĂ«rdorin njĂ« grup standardizimi tĂ« algoritmeve tĂ« kriptografisĂ« SM2 tĂ« miratuar nĂ« KinĂ«: algoritmi i krijimit tĂ« nĂ«nshkrimit digjital sm2sig_sm3, grupi i shkĂ«mbimit tĂ« çelĂ«save curveSM2 dhe grupi post-kvantar curveSM2MLKEM768.
  • Shtuar funksioni kriptografik i heshit cSHAKE, i bazuar nĂ« algoritmin SHA-3, i cili lejon krijimin e hash-eve tĂ« ndryshme mbi tĂ« njĂ«jtat tĂ« dhĂ«na hyrĂ«se pĂ«r tĂ« parandaluar sulmet qĂ« manipullojnĂ« riciklimin e tĂ« dhĂ«nave.
  • Shtuar algoritmi hibrid "ML-DSA-MU", qĂ« kombinon algoritmin post-kvantar tĂ« krijimit tĂ« nĂ«nshkrimit ML-DSA (CRYSTALS-Dilithium) me funksionin klasik tĂ« heshit SHAKE256.
  • Shtuar mbĂ«shtetje pĂ«r funksionet e krijimit tĂ« çelĂ«save SNMP KDF tĂ« bazuara nĂ« HMAC-SHA dhe SRTP KDF tĂ« bazuara nĂ« AES-CM, tĂ« cilat pĂ«rdoren nĂ« protokollat rrjetore SNMPv3 dhe SRTP pĂ«r krijimin e çelĂ«save kriptografikĂ«.
  • NĂ« komandĂ«n "openssl fipsinstall" Ă«shtĂ« shtuar opsioni "-defer_tests", qĂ« lejon shtyrjen e ekzekutimit tĂ« testeve gjatĂ« instalimit tĂ« moduleve FIPS.
  • PĂ«r platformĂ«n Windows Ă«shtĂ« realizuar mbĂ«shtetje pĂ«r pĂ«rdorimin e lidhjes statike ose dinamike me Visual C++ Runtime.
  • NĂ« TLS 1.2 Ă«shtĂ« shtuar mbĂ«shtetje pĂ«r negociatĂ«n e shkĂ«mbimit tĂ« çelĂ«save tĂ« bazuar nĂ« algoritmin FFDHE, qĂ« i pĂ«rgjigjet RFC 7919.
  • ËshtĂ« ndalur mbĂ«shtetja pĂ«r SSLv3 dhe SSLv2 Client Hello.
  • ËshtĂ« hequr mbĂ«shtetja pĂ«r motorĂ«t e ngarkueshĂ«m dinamikisht, nĂ« vend tĂ« tĂ« cilĂ«ve pĂ«r t'u zgjeruar funksionaliteti i OpenSSL duhet tĂ« pĂ«rdoret koncepti i ofruesve tĂ« tĂ«rheqshĂ«m.
  • NĂ« TLS, mbĂ«shtetja pĂ«r kurba eliptike tĂ« kaluara Ă«shtĂ« çaktivizuar nĂ« fazĂ«n e kompilimit. Mund tĂ« pĂ«rdoret opsioni «enable-tls-deprecated-ec» pĂ«r rikthim.
  • U shua utilita c_rehash, e cila tani zĂ«vendĂ«sohet me komandĂ«n «openssl rehash».
  • Opsioni i vjetĂ«r «msie-hack» Ă«shtĂ« fshirĂ« nga komandĂ«s «openssl ca».
  • MbĂ«shtetja pĂ«r metodat e pronarit EVP_CIPHER, EVP_MD, EVP_PKEY dhe EVP_PKEY_ASN1 Ă«shtĂ« hequr.
  • JanĂ« hequr funksionet e vjetra SSL/TLS qĂ« ishin tĂ« lidhura me versionet fikse tĂ« protokolleve, siç Ă«shtĂ« «TLSv1_client_method()».
  • Funksionet e vjetra ERR_get_state(), ERR_remove_state() dhe ERR_remove_thread_state() janĂ« hequr.
  • MbĂ«shtetja pĂ«r platformat e synuara darwin-i386{,-cc} dhe darwin-ppc{,64}{,-cc} Ă«shtĂ« ndĂ«rprerĂ«.

Burimi: opennet.ru

Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS đŸ”„ Blini hosting tĂ« besueshĂ«m pĂ«r faqe interneti me mbrojtje nga DDoS, serverĂ« VPS VDS | ProHoster