{"id":111034,"date":"2023-10-22T09:10:35","date_gmt":"2023-10-22T07:10:35","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3"},"modified":"2023-10-22T09:10:35","modified_gmt":"2023-10-22T07:10:35","slug":"opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","status":"publish","type":"post","link":"https:\/\/prohoster.info\/sq\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","title":{"rendered":"Ofruar biblioteka nghttp3 1.0 me implementimin e protokollit HTTP\/3","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Nd\u00ebrmarrja e par\u00eb e stabilizuar e projektit nghttp3, q\u00eb zhvillon nj\u00eb bibliotek\u00eb n\u00eb gjuh\u00ebn C me implementimin e protokollit HTTP\/3. Nj\u00eb variant i zhvilluar nga i nj\u00ebjti projekt p\u00ebr protokollin HTTP\/2 p\u00ebrdoret si baza e modulit mod_http2, q\u00eb p\u00ebrfshihet n\u00eb serverin http Apache. Progreset e projektit jan\u00eb po ashtu t\u00eb angazhuara n\u00eb utilitarin Curl. Kodi i bibliotek\u00ebs shp\u00ebrndahet n\u00ebn licenc\u00ebn MIT.    <\/p>\n<p>Standardi HTTP\/3 p\u00ebrcakton p\u00ebrdorimin e protokollit QUIC (Quick UDP Internet Connections) si transport p\u00ebr HTTP\/2. QUIC \u00ebsht\u00eb nj\u00eb shtes\u00eb mbi protokollin UDP, e cila mb\u00ebshtet shum\u00ebfishimin e disa lidhjeve dhe ofron metodat e enkriptimit, ekuivalente me TLS\/SSL. Protokolli u krijua n\u00eb vitin 2013 nga Google si nj\u00eb alternativ\u00eb ndaj lidhjes TCP+TLS p\u00ebr Web-in, q\u00eb zgjidh problemet me koh\u00ebn e gjat\u00eb t\u00eb instalimit dhe negocimit t\u00eb lidhjeve n\u00eb TCP dhe eliminoi vonesat gjat\u00eb humbjes s\u00eb paketave gjat\u00eb transferimit t\u00eb t\u00eb dh\u00ebnave.           <\/p>\n<p>N\u00eb nghttp3 ofrohet nj\u00eb implementim t\u00eb pavarur t\u00eb specifikimeve RFC 9114 (HTTP\/3 mbi protokollin QUIC), RFC 920 (teknologjia e tkurrjes s\u00eb titujve QPACK), RFC 9220 (d\u00ebrgimi i WebSockets mbi HTTP\/3) dhe RFC 9218 (nj\u00eb skem\u00eb e zgjerueshme p\u00ebr menaxhimin e p\u00ebrpar\u00ebsive n\u00eb d\u00ebrgimin e p\u00ebrgjigjeve n\u00eb k\u00ebrkesat e klient\u00ebve). Biblioteka nuk varet nga grupe t\u00eb caktuara QUIC dhe mb\u00ebshtet pun\u00ebn mbi realizime t\u00eb ndryshme t\u00eb protokollit t\u00eb transportit QUIC. N\u00eb t\u00eb nj\u00ebjt\u00ebn koh\u00eb, projekti zhvillon nj\u00eb implementim t\u00eb vetin t\u00eb protokollit QUIC \u2014 ngtcp2, e cila p\u00ebrdoret nga ana e parazgjedhur. Si backend p\u00ebr enkriptimin e t\u00eb dh\u00ebnave n\u00eb ngtcp2 mb\u00ebshteten quictls, GnuTLS, BoringSSL, Picotls dhe wolfSSL. N\u00eb t\u00eb nj\u00ebjt\u00ebn koh\u00eb me nghttp3 1.0, \u00ebsht\u00eb publikuar edhe l\u00ebshimi i par\u00eb stabil i ngtcp2 1.0.<br \/>\n<br \/>Burimi: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=59973\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3. \u0420\u0430\u0437\u0432\u0438\u0432\u0430\u0435\u043c\u044b\u0439 \u0442\u0435\u043c \u0436\u0435 \u043f\u0440\u043e\u0435\u043a\u0442\u043e\u043c \u0432\u0430\u0440\u0438\u0430\u043d\u0442 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0434\u043b\u044f \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/2 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u0443\u0435\u0442\u0441\u044f \u0432 \u043a\u0430\u0447\u0435\u0441\u0442\u0432\u0435 \u043e\u0441\u043d\u043e\u0432\u044b \u043c\u043e\u0434\u0443\u043b\u044f mod_http2, \u0432\u0445\u043e\u0434\u044f\u0449\u0435\u0433\u043e \u0432 \u0441\u043e\u0441\u0442\u0430\u0432 http-\u0441\u0435\u0440\u0432\u0435\u0440\u0430 Apache. \u041d\u0430\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 \u0442\u0430\u043a\u0436\u0435 \u0437\u0430\u0434\u0435\u0439\u0441\u0442\u0432\u043e\u0432\u0430\u043d\u044b \u0432 \u0443\u0442\u0438\u043b\u0438\u0442\u0435 Curl. \u041a\u043e\u0434 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 \u0440\u0430\u0441\u043f\u0440\u043e\u0441\u0442\u0440\u0430\u043d\u044f\u0435\u0442\u0441\u044f \u043f\u043e\u0434 \u043b\u0438\u0446\u0435\u043d\u0437\u0438\u0435\u0439 MIT. \u0421\u0442\u0430\u043d\u0434\u0430\u0440\u0442 HTTP\/3 \u043e\u043f\u0440\u0435\u0434\u0435\u043b\u044f\u0435\u0442 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u043d\u0438\u0435 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC (Quick [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111034","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.2 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/sq\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.2\" \/>\n\t\t<meta property=\"og:locale\" content=\"sq_AL\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/sq\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-10-22T07:10:35+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Biblioteka nghttp3 1.0 me implementimin e protokollit HTTP\/3 \u00ebsht\u00eb publikuar | ProHoster","description":"Nd\u00ebrmarrja e par\u00eb e stabilizuar e projektit nghttp3, q\u00eb zhvillon nj\u00eb bibliotek\u00eb n\u00eb gjuh\u00ebn C me implementimin e protokollit HTTP\/3.","canonical_url":"https:\/\/prohoster.info\/sq\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"sq_AL","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u041e\u043f\u0443\u0431\u043b\u0438\u043a\u043e\u0432\u0430\u043d\u0430 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0430 nghttp3 1.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3 | ProHoster","og:description":"\u0414\u043e\u0441\u0442\u0443\u043f\u0435\u043d \u043f\u0435\u0440\u0432\u044b\u0439 \u0441\u0442\u0430\u0431\u0438\u043b\u044c\u043d\u044b\u0439 \u0440\u0435\u043b\u0438\u0437 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 nghttp3, \u0440\u0430\u0437\u0432\u0438\u0432\u0430\u044e\u0449\u0435\u0433\u043e \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0443 \u043d\u0430 \u044f\u0437\u044b\u043a\u0435 \u0421\u0438 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 HTTP\/3.","og:url":"https:\/\/prohoster.info\/sq\/blog\/news\/opublikovana-biblioteka-nghttp3-1-0-s-realizacziej-protokola-http-3","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-10-22T07:10:35+00:00","article:modified_time":"2023-10-22T07:10:35+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/posts\/111034","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/comments?post=111034"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/posts\/111034\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/media?parent=111034"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/categories?post=111034"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/sq\/wp-json\/wp\/v2\/tags?post=111034"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}