Det har presenterats en utgÄva av det fria plattformsoberoende UNIX-liknande operativsystemet OpenBSD 6.9. Det Àr vÀrt att notera att detta Àr den 50:e utgÄvan av projektet, som fyller 26 Är i Är. OpenBSD-projektet grundades av Theo de Raadt Är 1995 efter en konflikt med utvecklarna av NetBSD, vilket ledde till att Theo fick begrÀnsad tillgÄng till CVS-repositoriet för NetBSD. DÀrefter skapade Theo de Raadt tillsammans med en grupp likasinnade en ny öppen operativsystem baserat pÄ kÀllkoden frÄn NetBSD, dÀr de frÀmsta mÄlen för utvecklingen blev portabilitet (stöd för 13 hÄrdvaruplattformar), standardisering, korrekt funktionalitet, aktiv sÀkerhet och integrerade kryptografiska verktyg. Den fullstÀndiga installations-ISO-avbildningen av OpenBSD 6.9:s grundsystem Àr 544 MB.
Förutom sjĂ€lva operativsystemet Ă€r projektet OpenBSD kĂ€nt för sina komponenter, som har spridit sig till andra system och visat sig vara en av de mest sĂ€kra och kvalitativa lösningarna. Bland dessa finns: LibreSSL (en fork av OpenSSL), OpenSSH, paketfiltren PF, routingdemoner OpenBGPD och OpenOSPFD, NTP-servern OpenNTPD, postservern OpenSMTPD, terminalmultiplexern (motsvarigheten till GNU screen) tmux, identd-demonen med implementation av IDENT-protokollet, BSDL-alternativet till GNU groff â mandoc, protokollet för att skapa redundanta system CARP (Common Address Redundancy Protocol), en lĂ€ttvikts http-server, och filsynkroniseringsverktyget OpenRSYNC.
Huvudsakliga förbÀttringar:
- I softraid-drivrutinen har RAID1C-lÀget lagts till med programmatiskt RAID1 och datakryptering.
- TvĂ„ nya bakgrundsprocesser har lagts till â dhcpleased och resolvd, som arbetar tillsammans med slaacd och unwind för automatisk konfiguration av nĂ€tverksgrĂ€nssnitt och namngivning i DNS. I dhcpleased har protokollet DHCP implementerats för att erhĂ„lla IP-adresser, och i resolvd hanteras innehĂ„llet i resolv.conf baserat pĂ„ namnservrar mottagna frĂ„n dhcpleased, slaacd och drivrutiner som umb.
- Inledande stöd för Apple-enheter med M1-processor har lagts till. Detta inkluderar igenkÀnning av Apple Icestorm/Firestorm arm64-kÀrnor och stöd för BCM4378 trÄdlösa chip som anvÀnds i Apple M1 SoC.
- Stödet för plattformen powerpc64, som utvecklas för 64-bitarsystem baserade pÄ POWER8 och POWER9-processorer, har förbÀttrats. JÀmfört med den tidigare utgÄvan har powerpc64 stöd för skyddsmekanismen RETGUARD lagts till, en astfb-drivrutin för Aspeed BMC framebuffer har lagts till, problem med radeondrm och amdgpu-drivrutiner pÄ system med AMD GPU har lösts, nÀtverksstart har lagts till för ramdisk-kÀrnbygget, stöd för energibesparande lÀgen för CPU POWER9 har lagts till och stöd för undantag som genereras vid flyttalsoperationer har implementerats, samt IPMI-stöd för PowerNV-system.
- För ARM64-plattformar har stöd för CPU Cortex-A78AE, Cortex-X1 och Neoverse V1 införts, med optimerade ARM64-anrop för copyin, copyout och kcopy, en cryptox-drivrutin har lagts till för stöd av ARMv8-kryptoerweiterungen och en smmu-drivrutin för RM System MMU med stöd för Guard Page. Stöd för Raspberry Pi, Rock Pi N10, NanoPi och Pinebook Pro har förbÀttrats.
- I video-drivrutinen har sysctl-parametern kern.video.record lagts till, som liknar kern.audio.record och kontrollerar aktiveringen av tom bildutmatning vid försök att fÄnga video (för att fÄnga video krÀvs att vÀrdet Àndras till 1). Processer tillÄts att öppna videoenheten flera gÄnger (löser problem med anvÀndning av webbkamera i Firefox och BigBlueButton).
- SpĂ„rpunkter för anrop av malloc och free har lagts till, vilket gör det möjligt att spĂ„ra minnesallokeringsaktivitet med hjĂ€lp av dt och btrace. I btrace har alternativet â-nâ lagts till för att parsa programmet utan att utföra nĂ„gra Ă„tgĂ€rder.
- Stödet för multiprocessorsystem (SMP) har förbÀttrats. Implementeringen av UNIX-sockets har tagits bort frÄn den gemensamma kÀrnlÄsningen, en gemensam mutex har lagts till för att serialisera operationer med msgbuf, och anropet uvm_pagealloc har gjorts mp-sÀkert, medan anropen getppid och sendsyslog har rensats frÄn lÄsningar.
- Problem i DRM-komponenter (Direct Rendering Manager) har ÄtgÀrdats, inklusive krascher i radeondrm-drivrutinen pÄ Powerbook5/6 och RV350-system, stöd för DRI3 har införts i amdgpu- och ati-drivrutiner, och enhetsskapande i katalogen /dev/dri/ har genomförts för kompatibilitet med Linux.
- FörbÀttringar har gjorts i hypervisorn VMM. I backend för virtualiseringshantering har stöd för att starta frÄn komprimerade RAM-disken infört.
- FörbÀttringar har gjorts i ljudsystemet. Möjlighet till separat tilldelning av ljudenheter för sndio endast för uppspelning och endast för inspelning har tillhandahÄllits. I sndiod har en Ättaports lÄgpassfilter med slutlig impulsrespons (FIR-filter) aktiverats, vilket eliminerade störningar frÄn överlappande spektra vid resampling. Som standard har funktionen för automatisk volymreduktion nÀr ett nytt program börjar spela (autovolume) inaktiverats, och standardvolymnivÄn har satts till 127. Blanda ljud frÄn alternativa enheter med olika nivÄer av sndiod-funktionalitet har tillÄtits.
- StandardmÀssigt aktiveras LLDB-debuggerns kompilering och installation.
- Stöd för logger-hanteraren har lagts till i rcctl, rc.subr och rc.d, vilket möjliggör loggutskrift frÄn bakgrundsprocesser som skickar data till stdout/stderr.
- För pekskÀrmar har möjlighet till anpassning av knapplayout tillhandahÄllits via wsconsctl. Wscons har förbÀttrat hanteringen av samtidiga beröringar.
- För ARM64-enheter har anvÀndning av APM implementerats för att fÄ data om energiförbrukning och batteriladdning. à tkomstbegrÀnsning för apmd-processen till filsystemet har Ästadkommits genom anropet unveil.
- HÄrdvarustödet har utvidgats. Nya drivrutiner har lagts till: acpige (för hantering av ACPI-hÀndelser, sÄsom tryck pÄ strömbrytaren), pchgpio (för GPIO-kontroller som moderna Intel PCH Àr utrustade med), ujoy (för spelkontroller), uhidpp (för Logitech HID++-enheter). Stöd har lagts till för AMD Vi- och Intel VTD IOMMU-utvidgningar för isolering av PCI-enheter och blockering av obehörig minnesÄtkomst. Stöd för Lynloong LM9002/9003 och LM9013-datorer har lagts till. Stöd för ACPI har lagts till i drivrutinerna pcamux och imxiic.
- Stödet för nÀtverksadaptrar har förbÀttrats: mvpp (SFP+ och 10G för Marvel Armada Ethernet), mvneta (1000base-x och 2500base-x), mvsw (Marvel SOHO-switchar), rge (stöd för Wake on LAN), Netgear ProSecure UTM25. För trÄdlösa drivrutiner har iwm, iwn och athn stöd för RA (802.11n Tx Rate Adaptation) lagts till. Det trÄdlösa systemet har automatiskt valt mellan lÀgena 11a/b/g/n/ac nÀr nÀtverksgrÀnssnittet anvÀnds som Ätkomstpunkt.
- En drivrutin för veb (Virtual Ethernet Bridge) har implementerats i nĂ€tverksstacken. Stöd för övervakningslĂ€ge har implementerats, vilket gör att inkommande paket till nĂ€tverksgrĂ€nssnittet inte skickas till nĂ€tverksstacken för bearbetning, men trafikanalysverktyg som BPF kan tillĂ€mpas pĂ„ dem. En ny typ av nĂ€tverksgrĂ€nssnitt â etherbridge â har lagts till. Kommandot route sourceaddr ger möjlighet till överskrivning av kĂ€lladressen för program, vilket gör att standardalgoritmen för adressval kan kringgĂ„s. IP-adresser Automatisk aktivering av nĂ€tverksgrĂ€nssnitt har sĂ€kerstĂ€llts vid aktivering av autokonfigurationslĂ€get (AUTOCONF4 och AUTOCONF6).
- Installationsprogrammet har implementerat leverans av en komprimerad ram-diskavbildning (bsd.rd) pÄ alla plattformar som stöder sÄdan inladdning.
- Genom syslog har en varning för anvÀndning av formatstrÀngsplatshÄllaren "%n" i printf implementerats.
- Demonen för routing OpenBGPD har fÄtt stöd för RTR-protokollet (Resource Public Key Infrastructure (RPKI) till Router Protocol). En ny kommandon "bgpctl show rtr" har lagts till för att visa grundlÀggande information om RTR-sessioner.
- Koden för ospfd och ospf6d har omstrukturerats för att harmonisera med andra routingdemoner och förenkla underhÄllet. Stöd för nÀtverksgrÀnssnitt i punkt-till-punkt-lÀge har implementerats.
- Den inbyggda HTTP-servern httpd har fÄtt nya alternativ "location (found|notfound)" för att kontrollera existensen av resurser.
- I verktyget rpki-client har stöd för RRDP-protokollet (The RPKI Repository Delta Protocol, RFC 8182) lagts till. Möjlighet att ange mer Àn en URI i TAL-filen har implementerats.
- I verktyget dig har stöd för RFC 8914 (Extended DNS Error) och RFC 8976 (ZONEMD) lagts till.
- I dhclient har möjligheten att specificera alternativ i hostname.if-filer lagts till med hjÀlp av strÀngar "dhcp".
- I snmpd-demonen har fullstÀndigt stöd för konvertering av Trapv1 till Trapv2 (RFC 3584) implementerats. Nya nyckelord read, write och notify har lagts till i snmpd.conf. Stöd för SMI-upprÀkningar har lagts till i snmp-verktyget.
- I DNS-resolvern unwind har stöd för DNS64 och möjligheten att ta emot anslutningar via TCP-port lagts till.
- I verktyget ftp har stöd för bestÀndiga omdirigeringar (RFC 7538) och förmÄgan att skicka rubriken If-Modified-Since nÀr man skickar HTTP/HTTPS-förfrÄgningar lagts till.
- I OpenSMTPD har ett alternativ "-a" lagts till för att utföra autentisering innan meddelandet skickas. Kryptering har övergÄtt till att anvÀnda biblioteken libtls. I de lyssnande socketarna för TLS har möjligheten att konfigurera flera certifikat som vÀljs baserat pÄ namn (SNI) implementerats. domÀn (SNI).
- I LibreSSL har stöd för protokollet DTLSv1.2 lagts till. Möjlighet att bygga endast libtls ('âenable-libtls-only') utan libcrypto och libssl har implementerats.
- Paketet OpenSSH har uppdaterats. En detaljerad översikt över förbÀttringar kan ses hÀr: OpenSSH 8.5, OpenSSH 8.6.
- Antalet portar för arkitekturen AMD64 var 11310, för aarch64 â 10943, för i386 â 10468. Bland versionerna av applikationerna i portarna: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE-applikationer 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 och ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.
Komponenterna frÄn tredjepartsutvecklare som ingÄr i OpenBSD 6.9 har uppdaterats:
- Grafikstacken Xenocara baserad pÄ X.Org 7.7 med xserver 1.20.10 + patchar, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
- LLVM/Clang 10.0.1 (+ patchar)
- GCC 4.2.1 (+ patchar) och 3.3.6 (+ patchar)
- Perl 5.32.1 (+ patchar)
- NSD 4.3.6
- Unbound 1.13.1
- Ncurses 5.7
- Binutils 2.17 (+ patchar)
- Gdb 6.3 (+ patch)
- Awk 18.12.2020
- Expat 2.2.10
Den nya lÄten "Vetera Novis" slÀpps med versionen OpenBSD 6.9.
KĂ€lla: opennet.ru
